Question about 1993 Chevrolet S-10 Blazer

1 Answer

I have a 93 s10 blazer it is saying high voltage to tps i put a new tps in still no change

Now the idle drops and shuts off when i stop

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 87 Answers

You probably have a short in the wiring to the tps somewhere, trace the wiring

Posted on Jan 17, 2013

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: will not hold idle when in drive or reverse 1991 S10 Blazer

Well Boys
If I tell you how to fix the S10 Problem are you going to send me $10.00Regard.

Regards,

Posted on Nov 28, 2008

  • 18 Answers

SOURCE: trans change

no it will not sorry

Posted on Feb 12, 2009

  • 1 Answer

SOURCE: Car idles high and does not recognize the TPS.

my 1995 camaro just started to idle to high what could it be

Posted on Jul 11, 2009

  • 12 Answers

SOURCE: I change my TPS sensor

The TPS needs to be adjusted to attain the correct idle. Loosen the screws and rotate it slightly forwards or backwards to get the right idle. The correct way is to use a multi-meter and adjust it based on specific resistance. Try the first method to see if this works.

Posted on Mar 03, 2011

  • 1 Answer

SOURCE: 1993 CHEVROLET S10 BLAZER-WHEN DRIVING

My 93 s10 blazer idles really ruff and i
erratically for the first few minutes until it warms up. It now sound like its going to stall every morning I start it up and black soot comes out the tail pipe onto the pavement but only while its idling rough. After i changed the cap and rotor it idled good for a couple days then started doing it again.Already changed the fuel filter and pcv valve. whats the problem?

Posted on Mar 13, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

On my 93 chevy s10 4x4 blazer, my instrument panel worked before new motor was put in, after having the new engine put in, my fuel gauge, oil pressure, voltmeter, rpm, and my temp gauge all quit worki


Look for a missing ground strap from the engine to the body or frame. Remember the engine sits on rubber mounts so that ground strap is essential.

Feb 21, 2014 | Cars & Trucks

1 Answer

Codes are reading low tps voltage, mapps high voltage ignition on low voltage at idle. Idle surges sputers and stalls when driving. Replaceed mapp and tps with no improvment?


Have you consider to check the battery power. I believe the main problem you have is either the battery or the alternator. Due to these two things with low voltage the brain ( ECU ) does not have the enough power to work. Good Luck.

Aug 15, 2012 | 1992 Chevrolet S-10 Blazer

1 Answer

I have a 94 chevy s10 blazer 4x4 with a 4.3 vortec in it the motor is a 93 just put a whole new fuel system in it and new tps senser , mat senser plugs wires everything but my truck is surgeing really bad...


Your distributor internal part has failed, it is the reluctor it shifted and is sending wrong injector signal in the wrong area just replace the whole distributor or take it out open the cap you will see a star shape device that is the reluctor, it shifted you can probably move it and its not suppose to move but because of wear and tear it happened

May 07, 2011 | 1993 Chevrolet S-10 Blazer

1 Answer

I change my TPS sensor now my 93 s10 6 cylinder 4.3 ltr idles high.


The TPS needs to be adjusted to attain the correct idle. Loosen the screws and rotate it slightly forwards or backwards to get the right idle. The correct way is to use a multi-meter and adjust it based on specific resistance. Try the first method to see if this works.

Mar 03, 2011 | Chevrolet S 10 Cars & Trucks

2 Answers

1993 CHEVROLET S10 BLAZER-WHEN DRIVING IDLE IS AT NORMAL SPEED. BUT, WHEN YOU COME TO STOP, IDLE IS HIGH. WHAT IS MY PROBLEM?


My 93 s10 blazer idles really ruff and i
erratically for the first few minutes until it warms up. It now sound like its going to stall every morning I start it up and black soot comes out the tail pipe onto the pavement but only while its idling rough. After i changed the cap and rotor it idled good for a couple days then started doing it again.Already changed the fuel filter and pcv valve. whats the problem?

Dec 28, 2010 | 1993 Chevrolet S-10 Blazer

1 Answer

My 99 blazer s10 wit 4.3 engine at idle lopes or skips changed injectors,fuel pump,tps sensor thermostat,egr is workin,tuned up plugs wires cap rotor,fuel ,air filter, had inte man resealed,brougt it to 2...


replace the electric part of the ignition down on the steering colum ....u will have to drop the steering colum down but not totaly remove...fixed 2 s-10 trucks same year that way

Nov 26, 2010 | 1999 Chevrolet Blazer

3 Answers

I have a 1994 with vortec 4.3 that shakes sometimes


Shakes how? While stopping? Or solely while idle, Engine light on?

If if shakes while stopping you need to check you're wheel hubs and or Suspension ,

Shakes at a light, You may have a bad fuel Injector, Check you're psi in you're fuel pump, A TPS would cause low idle or sometimes high idle, With low idle and a bad motor mount it would shake,

I know theres a few things I'm missing but,.. I have a major Headache atm so I'll get back to you with some more, when i can think better. :)

Sep 08, 2009 | 1994 Chevrolet S-10 Blazer

1 Answer

Will not hold idle when in drive or reverse 1991 S10 Blazer


Well Boys
If I tell you how to fix the S10 Problem are you going to send me $10.00Regard.

Regards,

Nov 27, 2008 | 1991 Chevrolet S-10 Blazer

Not finding what you are looking for?
1993 Chevrolet S-10 Blazer Logo

Related Topics:

105 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8215 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...