Question about Cars & Trucks

Open Question

Buick century with 3.1 idles fine loss power under load blogs down

Posted by Anonymous on

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

dieselpuller
  • 1 Answer

SOURCE: ford f250 2003 super duty diesel 6L - loss of power and idle fluctuates

icp sensor, definitly. you can get to it but you have to go from the bottom. remove the trans filler tube, and lower the the trans slightly, then you can remove the turbo heat shield and get to the sensor, you will need a 1 1/16" 12 point crows foot socket for the sensor its self.

Posted on Apr 03, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hours of reading blogs; none show my symptoms: SAAB 95, 2005 Arc. Hiccup/hesitation/stumble when's engine warm to hot, any speed.


Are you talking about a go-cart, or a motorcycle, or a tractor-trailer 18 wheeler? Then OF COURSE, you must IDENTIFY the MAKE, the MODEL, and the YEAR of whatever vehicle you are asking about, if you want any REAL help!

May 16, 2017 | Cars & Trucks

1 Answer

2001 Buick Century 3.1 liter, has no power when accelarting, slows when going up hill. Starts, and idles fine, have to manuallu make it shift gears by letting up on gas. Could id be the plugs and wires?


this happened to us on vacation. Catalytic coverter was plugged. It did this for a long time before overheating on a road trip. Have someone reputable check it, if it is hesitating a lot.

Dec 31, 2010 | 2001 Buick Century

1 Answer

T reg punto 1.2,idles fine,put it under a load and it runs rough. replaced coils, plugs, its as if something is breaking down under load,any ideas please,thanks gary


poss ECU fault ,common on these, but you need to change both coil packs at same time, programing is easy , fit ecu + coil packs run till rad fan cuts in+out 3 times then hold at 3000 rpm for 30 secs.

Jul 16, 2010 | 1990 Buick Reatta

1 Answer

Fast idle


Sounds like your throttle position sensor is bad.
Take it to Auto Zone and ask them to pull any computer codees that may be latched. Not sll codes trigger the check engine light

Apr 04, 2010 | 1999 Buick Century

2 Answers

Car idles fine but at half throttle and more the


you could have low fuel pressure.your fuel pump out put weak.bad coils causing weak spark or clogged fuel injectors.

Nov 23, 2009 | 1999 Buick Century

1 Answer

Engins starts but idles high for about 2-3 sec. then stalls out


Sounds like the choke needs to be turned down slightly and the idle turned up?

Jul 29, 2009 | 1987 Buick Century

1 Answer

97 buick century sputtering and stalling


He has gotten a bad load of fuel. Try a can of dry gas to emulsify the water, but if there is too much for the dry gas to handle, the tank may have to be cleaned. I would also replace the fuel filter also, the gas may also be dirty enough to restrict the filter.

Jul 10, 2009 | 1997 Buick Century

3 Answers

1998 Buick Century losses significant power at lower speeds


Possibly the EGR valve or TPS sensor if you have CEL codes. Check fuel pressure and if low change fuel filter if it is still low replace the fuel pump I beleive it is suppossed to be 41 to 47 psi. Pretty easy to replace fuel filter the Buick Century has a cover you remove in the trunk to access the fuel pump making the change very easy, if you can fit in the cramped space of the trunk.

Mar 16, 2009 | 1998 Buick Century

1 Answer

1998 buick, century 3.1 will not start..help plz!!!


first you might possibly have a loose main ground wire, check all grounds under hood... if not that, try the alternator... you should be able to find a rebuilt one for not alot of cash...

Jan 14, 2009 | 1997 Buick Century

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

29 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...