Question about 1991 Saturn SL1

1 Answer

Car runs but jumps while driving

I have a 1993 saturn i've replaced the EGR valve spark plugs and wires i also replaced the fuel filter and still have the same problem i don't know what to do can you help?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 743 Answers

Take your coil packs off as well as your module whch is on the bottom of your coil pack (4 bolts 8mm)and take them down to your nearest AutoZone and they will test them for free...one of the coil packs could be bad, but just as well test the module while you are at it.

Posted on Oct 21, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 94 e 150 Ford van is sputtering sometimes Idel and running how can we fix this I have changed spark plugs wires fuel filter dis cap rotor button


did it happend right after you tune it up if not and it was there before check the egr valve try disconecing it then test drive it if it goes away replace your egr valve let me know if it dont work so i can try helping you

Nov 12, 2012 | Cars & Trucks

1 Answer

Erratic Idle - When starts the idle is about 1100 RPM as it warms up, it goes to 700 - 400 RPM


Have you "reset" the computer on the car. When parts are replaced, the comp continues to run the vehicle on all the old settings which can drive you nuts because nothing you do will fix a problem. Usually, taking both battery cables off and waiting for 15 minutes will reset the computer. If this does not do it, then ask a dealer how to reset yours.

Aug 30, 2012 | 1995 Toyota 4Runner

1 Answer

Have a 94 chevy blazer 4x4 with vortec eng. can keep it running it is getting spark and gas will start but only runs for a moment then shuts ofc, i have replaced the starter, plugs wires, cap and roter,...


Sounds like it could be the EGR Valve.If you can drive it and get up to 45-55 mph and it runs smooth then its the EGR valve that is stuck in the open position.I would take the EGR Valve off and clean the carbon out of it using a non-chlronated brake cleaner.

Jan 27, 2012 | Saturn L-Series Cars & Trucks

1 Answer

Lexus LS400 cranks but will not stars


CHECK FOR SPARK AND FUEL.IF ALL IS GOOD A BAD COLD START VALVE WILL CAUSE COLD ENGINE START UP PROBLEMS COLD START VALVE DOES SAME JOB AS ENGINE COOLANT TEMPERATURE SENSOR IT ENRICHEN FUEL SYSTEM FOR COLD START UPS. DO LITTLE TUNE UP MAKE SURE SPARK PLUGS AND WIRES GOOD, REPLACE DISTRIBUTOR CAP AND ROTOR,CHECK IGNITION TIMING, REPLACE AIR FILTER AND FUEL FILTER. IF CAR GETTING FUEL AND SPARK.CAR TIMING BELT COULD HAVE JUMP TIMING IF TIMING BELT NEVER BEEN SERVICED OR REPLACED.

Oct 24, 2011 | 1993 Lexus Ls 400

1 Answer

I have a 1990 mitsubishi might max it wont run smooth unless you keep your foot on the gas and keep the rpms up a little bit and it wont drive cause it stalls everytime you try to move it. ive replaced the...


You've already eliminated the spark plug & wireset, distributor cap & rotor.
Sounds like your car needs a tune-up, specifically, the PCV (positive crankcase ventilation) valve, and/of the EGR (Exhaust Gas Recirculation) valve.

Components checked/replaced during a tune-up are:
air filter
motor oil
motor oil filter
breather filter
fuel filter(s)
fuel strainer
PCV valve
EGR valve
spark plugs
spark plug wires
ECM or distributor cap & rotor
cabin air filter
transmission oil filter
transmission oil
engine coolant
check all vacuum hoses and lines

Troubleshooting the no-start condition - from the 1990 Mitsu Mighty Max Repair Manual:

Priority Action Part Type -- Cause
1 Inspect Battery -- Battery Discharged or Faulty.
2 Inspect Battery Cable -- Corroded, Broken, Shorted or Poorly Connected Battery Cable.
3 Inspect Distributor Cap -- Distributor Cap Cracked or Burned.
3 Inspect Fuel Filter -- Clogged or Dirty Fuel Filter.
5 Inspect Ignition Coil -- Faulty Ignition Coil.
6 Inspect Wireset -- Worn, Damaged or Faulty Spark Plug Wire(s).
7 Inspect Spark Plug -- Incorrectly Gapped or Fouled Spark Plug(s).
8 Inspect Starter -- Starter Motor Faulty.
9 Inspect Fuel Pump -- Low Fuel Pressure.
10 Inspect Solenoid Switch -- Faulty Starter Solenoid Switch.
11 Inspect Fuel Pump Relay -- Faulty Fuel Pump Relay.
12 Inspect Fuel Injector Pressure Regulator -- Faulty Fuel Injector Pressure Regulator.
13 Inspect Ignition Switch -- Improperly Connected or Faulty Ignition Switch.
14 Inspect Starter Drive -- Faulty Starter Drive.
15 Inspect Fuel Injector -- Dirty or Worn Fuel Injectors.
16 Inspect Fuel Pump Strainer -- Clogged or Dirty Fuel Pump Strainerat.
17 Inspect Engine Control Computer -- Incorrect Operating Information Being Delivered and Sent From The EEC.
18 Inspect Fuel Tank -- Fuel Tank Empty.
19 Inspect Carburetor -- Carburetor Flooded or Faulty Choke.
20 Inspect Distributor -- Worn, Loose, or Incorrectly Installed Distributor.

Aug 17, 2011 | 1993 Mitsubishi Mighty Max

1 Answer

When my Altima has been running a while (on frwy) At about 60 -65 MPH The car feels like it jumps. Or wants to switch gears. Then when i come to a stop, such as a red light The car sounds and feels as if...


Sounds like your car needs a tune-up, specifically, the PCV (positive crankcase ventilation) valve, and/of the EGR (Exhaust Gas Recirculation) valve.

Components checked/replaced during a tune-up are:
air filter
motor oil
motor oil filter
breather filter
fuel filter(s)
fuel strainer
PCV valve
EGR valve
spark plugs
spark plug wires
ECM or distributor cap & rotor
cabin air filter
transmission oil filter
transmission oil
engine coolant
check all vacuum hoses and lines

Aug 17, 2011 | 2003 Nissan Altima

1 Answer

Getting a PO300 code, have replaced the crank, MAP sensors, fuel pump and filter and replaced Coil #3 /new Plugs, i am running out of options. Been like this for two weeks and I need a vechile for work.


P0300 Random/Multiple Cylinder Misfire Detected, if your doing the cylinder number 3 the code should have read PO303,, either way, these are some of what needs to be checked A code P0300 may mean that one or more of the following has happened:
  • Faulty spark plugs or wires
  • Faulty coil (pack)
  • Faulty oxygen sensor(s)
  • Faulty fuel injector(s)
  • Burned exhaust valve
  • Faulty catalytic converter(s)
  • Stuck/blocked EGR valve / passages
  • Faulty camshaft position sensor
  • Defective computer
  • If there are symptoms such as the engine is stumbling or hesitating, check all wiring and connectors that lead to the cylinders (i.e. spark plugs). Depending on how long the ignition components have been in the car, it may be a good idea to replace them as part of your regular maintenance schedule. I would suggest spark plugs, spark plug wires, distributor cap, and rotor (if applicable). Otherwise, check the coils (a.k.a. coil packs). In some cases, the catalytic converter has gone bad. If you smell rotten eggs in the exhaust, your cat converter needs to be replaced. I've also heard in other cases the problems were faulty fuel injectors.
    Random misfires that jump around from one cylinder to another (read: P030x codes) also will set a P0300 code. The underlying cause is often a lean fuel condition, which may be due to a vacuum leak in the intake manifold or unmetered air getting past the airflow sensor, or an EGR valve that is stuck open.

Jun 17, 2011 | Chevrolet TrailBlazer EXT Cars & Trucks

1 Answer

My 93 Saturn SL2 intermittent stalling issues


I would look at the egr system. First pull the valve and clean it. If you have a vacuum tester this would be a good time to test the valve itself as well. When under load you should be able to see the diaphragm engage and hold and then release as you release the vacuum. If that doesn't work check and/or replace the egr solenoid. It's located on the driver's side of the valve cover and usually runs about 60$.

Yours is a common complaint and the above is the most common remedy. Outside of that you might want to check and clean the idle air control valve and the port where it's housed. If it is extremely dirty or something managed to get stuck in there that could affect you vehicle running at idle as well.

Another thing, even though you just changed the plugs, pull one back out and look at it. If is fouled with oil you might need a new valve cover gasket which if it's leaking badly enough will impede spark.

Apr 30, 2010 | 1993 Saturn SL2

1 Answer

Engine sputters when accelerating to speed limit and fails to hold it . also loses power climbing hills


Check your EGR valve, IAC valve, fuel pressure regulator, fuel pump, fuel filter, spark plugs and spark plug wires

Jan 02, 2010 | 1993 Ford Escort 4 Door

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

165 people viewed this question

Ask a Question

Usually answered in minutes!

Top Saturn Experts

yadayada
yadayada

Level 3 Expert

61037 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Saturn Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...