Question about 2003 GMC Yukon XL

1 Answer

Engine won't start and instrument cluster don't work at all

Was driving and the instrument cluster quit working then engine shut off

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 73 Answers

Either a ground wire is disconnected somewhere or timing belt broke,does the engine still turn over but not start or do you not have any power at all ?

Posted on Jan 16, 2013

Ad

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 2 Answers

SOURCE: digital instrument cluster

theres a fuse on the back side of these that will somtimes burn out to

Posted on Mar 21, 2009

  • 4088 Answers

SOURCE: Didital Instrument cluster; all guages work except

You might try to find another cluster from a wrecking yard and install it yourself. Otherwise, it sounds like they have you just where they want you. Good luck!

Posted on Apr 13, 2010

  • 867 Answers

SOURCE: tranmission and instrument cluster

The speed sensor on your trans sends a signal to the electronics telling it when to shift, this will be where you fault is.

Posted on Mar 05, 2012

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Engine will start, but all the dash warning lights come on, then the engine shuts off. if i tap under the dashboard on the passenger side before engine shuts off, most the time it will keep running.


Sounds like you have a loose connection in the instrument cluster in the dash. There were a lot of Town & Country owners having engine issues related to a faulty instrument cluster. The security system is connected through that somehow and if it loses power, like it sounds yours does, it would shut the car off even while driving. The fact that you can tap on the dashboard and keep it working leads me to believe it's the instrument cluster.

Oct 14, 2012 | 1999 Chrysler Town & Country

1 Answer

I have a 1996 acura rl and my problem is my remote entry won't work and my cluster light won't shut off and the check engine light came on all at once don't have a clue as to why


remote entry wont work because either remote battery is dead or remote broken.cluster light will stay on if head light stay on could have faulty headlight relay or headlight control unit faulty let dealership check it out.

Sep 09, 2012 | Cars & Trucks

1 Answer

Won't turn over. The instrument cluster won't work


ok iif the instrument cluster does not work.. before i give a solution can you tell me if it have atach and temp gage not a temp gage witha idiot light but a actual temp gage.. because if temp gage and fule gage hands are not in their proper place like if yo uhave a 1/4 tank of gas and it reads way past full and the temp gage is gone out of site way past say 240 degrees then it is your speedo head .. have this trouble the other day on a chevy 2002 cavalier.. replaced the head and wahla the car started. it seems the speedo head is tied in with the computer system on these cars.. and if the tach is not working you need not worry if you cannot find a head with a built in tach.. a normal speedo head with out the tach part will also work.. just when you change the head count the pins on the old one and compare it to the new one if they match then just plug it in and car should start..

May 13, 2012 | 2002 Pontiac Sunfire

1 Answer

No pwer at all going to driving light nor the instrument cluster, starter turns but it won't turn on .and on the fuse block some of the fuses have no power running to them .the fuses are still good


Sounds like you have a power drain (small-amperage short) in the wiring going to your instrument cluster. The short has disabled some of your instrument cluster lights, but, since is has high resistance, it has not blown a fuse (since it draws to few amps). Once the current drain has wasted enough amperage, there's not enough left in the battery to start the car.
Phase 1: Interim solution: (1) charge the battery with your battery charger (if you don't have a battery charger, attach the battery with jumper cables to the battery in a running car - its alternator will charge your battery).
(2) pull the fuse(s) to the instrument cluster, thus killing power to the short.
(3) start and use you car without instrument cluster lights until you can move
to phase 2 of your repair. If you're not sure that you've killed power to the short, disconect the battery each time you stop the engine.
Phase 2:
(1) isolate the problem (the short) to one specific fuse, meaning one specific branch circuit in the car.
(2) trace the wiring from the fuse block to the instrument cluster, looking for
burn marks, bare wires (all wires should be insulated), or anything touching
a frame ground. Also look for moisture iintrusion - water can cause these types of high resistance "shorts" - with the symptom that the problem disappears after the water dries up.
(3) correct wiring problem found in step 2, plug in fuse. done
(4) if replacing instrument cluster, use instructions below.

1995-99 Models

See Figure 4
Fig. 4: Common instrument cluster found in 1995-97 "S" series Pick-ups.
(see illustration at end of message)

1. Disconnect the negative battery cable.
2. Remove the sound insulators/trim panels.
3. If necessary for access, unfasten the steering column nuts and if necessary, the bolts at the lower flange, then lower the column for access.
4. Unfasten the instrument cluster bezel screws located at the lower edge of the bezel. If no screws are present, then remove the bezel by pulling it straight out.
5. Unfasten the four screws retaining the instrument cluster to the instrument panel, unplug any necessary cluster electrical connections, then remove the cluster.

To install.
6. Install the cluster to the instrument panel making sure the cluster is firmly seated onto the connector, attach any necessary electrical connections and tighten the cluster fasteners to 17 inch. lbs. (1.9 Nm).
7. Install the instrument cluster panel bezel by snapping it into position, then if equipped, install the screws along the bottom of the bezel.
8. If lowered, re-position the steering column and tighten retaining nuts to 22 ft. lbs. (30 Nm) on 1995 models. On 1996-99 models tighten the nuts to 20 ft. lbs. (27 Nm). If removed, tighten lower flange bolts to 120 inch lbs. (13 Nm).
9. Install the sound insulators/trim panels.
10. Connect the negative battery cable.

9_30_2011_9_51_04_pm.jpg

Sep 26, 2011 | 1996 Chevrolet Blazer

1 Answer

My 2001 Saturn L200 service light with the wrench keeps coming on. If I drive about 100 miles and park the car when I return to start it that is when the light comes on not while driving. I can not get the...


Service (Wrench) System Check The SERVICE (Wrench) telltale is turned ON by the cluster when it receives a command from the powertrain control module (PCM) or the body control module (BCM). The PCM or BCM will turn the SERVICE (Wrench) telltale ON for all non-emission related diagnostic trouble codes (DTCs) that require that a telltale be turned ON, some DTCs do not turn ON a telltale but are stored to aid in diagnosis.
The SERVICE (Wrench) telltale will also be turned ON if the Antilock Brake System (ABS) control module has detected a fault in its own warning indicator system. If the ABS cannot turn ON its own telltale, a message will be sent to the BCM through the Key Word 2000 data bus to turn ON the SERVICE (Wrench) telltale.
The SERVICE (Wrench) telltale will be turned ON by the cluster for 2-3 seconds, when the ignition is turned to RUN, for a visual system check.

You need to have codes checked .

May 07, 2017 | Saturn L-Series Cars & Trucks

1 Answer

2003 Silverado 4.8 V8. Speedometer and tachometer, as soon as underway, read past maximum. When engine is shut off guages do not return to "0"


Hi Norton,

What has happened is your speedometer and tachometer drive motors are failing inside your silverado instrument cluster. I see this very often in GM trucks, to fix the problem you need to have your instrument cluster rebuilt.

Check out this article that talks more about it http://drspeedometer.com/chevy-silverado-instrument-clusters-why-they-quite-working

Thanks,
Fred

Sep 27, 2010 | Chevrolet Silverado 1500 Cars & Trucks

1 Answer

I have a 2001 Dodge Ram 3500 4X4, w/5 spd tranny. I am having trouble with my HVAC controls (they quit working and only hot air comes out), and also the instrument cluster. Periodically I lose the tach...


tach is most likely a cam sensor, hvac could be a bad vacuum problem (bad hose ) the electrical (dash stuff) I would start looking for a loose or bad ground wire or dirty battery terminals

Sep 04, 2010 | 2001 Dodge Ram Maxi

3 Answers

Gages speedo tac all quit. fuses are good 98 jeep wrangler. did it before but came back on. changed gage cluster still will not work


Have you checked it with a scan tool to be sure it is actually getting the information? The instrument cluster do go out, meaning the ribbon on the back.I would check the connection, then turn to a way to determine if it is recieving a signal from ECM.

Oct 09, 2009 | 1998 Jeep Wrangler

1 Answer

Turn the key on: the instrument cluster and engine don't start


solution???... don't call your mercedes a Huundai Excel... then maybe you'll get results.. .ya think?

Aug 29, 2009 | 1994 Hyundai Excel

Not finding what you are looking for?
2003 GMC Yukon XL Logo

157 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

76132 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...