Question about Rover 75

1 Answer

I have a airlock in my cooling system

The heater is blowing cold and the temperature guage is showing that the car is hot and i keep having to top up the coolant

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Rover Master
  • 22,114 Answers

You havent stated what model here ,think you have more than one problem now if this is the K series petrol engine then dump the car as its not worth repairing .If the older one with the honda engine then this is well worth keeping and repairing

Posted on Jan 17, 2013

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Brian032472
  • 150 Answers

SOURCE: Frequently loss the coolant and

You are losing coolant if you have a coolant pressure tester follow the directions and use it. If you don't when the car is cool use a 50/50 solutuion of water and coolant fill system and check all the listed items carefully with a flash light and look for leaks. It is either a bad hose, cap, water pump or radiator. Your coolant circulates through the dash and the blower blows throught the heater core to produce heat. No coolant no heat. I would also check the passanger side floor for anti freeze or moisture could be a leaking heater core also.

Posted on Nov 02, 2008

chazman05
  • 48 Answers

SOURCE: 1996 ford contour gets hot , no hot heater or temp guage movement

Is your temperature gauge working now? That is of more concern then your heater as you wouldnt know if your engine was overheating until its too late. Your heater core could be clogged, they get clogged quite easily. You can flush them or replace. The part is inexpensive but on some models you have to take out dash to replace them, but on other models it only takes about 30 mins and a few bolts.

Posted on Dec 17, 2008

  • 15 Answers

SOURCE: AIRLOCK IN COOLING SYSTEM

Hi Nizzy . Sorry to tell you but it sounds like your water pump impeller has fallen/broken off . Depending on your engine code it would be better off changing the cambelt and tensioner at the same time . Regards VW Audi tech

Posted on Jan 20, 2009

gordanddar
  • 477 Answers

SOURCE: temp guage showing hot, not getting any heat for 1992 Mercury Cap

If the hoses to and from the heater core are hot , and you say the heater core is hot , then the only answer is that the air duct that flows into or out of the heater core plenum ( housing ) is not opening.
Heater control on dash borad inoperative.
Not sure about 92 capri , some cars have a cable linkage , some work on vacume motors.
Try to find a haynes manual for your car , they will walk you through almost every step of anything you may ever want to do to your car.

You seem to know what you are doing , but I gotta ask ........the heater core you felt was up behind the dash inside the passenger compartment of the car right ?

Posted on May 10, 2009

  • 401 Answers

SOURCE: 2006 Pontiac Torrent heater blowing cold air

hi
check the heater hoses and if both are hot then the mode door is broken
i have replaced 2 in the torrents(not a nice job)

Posted on Jun 21, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I get hot air out of my heater vents


Make sure that the cooling system is completely full. Not just the reservoir but the system itself under the cap that is above the thermostat.. Check is full and then when the system is hot, burp the system to get rid of airlocks by squeezing the two radiator hoses, bottom one first and then the top one. Leave the system to cool and then check the level again.

Jan 02, 2016 | Cars & Trucks

2 Answers

I have a 2000 Dodge Durango. The heater blows cold air, the a/c works fine. I was told this could be a bad fuse.


the thermostat that regulates the water temperature is bad. it is in the open position keeping the water from heating

Oct 01, 2013 | 2000 Dodge Durango

1 Answer

My engine temperature gauge reads hot but heating system is not working. Outside temperature is below zero


It is possible that somehow your heater core is either blocked or airlocked. Best thing to do is to feel the two hoses that go to and from the heater core when the engine is up to normal operating temperature. If one hose is hot and the other is barely warm than you have a blocked up heater core. If you feel both hoses and they are barely warm than it is possible that you have an airlock in the system. The airlock is mostly likely to occur if you have recently had your heating system worked on such as a new radiator, thermastat, etc. If both hoses are hot then it could possibly be the heater blend doors inside the heater box could be stuck in the cold position. They are controlled from the switches on the dash. When you adjust the heat setting on the dial from hot to cold or cold to hot it moves the blend doors to either let more cold air in or more heat in. Hope this was helpful. Happy motoring.

Dec 28, 2010 | 2006 Ford Explorer

2 Answers

Engine temp guage shows cold


Let the truck run for about 15 minutes. If the engine temperature does not come up turn the heater on and check to see if the air coming out is hot or cool. If it is hot the engine's thermostat is operating fine and most likely the problem is with the temperature sending unit for the gauge. If the air is cool the thermostat is stuck open. Try replacing the thermostat if the air is cool.

Jun 05, 2010 | 1996 Isuzu Hombre

2 Answers

Changed the thermostate and drained the radiatior and put new fluids in brought car to running temp but heater still wont blow hot are


Feel of the heater hoses going to the heater core,if they are not getting hot,then remove the heater hoses and flush the heater core out with a water hose.Also be sure to bleed all the air out of the cooling system.

Dec 20, 2009 | 1996 Ford Taurus

1 Answer

1995 GMC suburban temp guage pegs high, but heater


Sounds like there may be an air pocket in the system.
Try 'burping' the system. If this still doesn't fix the problem, check the temperature of the heater core hoses (in and out) The inlet should be fairly cool, the other should be piping hot. If they're both cold; the heater core has an internal blockage.

Next, replace the thermostat with a winter (180-195 F) derivative.
Bleed the system accordingly, and keep me posted!

Nov 30, 2009 | 1990 GMC C2500

2 Answers

New heatercore but no heat flushed system out but still no heat the dash gets hot but very little heat comes out when on for awhile the fan works just blows cold air


Did you run engine from cold, with heater on when you refilled the system? Try again, rad cap off, with heater on, and let engine get up to operating temperature, make sure you have good flow through rad ,leave cap off, until rad fan comes on to cool returning coolant to rad at least twice. Give engine a little extra rev, for 5 seconds or so, every once in a while to make sure flow getting through heater core, and add coolant as necessary. See if that helps, as it may just be an airlock in system. If your cooling system has any bleed screws incorporated, crack them once in a while as well.

Nov 05, 2009 | 2000 Oldsmobile Bravada

1 Answer

1980 mercedes 300cd. The heater blows cold. It has a brand new servo unit. The recirculation pump is works when hot wired. All new hoses and clamps.The vacuum heater valve is operational. I am ready to...


Check you have coolant flow to the heater core - feel the inlet and outlet coolant hose as near as possible to the heater core- they should be both be hot and approx equal in temperature.
If the outlet hose is noticably colder you may have a blocked heater core ( a reverse flush with water from garden hose may fix it).
Check the cooling system has been properly filled, with the heater coolant valve open, bleeding off any airlocks as required.
Check any cold/hot air re-direction vane within the cab heater air ducting is operating properly (not seized or stuck).

Oct 27, 2009 | Mercedes-Benz 300-Class Cars & Trucks

2 Answers

Nissan Altima no cool air blowing or hot air blowing


Hi!
It appears we have an Air lock scenario and you will need to perform a system Bleed.
Park the vehicle on level ground, when cold remove coolant filler cap, start engine and leave to idle, turn heater on full and blower to max. When engine reaches operating temperature watch and listen near coolant filler, keep clear as gurgling and hopefully a boil over should occur. Top up with very warm coolant and wait as it may do it again.
Check for heat inside vehicle if warm replace coolant cap but keep an eye on temperature gauge as the ~Air lock may have moved on from heater matrix/core so proceedure needs to be carried out again from COLD.

Please press the Blue button to appraise my FREE Efforts, Thank You!
Paul 'W' U.K

Feb 24, 2009 | 2002 Nissan Altima

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

95 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rover Experts

yadayada
yadayada

Level 3 Expert

75744 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14333 Answers

Rob
Rob

Level 2 Expert

62 Answers

Are you a Rover Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...