Question about 1995 Ford Mustang

1 Answer

95 mustang won't start,

Checked spark plugs and they are firing, fuel pump working, engine getting fuel, battery is not dead either,blowing out exhaust and air filter checked and working too.

Posted by on

  • Sandra Wilson Jan 15, 2013

    Ok thanks will try these sensors

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 41 Answers

If it's getting fire and fuel would suggest timing issue. Maybe check crank and cam sensors. Getting any check engine light?

Posted on Jan 14, 2013

  • 2 more comments 
  • Sandra Wilson Jan 14, 2013

    No check engine light on

  • Sandra Wilson Jan 14, 2013

    Where r these sensors to check?

  • jim0264
    jim0264 Jan 14, 2013

    Cam sensor is located under hood, center, front engine area below water pump, and mounted on timing cover. Crtank sensoris located below that at the bottom of the block and on the outside and behind the pulley of the crankshaft.

  • jim0264
    jim0264 Jan 14, 2013

    Sorry, outside of cover behind the pulley.

×

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

SOURCE: engine cuts out , does not throw a code

I also have a 2001 Crown Vic that developed a problem similar to this. It would lope and buck at around 40-45 MPH. I too changed the plugs, then changed the coil boots. It still missed. So I bought 1ea. new coil. After changing the new coil with three old ones, the missing stopped.

Posted on Aug 02, 2008

10 Years
  • 60 Answers

SOURCE: engine turns over but will not start

Check the distributor and timing order to make sure it has not jumped at all from a timing malfunction.

Posted on Aug 29, 2009

  • 7353 Answers

SOURCE: i have a 1999 ford escort 2.0 that just quit

Try spraying some carb cleaner in the air intake and see if it tries to run. If it does its a fuel issue. Either you dont have fuel pressure, or the injectors are not opening. What is the fuel pressure? should be approx 40 psi. Does the CK ENG light up when you turn the key on?

Posted on Jan 01, 2010

  • 5501 Answers

SOURCE: 1989 mustang gt 5.0 fuel

Was looking at posts and other sites. I take it that some relays are even under seats. Anyway, Apparently the ECU relay and the ECC relay are linked. When properly operating the ECC brain sends a signal to the ECC relay and the ground wire is tan/green. The brain can be throwing the signal and the relay terminals are not receiving the signals, so the relays cannot switch.

Although you have replaced some relays, you need to check your plugins for these 2 relays.

Posted on Nov 28, 2010

pchambley
  • 334 Answers

SOURCE: i have an 2003 ford expedition that just stopped .

Probably the inertia switch for the fuel pump..You owners manual should show you where its located..See if the button has pop up ..If it has push it back down until it clicks..If it wont stay down then hold it down and see if it will start..If it does you will have to replace it..If thats all good then check the relay for the fuel pump..

Posted on Sep 08, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

92-95 honda civic ex 1.6L vtec won't start! New battery, new main relay. Still no start. As you notice the engine would crank but won't start up. Also the dash lights aren't lighting up either....


Did you get the key switch checked out ? The dash indicator lights have to be on for the engine to start. So you are not getting power to the dash lights, and probably not to the computer or ignition coil either.

Jul 06, 2013 | Cars & Trucks

1 Answer

My 1991 Ford Tempo won't start. It turns over but doesn't spark. The battery has been replace, checked fuel pump and spark plugs but it still won't turn on. Help?


change the ignition pick up coil assembly normally located on the distributor under the rotor on the bottom of the distributor or just replace the distributor

Jan 30, 2013 | 1991 Ford Tempo 4 Door

1 Answer

My 2001 mercury sable has new altinater,battery, and spark plug but won't fire up.What could be the problem?


Are you getting fuel pressure? You have an inertia switch in the trunk and it might need reset(push the red button down). It shuts off the electric fuel pump in case you have an accident or get bumped hard.Sometimes they just actuate for no known reason.
Also crankshaft position sensor could be dead. Have you run the engine codes? don-ohio (:^)

Jan 18, 2013 | 2001 Mercury Sable

1 Answer

Flooding 95 mustang with a 3.8


Well if it is flooding, either something is shorting out the injectors and causing them to be wide open, or one injector is stuck open, or you have a pressure regulator leaking liquid fuel into the intake.
Are all of the spark plugs wet ?
Can you start the engine if you disable the injectors ?

Jan 13, 2013 | 1999 Ford Mustang Cobra

1 Answer

Cranks well but won't start.


Looks like you got spark, and gas in the throttle body made it fire: nice work.
Sounds like your fuel pump is out or the wiring is not turning it on. One way to be sure is to set a spare battery near the tank and hot wire the pump with jumper wires. Or if you have a voltmeter check for voltage at the fuel pump connector while the truck is cranking.. If the pump is working and getting gas to the engine, see if the injectors are pulsing. A good idea to check fuel pressure if the pump is working.

Nov 17, 2012 | 1992 Toyota Pickup

1 Answer

Engine won't start


If you have spark at the right time, compression, and fuel, you should have combustion.
Was it running before you had the work done ?
Is it possible the distributor timing is off ?
You know for sure the plugs are firing, not just the coil ? And the accel pump in the carb is spraying gas ? And the choke is closed ?
A major vac leak like the PCV valve hose or intake gasket could keep it from starting.

Jul 06, 2012 | Dodge Cars & Trucks

1 Answer

Have a 2000 GMC Yukon Denali. Won't fire.


Make sure that the belt isn't extremely tight and they the belt tensioner isn't liked up by pulling in the belt. It should move and spring right back. Make sure engine isn't locked up. And please explain what happen with the vehicle. The fact that you replace plugs and wires and fuel filter for a car that's not turning is throwing me off. So right now we are going all over the place. But definite look at belt and tensioner I've seen a few times that a bad tensioner will make the belt wrap around tighter inhibiting the engine from turning.

Jun 26, 2012 | GMC Yukon Denali Cars & Trucks

1 Answer

1997 mazda 626 won't start.


Are the plugs wet with fuel?
Check for spark. No spark? it may be the ignition module.

Plugs dry and spark present? No fuel?Spray a little starting fluid and see if it will run on that.
Then check pump fuses and for fuel pump noise.

Jun 01, 2017 | 1997 Mazda 626

2 Answers

Cranks over but won't start changed fuel pump but still not starting started once drove it 20 miles and now won't start again


I had a 95 Astro that acted in a similar way. Mine was the fuel pump. I wonder if your ground is loose for the pump circuit or if there is a relay dying on you. Does it act differently with a change from hot to cold weather? A loose ground would do that. You could also have a faulty pump. I heard stories of people getting non-GM approved pumps that failed or had to low a PSI to accurately supply the engine with fuel. Is it getting adequate fuel pressure (50-60 PSI). It should be 60 psi but I was told my 50psi was within GM specs. Mine eventually drank the radiator due to a blown head gasket that no one ever properly diagnosed.

Sep 09, 2011 | 1997 Chevrolet Astro

Not finding what you are looking for?
1995 Ford Mustang Logo

293 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5501 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...