Question about 2006 Kia Picanto 1.1

1 Answer

Where is the horn relay on kia picanto

Horn not working,and imoberliser not working

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 73 Answers

Get a haynes repair manual,most relays are under the hood by the drivers side in a black box

Posted on Jan 14, 2013

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad
  • 333 Answers

SOURCE: horn on kia rio not working

It sound like the horn is the problem. You may need to purchase a new horn located in the front grill somewhere. I hope this helps.

Posted on Feb 06, 2009

catbob007
  • 70 Answers

SOURCE: where is the horn

replace relay

Posted on Jul 27, 2009

  • 417 Answers

SOURCE: The horn stopped working in my 2000 KIA GSX.

The easiest thing to check first is to see if the fuse for the horn relay in the fuse box is blown. Hope this is helpful.

Posted on Apr 19, 2010

  • 128 Answers

SOURCE: 2004 kia sorento, horn not

Check the wiring in the steering wheel. It may of came undone.

Posted on Nov 30, 2010

spyroshima
  • 186 Answers

SOURCE: my kia picanto 2009 horn is going off and on

Remove your horn button & check the clearance between the metal plates/contacts. if they are too close together bend them apart a bit with a thin screwdriver. If you remove the horn button & its connected by a wire, there is a spring at the end of that wire conecting it to the button. It may be coming into contact with another metal part. If none of this applies, check to see if the warranty will get u anew one. This is IF its a mechanical problem. If its an electrical issue, eg. Alarm system, then thats a whole diferent chapter...

Posted on Jan 10, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

2004 Ford F-150 the horn just stopped working. Chk'd fuse all OK. Now what?


Disconnect the horn wiring at the horn. Check for voltage at the horn when the horn 'button' is pushed. If there is voltage at the horn, the problem is the horn has died. Remove and replace. No voltage at the horn is most likely related to the horn 'button' but could be wiring. Could also be corroded connections at the horn wiring.
Just had to replace the horn on a 2011 Chevy.
A 1930 Model A horn still works though.

Sep 16, 2017 | Ford Cars & Trucks

1 Answer

Location horn relay on 82 cj7


The horn relay primary receives + full time and is actuated by receiving ground (-) from the horn button. Check ground continuity at the horn button (at the steering wheel) to make sure it is working first (most likely culprit). If the horn button is working, check to see if the horn relay is working (second most likely culprit). To test the horn relay, provide chassis or battery ground to the (-) primary terminal of the horn relay and see if the horn honks. If it does, that will tell you that the problem is in the wiring between the steering wheel and the relay, most likely a disconnected wire at the steering column.
The only other components in the system are the fuse for the horn circuit (if you have 12v at the horn relay, that is fine), and the horn itself. My bet is on the horn button pad itself.

May 25, 2014 | Jeep CJ7 Cars & Trucks

1 Answer

Jump started tt 02 radio not working all fuses on end of dash look ok no safe mod


should not jump start certain vehicle , may imoberlise e.c.u unit or fry circuits. n/s/r trunk stereo amplifier behind cowling carpets. possibly.

Mar 17, 2013 | 2002 Audi TT

2 Answers

My horn doesent work


WITH KEY ON EVERY THING ELSE OFF PUSH THE HORN YOU SHOULD HEAR A SMALL CLICK THAT THE HORN RELAY IF SO TEST FOR POWER AT THE HORN MAKE SURE IT IS STILL CONNECTED IF POWER IS GOOD REPLACED HORN

Feb 14, 2013 | 1993 Mercury Topaz

1 Answer

Horn no working , i need diafram


first run a live wire from the battery to the horn connection to see if the horn works,now some older cars have a permanant feed to the horn and then the return to the horn switch so have a look to see how many wires on the horn ,if two wires then one side of the horn to the + and the other to the earth - and see if it works

Sep 24, 2012 | Cars & Trucks

1 Answer

Won't start


sounds like imoberliser fault will need to have a diagnostic machine on it.

Jul 10, 2009 | 1999 Cadillac DeVille

3 Answers

Horn wont work.i check the fuse in the door and


Maybe horn became unplugged. Put 12 v power to horn make sure horn works. Put test light on terminal on horn have someone press the horn button, if light comes on and horn does not blow you may need new horn. if light does not come on you may have bad contact at horn button, blown fuse, broken wire, bad horn relay or possibly just a bad ground.

Jun 22, 2009 | Chevrolet Blazer Cars & Trucks

1 Answer

Car imoberliser. ford galaxy ghia 2000 .


the chip controls the anti theft system, youll have to get a new key and componants from dealers and itll have to be reprogrammed to your ECU on the car.
www.fgoc.co.uk

Mar 26, 2009 | 2000 Ford F Super Duty Chassis Cab

3 Answers

Suzuki grand vitara RHZ Diesel auto/Diagnostic tool


my 1993 very recently aguired.Grand vitara deisel. has imoberlised it's self. have had guys up with computer diognostics and found it in safe mode.found fault on turbo charger fixed it..all go, went for a short run ..great turned it off and on twice all fine.....next morning it had imoberlised itself again guys came with computer no fault found.. but it still will not start....help please........

Jan 18, 2009 | 1999 Suzuki Grand Vitara

Not finding what you are looking for?
2006 Kia Picanto 1.1 Logo

Related Topics:

555 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kia Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

yadayada
yadayada

Level 3 Expert

78919 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Kia Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...