Question about Mitsubishi Cars & Trucks

Open Question

Cs2a lancer gdi no start no power to pump i need to get relay location please

Hi iam tony 2 days ago while driving my lancer gdi 1500cc the started to loose power under full throttle it will run excellent at2000rpm and under the check light come on above did a scan code po190 shows change sensor and start the engine runs for about 15 min check light comes on check fuel lines with switch on result no fuel would you please tell me how to find the fuel pump relay

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 321 Answers

SOURCE: buick lesabre nightmare

Need to get a scan tool and look at the data stream while it is running for alot more info.Also any trouble codes.Sounds like initially,the engine isn't getting any fuel.I would have a pressure gauge connected to the fuel rail on the engine,so i could monitor the fuel pressure while all this is going on.Items to look at on the data stream would be timing,what timing is the PCM commanding for the engine.Also,have you checked for continuos power feed to the coils during this no start condition,and fire at the plugs while cranking.You could possibly still have spark,but maybe it is extremely weak?I have seen bad ignition switches cause weird problems before too.Many things power up through the ignition switch,just a thought.Have also seen bad PCM's cause strange problems..38 volts is a little on the low side for GM.Usually see those at,at least .50 and up,and rise steadily while pressing the throttle,up to just under 5.0 volts.Potentiometer with 5 volt supply.Vacuum leak can be checked with engine running at a steady idle speed,spray brake cleaner all around the intake manifold and listen for engine speed change.

Posted on Jul 31, 2008

  • 255 Answers

SOURCE: buick lesabre no start

Hi you have replaced allmost everything ,(try fuel pump relay)

Posted on Aug 18, 2008

latoss101
  • 47 Answers

SOURCE: gdi 1800 cedia wagon-odometer 80,000km exact, starting, no power

yes

Posted on Jan 03, 2009

  • 1 Answer

SOURCE: My 1994 suburban engine stops. No fuel, no MIL light.

I checked all of the fuseable links and they were all good. Next I decided to check all the power wires to the ECM and also the grounds from a wiring diagram because the Mil is controlled by the ecm and the bulb was good. The ecm is located behind the glove box. Bingo, the orange wire was only reading 3-5 volts at the ECM, but 12.5 volts after the fuseable link at the underhood fuse block (passenger side firewall). I ran a temp wire directly from after the fuseable link to the orange wire at the ecm and the ecm turned back on and the Mil or "check engine soon" light came on too. The truck started up and has never run smoother.

Note that at first the truck just stalled out and I could restart it right away with no error codes. Eventually the stalling became more frequent with longer reset times required. Once it threw a "code 54" and I thought it was fuel related as each time the gas stopped and I could still start the truck with gas poured into the TB. Ignition ok. My fuel pump turned on and ran if I tested it. I even checked the pressure regulator and the fuel filter to no avail.The orange wire that powers up the ecm is technically part or the fuel pump relay circuit as it also feeds the fuel pump relay 12.5 volts all the time. The thin orange wire from the fuse block is joined to two other thin orange wires in the large group of wires that heads to the ecm along the firewall behind the engine. I had to dig it out of the many wires to find it and remove a lot of tape. It is amazing to me that this one little orange wire could cause so much grief and be so hard to track down. I could not have afforded to take this problem to the Dealer.

Posted on Mar 26, 2009

  • 1 Answer

SOURCE: 2001 kia rio engine looses power

try your crank shaft sensor, sounds like the same problem i had , had crank shaft sensor replaced and it drove fine afterwards. maybe go to auto zone or something and see if that code comes up

Posted on Apr 18, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

What causes my 2001 mitsubishi GDI car to be firing only on number 2 and 3 cylinders


Check to see if #1 &4 use a common coil pack. If so, = likely culprit.

Jan 15, 2015 | Mitsubishi Cars & Trucks

1 Answer

Gdi lancer wont rev up


good day Sir, try to check the spark plugs and the fuel filter i hope this tips will help you.

May 19, 2010 | 2002 Mitsubishi Lancer

5 Answers

I have a mitsubishi lancer cedia model 2000 frequent stall when driving i switch it off and on again in the ignition and come to live again for a few miles and does the same again what could be the cause


If you have the GDI model,they were designed to run on very lean air/fuel ratio.
Once the mileage is up a bit a lot of problems can be traced back to a high carbon build up in the intake manifold.

Apr 24, 2010 | 2002 Mitsubishi Lancer

1 Answer

Fuel pump inop on 2002 mitsubishi lancer ozzy edition non turbo 5spd. I checked fuse #8 and 10 both are good. No power coming from fuel pump relay2 at bulk head connector . I have disconnected connector at...


Your vehicle is equipped with two fuel pump relays. Both are located on the junction block which is located behind left end of dash. You will need to test both of them to ensure they are working properly. Let me know how they test out.

Mar 16, 2017 | 2002 Mitsubishi Lancer

1 Answer

97 Mitsubishi legnum,runs great but takes a bit to start, thought it might be fuel pump relay as you can,t hear pump start when key is turned on, is that normal for legnums.


Hi,
is your car a GDI engine? If it is GDI you can't really hear the pump working when you put ign on.
Give me some details and I might be able to guide you there.
Chassis, engine numbers, GDI ??

Apr 23, 2009 | 1997 Mitsubishi Galant

3 Answers

Gdi 1800 cedia wagon-odometer 80,000km exact, starting, no power


Hi it sounds like your high pressure pump needs replacing. the pump can be repaired but you will have to find someone who knows about it, i fix a lot of them before. there is a spring that pushes out the piston in the pump so it can compress the fuel that spring losses its ability to extract the piston back out. i have pictures of one if anyone wants to see

Jan 03, 2009 | 2002 Mitsubishi Lancer

2 Answers

Automatic gearbox failed


get rid of the car while you can

Oct 10, 2008 | 2002 Mitsubishi Lancer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

78 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8152 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...