Question about 2003 GMC Yukon

1 Answer

2003 gmc yukon wont idle

My 2003 yukon wont idle, i put a new mass air flow sencer and still i have the same problem, what could it be? the truck runs fine other than it wont idle??????? please help

Posted by on

  • slingersink Jan 23, 2009

    the replaced the gas cap it is not a rough idle it just wont idle as soon as you let of the gas. do you no what it could be?

  • Anonymous Mar 21, 2014

    headlights wont come on

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,990 Answers

I know that this will sound Stupid. Change the Fuel Cap. If the Seal on the Gas Cap is Bad it will allow Air to get into the Fuel tank and cause your Rough Idle.

Posted on Jan 23, 2009

  • Travis Humphries
    Travis Humphries Jan 23, 2009

    I usually just run a Can or two of B12 Chemtool through the Fuel System to Eat away all the Deposits. Works Great. You have already replaced Everything that could cause this. The only other thing that I can think of is Maybe the Throttle Body Gasket is Sucking Air. Maybe a Light Rebuild on the TBI Could resolve this Problem.

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2003 gmc yukon denali through a mass air flow sensor code changed still having problems with it stuttering to start and while driving on freeway or at stop light when taking off


Trouble codes? If none, then check O2 sensor outputs and replace as needed. Could be a leaking intake manifold gasket if you get "lean banks" codes. This happens in cold winters, but fixes itself in Spring.

Dec 20, 2014 | 2003 GMC Yukon Denali

1 Answer

Yukon gmc revs up while at a red light


It sounds like the throttle position sensor, idle air control solenoid, or the mass air flow sensor. all three could cause this. a good scan tool will help you figure out which. Most auto parts places will test it for free

Apr 21, 2014 | GMC Yukon Cars & Trucks

1 Answer

Have a 2003 Gmc Yukon Xl 2500 6.0. When you first start it, the idle is low then high repeatedly. When you take off it sputters and will be ok until its warmed up. We have replaced the battery, spark...


I suspect the idle solonoid and/or the automatic choke Idle somonoid plays havoc when cold and you have to keep playing with the revs to keep it running. Even though you had cleaned the mas airflow sensor it still may be faulty. I would take it to Orielys or Autozone and ask them to read the codes for you {no charge} this will eliminate the guess work, good luck

Oct 21, 2013 | 2003 GMC Yukon XL

1 Answer

What are the symptoms when fuel pump goes bad on 2003 yukon danali


When a fuel pump goes bad,you wont start,the signs before a failing fuel pump is excessive cranking, and the engine cough through the intake, a check engine light stating lean bank one and lean bank two.You would have a MAF (Mass air flow code).

Mar 28, 2012 | 2003 GMC Yukon Denali

2 Answers

1999 gmc yukon obd11 codes po101 po171 po174 po429 what could be the causes


ok heres problem 101 is mass air flow sensor 171 running too rich 174 running too lean can find 429 but it the same lines i believe take out your mass air flow sensor and clean it check it connection if comes back on replace the mass air flow sensor

Sep 24, 2010 | GMC Yukon Cars & Trucks

1 Answer

Have fuel and spark no run p101 mass air flow sensor code


Replace the mass air flow,this is the problem,rate,if this was helpful,thank you,

Jun 12, 2010 | 2000 GMC Yukon XL

1 Answer

2001 yukon codes causes banks 1 and 2 to run lean?


If bank one and two are running lean problem is the Mass Air Flow Sensor (MAF) Dirty or Defective.

May 20, 2010 | 2001 GMC Yukon XL

1 Answer

I have a 2003 gmc yukon 5.3 the engine idles rough sometimes the idle will get so low the engine will shut off.(the engine runs good while driving) hooked to scaner po101 maf/vaf (dont know what vaf is),...


you have a vacume leak somewhere.check all of your vacume hoses for leaks.Injector seals can cause this too.Also intake gaskets could be leaking.Running to lean usually means the car is getting to much air coming in.To check leaks spray brake cleaner around the hoses and the bottom of your intake if the rpms change then you found a leak.

Feb 21, 2010 | 2003 GMC Yukon XL

1 Answer

My 2000 Yukon engine hesitate


Chk MAF sensor (mass air flow) first sensor in ducting coming out of air filter.

* Use only one foot on the gas peddle - Just teasing. :)

May 22, 2009 | 2000 GMC Yukon

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

783 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...