Question about 2002 Chevrolet TrailBlazer

1 Answer

All dash lights came on and none of the instrument gages worked.

We shut the car off and started it again and it was fine. Next day they came on after the card was running. Shut it off and restarted and all dash lights came on again. Shut it off and restarted and it was fine. I might asdd it was -20 degrees the first time and aout -13 next time and car had sat outside all day long. Is that something to do with the tumblers in the ignition? Is there a lubricant to spray into the ignition?

Posted by on

  • nptballa04 Jan 25, 2009

    same problem have to turn off an back on mph wrks b ut AC don't work as good and locks get messed up

  • smleinen Jan 25, 2009

    i have an 02 trailblazer air bag light comes on blinks 6 times then stays on any help other than going to dealer

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,990 Answers

This Problem is a Direct cause of the Low Temperatures. When it is - whatever the Relays are getting REALLY slow to Respond and Causing all kinds of Problems.

Posted on Jan 23, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

All my gauges just quit working. car still runs fine. they done this 2 or 3 times but would always start again. this time have not come back on. turn signals and dash lights work just no gauges.


At the moment, your instrument cluster maybe faulty? Due the basic tests, try to be sure. Check for applicable trouble codes relating to instrument cluster--pcm--communication codes. Some of the national brand auto stores in this country may check codes for free, if there are any.
Check voltage and ground circuits for the instrument cluster. The sending units for gages are wired to pcm then the pcm sends serial data to instrument cluster telling instrument cluster what to do with gages. If you want to check gage sending units, that's ok.

If you have a scanner that can communicate with instrument cluster, you can get instrument cluster to do a self-test. The self-test, the instrument cluster will turn warning lamps on and off, sweep gages w/o outside data input. The instrument is considered good, if it passes that test, if not, the instrument cluster is considered faulty.

Apr 28, 2016 | 2002 Pontiac Bonneville

1 Answer

Hyundai Sonata 2004 turn signal does not work properly


did you check the directional switch. sounds like you have a bad one

Nov 07, 2012 | Hyundai Sonata Cars & Trucks

1 Answer

No gear indicator, replaced cluster, odometer and PRNDL lights on, but no indicator light for gears. ????? Swapped out instrument cluster, gears displayed on other vehicle, (both instrument clusters)


I had a similar situation. No odometer, fuel gage, etc. Turned out to be loose connection in the relay box that is closest to the battery cables. I opened the box and reinserted the connections. It happened again and I took a hammer and gave the black box a whack and it started working again. I found that when the car is running, my wife behind the steering wheel an me under the hood, that when I manipulate the box she hears a click under the dash and the symptoms appear and disappear. That is where I would direct my attention. I understand it is a common problem on this model from a Buick mechanic.

Nov 06, 2012 | 2003 Buick Century

1 Answer

I have a 2004 Chev Trailblazer and the instrument cluster the back lights work but the instruments don't, the fuses are good, sometimes after driving it for 15 or 20 minutes and shutting it off and...


This is very common, in fact GM issued an extended warranty on the gage clusters from 2003-2005. Unfortunately the extended warranty has expired. The cluster either needs to be replaced or rebuilt. I know there are several companies that specialize in rebuilding them, but it takes 3-5 days and the vehicle is not drivable during that time and the repair is not cheap. I just checked and there is one on e-bay for $90 that may work for you. Here is the link, good luck! http://motors.shop.ebay.com/i.html?_nkw=trailblazer+gauge+cluster+&_cqr=true&_nkwusc=trailblazer+gage+cluster&_rdc=1

Jan 27, 2010 | 2004 Chevrolet TrailBlazer

3 Answers

Gages speedo tac all quit. fuses are good 98 jeep wrangler. did it before but came back on. changed gage cluster still will not work


Have you checked it with a scan tool to be sure it is actually getting the information? The instrument cluster do go out, meaning the ribbon on the back.I would check the connection, then turn to a way to determine if it is recieving a signal from ECM.

Oct 09, 2009 | 1998 Jeep Wrangler

1 Answer

My dash lights all come on, the gages stop working, air conditioner stops, windows wont roll down. One day it works fine, next nothing works. One day it would not start- but only one day. They cleaned a...


Sounds like an electrical problem; look for loose, corroded or kinked/broken wires. The problem is most likely in the dash wiring/connections and seems to be pretty common in jeeps.

Sep 01, 2009 | 1999 Jeep Grand Cherokee

4 Answers

Instrument panel went dead


Checked Every fuse in the fuse box (no small task).This includes #4 - Power point Instrument Panel, #14 - Day time running lamps (auto lamps doesn't work nor does auto lock), #27 - ignition switch run feed, #35 - Instrument Cluster, #41 - Instrument Cluster, #42 - Delayed Accessory, #45 - Ignition switch run/start feed, #102 - Door locks body security module, #103 - Ignition switch, #110 - Ignition switch, & #116 - Ignition switch. But I also check all other ones as well, they all register OK. AC panel & radio work. Turn signals work. Mileage does not work, trip computer does. So, basically, everything works except auto head-lights, auto locks, and the dash cluster (no MPH, RPM, mileage display, Fuel, Temp, Tran Temp, and Oil Pressure).

Aug 19, 2009 | 2003 Ford Excursion

2 Answers

Electrical / Lights / Gages


Pull instrument/ cluster panel and re-melt cold solder joints where circuit board connects to dash connectors. Get them hot enough to turn them bright silver, usually 3-5 seconds each pin.
Good Luck!

Jun 24, 2008 | 1996 Dodge Neon

Not finding what you are looking for?
2002 Chevrolet TrailBlazer Logo

109 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

64052 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...