Question about 1989 Chevrolet C1500

2 Answers

Motor runs rough under a load

It started running rough. did a compleate tune up and still the same prob.

Posted by on

  • Roberta Smith
    Roberta Smith May 11, 2010

    it's like a misfire occasionally ?



    Robert

×

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 962 Answers

Check the Idle control valve by cleaning it. buy some carb cleaner or brake cleaner. Remove the air duct work from the fuel system side by removing the clamps. Or take it off altogether. look inside the fuel system cylinder (hole) and to the sides you will see 2 holes. That is the IAC from the inside. Run the engine at about 1200 rpms and spray straight at the holes on the side for a good 10 seconds. turn off the car and let the cleaner soak into the valve. Restart th car and repeat the process. If it improves , great. If it does not you can remove the IAC and clean it. If that does not work replace it.You can also check for any vacuum leaks , a bad PCV valve, etc. If none of that works take it to an auto parts store for a free scan. get a trouble code and you can take it from there.

Posted on Jan 23, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 11,896 Answers

May have a vacuum leak. Probably a failed or cracked hose. Look at the hoses where they push over the connections. They often split up the hoses at the connection. Hook up a vacuum gage and drive it and when it is running rough, check the vacuum. If this problem happened suddenly, there is a good chance it is a vacuum leak. An intake gasket or camshaft usually gets worse gradually
Also If you can check your FUEL PRESSURE, fuel pumps can come & go & make it seem like water in the gas. Adding a electric pump in line will also help in vapor locks. Replace fuel filter while doing your tune-up.
If you have a distributor check coil resistance and clean the counter weight on the distributor shaft. Also check distributors vacumm advance

Posted on Jan 23, 2009

  • Nate Stansfield
    Nate Stansfield Jan 23, 2009

    A friend of mine had this problem with 89 Silverado 4X4 with 454 that idled ok, but was real doggy trying to
    take off, but ran fair...just didn't want to accelerate. It was a split
    hose inside the gas tank, causing low fuel pressure.
    He had also just replaced EGR and TPS and come to find out it was the hose


×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Ford F450 V10 rough running under load.


Good place to start. Ignition module may be the cause too.

Mar 06, 2016 | Ford Cars & Trucks

1 Answer

Runs rough under load


Did change fuel filter,tune up,could be catalytic converter.

Jan 28, 2014 | 1996 GMC Yukon

1 Answer

Rough idle cold or warmed up,runs great on highway


tune up,fuel filter,air filter,clean throttle body.

Mar 09, 2013 | 1996 Ford Thunderbird LX

1 Answer

1999 Chev K2500 Suburban (Old Body) 5.7 / auto started running rough at accelleration, under slight load (hills, trailer, starts). No codes or MIL light. Replaced plugs & wires (only owned truck for...


If you can determine the ignition system is ok, I would look at fuel pressure and the fuel filter. If the distributor was loose you may have to check base timing.

Dec 05, 2012 | Cars & Trucks

2 Answers

97 cavalier starts and runs ok from a cold start after a few minutes of warm up it starts to run rough and miss. If i try to drive it it will start out ok but won't shift automaticly but shifts fine m


Sounds like possibly more than on problem, crankshaft position sensor, or ignition module likely on starting prob which maybe affecting shifting due to hard code in ecm, or shift prob could be shift solenoid in valve body of transmission. Both parts readily available from local parts store

Nov 27, 2011 | 1997 Chevrolet Cavalier

1 Answer

Car start runs rough, after replace crank sensor car run rough, now don't run.


go through wireing near sensor and plug attached to sensor and clean it all first,my mate had same prob cleanded it all and now works,not saying will be solution but it worked for his.

Nov 15, 2011 | 1992 Pontiac Sunbird

2 Answers

When running down the road it runs great but when you stop the motor loads up with gas and it acts like it is running on 3 cycl


Have you changed the plugs lately? You may need a tune up. Change the plugs and wires. Also, check your distributor cap. If you haven't had a tune up in a long time, I would get it done. Make sure you check for a vacuum leak as well. A simple leak can make a car run rough.

Feb 25, 2011 | 1993 Ford Explorer Limited

1 Answer

1999 3L S Type Jaguar Rough Running


WITH MOTOR RUNNING REMOVE ONE PLUG LEAD AT A TIME (INSULATED PILERS) MOTOR SHOULD REACT IF GOOD , IF ENGINE SPEED DOES NOT DROP ITS A FAULT AT THAT CLY, TRY NEW SPARK PLUG 1ST THEN LEAD, ALSO CHECK FOR ANY FAULTS OR SHORTING OF THE PLUG LEADS, COIL PACKS. (MORE NOTACABLE IN DAMP CONDITIONS) THESE CARS NEED TOP QUALITY PLUGS, OR THEY WILL ALL FAIL UNDER LOAD,

Dec 05, 2009 | 2000 Jaguar S-Type

2 Answers

Lossing power when hot


Bad Fuel pump or ecm. Good Luck

Nov 18, 2008 | 1997 Honda CR-V

Not finding what you are looking for?
Cars & Trucks Logo

101 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

61168 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...