Question about 1996 Mercury Sable

1 Answer

Battery light where no battery problem exists

I got my battery replaced today, after having to call for a jumpstart a few times during the below zero weather we have been having in Maine. The battery light only used to show when starting or when stalling. Now it is on all the time, even though the battery is working fine. The mechanic had checked the electrical connections and said all was fine. What could be wrong?

Posted by on

  • Suzanne Wilson
    Suzanne Wilson Jan 23, 2009

    hey guys....the battery light went out this morning! I think it just needed to charge up more. :) Thank you for all the responses!

  • hitecator
    hitecator May 11, 2010

    Have you checked your battery terminals?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,990 Answers

Check the Tension on the Belt. If it is Even just a little bit loose it will cause the Dash light and it will not allow the Alternator to Recharge the Battery.

Posted on Jan 23, 2009

  • Travis Humphries
    Travis Humphries Jan 23, 2009

    No Problem! Happy to Help!

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 1996 mercedez e320 only starts when I JumpStart


Connect a voltmeter across the battery terminals. While engine off, if the voltage is below 12V it means your battery is either dead or discharged. Once you've jump-started your car, check the battery voltage again. If it's still low (like below 13.5V) it may mean you have a problem with your alternator.
Let me know the voltages and we'll think what to do next.

Oct 17, 2014 | Cars & Trucks

1 Answer

1997 jeep cherokee sport


You have a possible issue with the voltage regualtor inside of your alternator.
You can drive to Autozone & have them test for under voltage & overvoltage condition, appears to be a voltage regulator failing.

Let me know how it turns out for ya!
Good luck to ya....

fastestnascar@gmail.com

Jan 13, 2012 | 1997 Jeep Grand Cherokee

1 Answer

Battery light on after alternator replacement


Check battery voltage 12.6 full charge Running 13.8 to 14.5 below 12.6 Battery shot below 13.8 running alternator shot

Nov 23, 2011 | 2002 Chrysler Town & Country

2 Answers

My 2002 pontiac aztek battery light came on yesterday. Today i went out and NOTHING. jumpstarted it ran for a few minutes then died. Will not start without being jumped. i figured out how to get past the...


Hello! I do not believe this is a security issue...The Battery Light is telling you that the charging system has a fault...One of three possibilities exist...# 1...The battery can no longer hold a charge...
# 2...The Alternator is defective...Or # 3...The cables that interconnect power and ground are corroded and resistive...Do you have a voltmeter and a wee bit of experience using one?...If not send a comment...Set the meter to rear +12 volts...Place the meter probes directly in the center of the battery post...Record the reading...Jump start the vehicle...Quickly remove the jump cables and while the engine is still running, take the same reading again...The second reading must be 1.8 to 2 volts higher than the first...This tests the alternator...If alternator is good...Have the battery tested...Clean cables (on both ends) if necessary...

When the battery, alternator and cables are correct, the battery light will go out...At that point in time the engine should start...If not, then we have other issues and I'll fix them if necessary...

Guru.......Saailer

Feb 08, 2011 | 2002 Pontiac Aztek

1 Answer

My mercury cougar won't start, all lights are ok


Take another look at the battery, clean the posts and the terminal ends. Charge the battery, or jumpstart from another vehicle, and allow it to run for 5 to 10 minutes. Shut the vehicle off and see if it will start again. If not you will most likely need to replace the battery.

Jan 10, 2010 | 2000 Mercury Cougar

1 Answer

My 06 sedona wont start just a clicking noise, radio and lights work. Just got a new battery for it and nothing changed. Is there a fuse/relay problem or probably the starter?


Try jumpstarting it. My 06 has done that a few times and jumpstarting has worked every time. Usually, one of the kids left a dome light on or something.

Oct 28, 2009 | 2006 Kia Sedona

1 Answer

Tachometer stopped working completely but all other gauges are fine. Tachometer would work off and on for a few days before completely not working. "Check engine light" stays on. All fuses are fine. This...


It's very UNLIKELY the jumpstart had anything to do with it, unless you accidentally connected the battery in 'reverse polarity', which causes the electrical system voltages to 'DROP' instantaneously to near zero volts and create 'current spiking' in all active circuits. Nevertheless, the microcomp in the instrument cluster which drives the TACH has protective curcuits. The only solutions are to eliminate any problems in the wiring between the ECM/PCM and the instrument cluster, and bench test the tach to determine if it's working properly. Process of elimination - if wiring is ok and the Tach is ok, then the problem is in the ECM/PCM.




0a6ec56.jpg

Sep 06, 2009 | 2004 Hyundai Santa Fe

2 Answers

Volvo S70 won't start - battery, generator, or other


usually multiple clicking (like a machine gun) does indicate lw battery voltage. did you get 11.9 volts with it running or car off? with running you should be over 13.6 min up to 14.0 volts. these cars have a fair amount of electronics with some residual voltage draws which may shorten battery life. 4 yrs is not too bad. i would consider replacing battery

Dec 13, 2008 | 2000 Volvo S70

Not finding what you are looking for?
1996 Mercury Sable Logo

52 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

70365 Answers

Ron Lankford

Level 3 Expert

5386 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...