Question about 1993 Geo Metro

1 Answer

Engine races at cold start - 1993 Geo Metro

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 58 Answers

Sounds as if you have a vacuum leak. and when cold the motor runs with pre set conditions, add in a vacuum leak and you may idle high. take a bottle spray bottle and fill it with dish soap and water. then spray your engine and vacuum lines down. when you hear the slurp and feel the idle go down trace your bubbles to the suction point. aaaaHH i love cars :) good luck

Posted on Jan 29, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Truck idles very high when starting


how cold is cold???? In Alaska or Key west?
tell location and bingo, i know. but didnt
all engines race cold for sure EPA regulated ones.
and race faster the colder it is

what is RPM see dash, see dash rpm gauge called the
tachometer, use that to answer
or if no tacho there, ill never know here in the cloud.

no engines size stated


its 85f here.
2000 RPM is easy cold.
here about 1500 cold (85f) but drops fast say 5min.

Dec 25, 2015 | 2002 Suzuki XL-7

1 Answer

I have a 1997 Fiesta auto, runs fine apart from a slight gearbox issue. When starting from cold and selecting Drive the car will sit there for upto 5 seconds before moving away and will stall if the brakes...


I would be looking for a vacumn hose leaking. The cold engine needs a rich mixture and braking uses the vacumn booster causing the mixure to lean. A warm engine races with the extra air.

Feb 27, 2015 | Cars & Trucks

1 Answer

How can I adjust my polo classic 1998 fuel injection revs.Normaly it idle on 900, but now increased to 1300 to 1600


knocked the ECT connector wires loose?
so my guess you mean, hot engine races,because cold engines all do that , by design.
racing idle hot.
  1. engine not hot. thermostat bad.
  2. engine hot and Ect Sensor lies, (wires fell off)
  3. ISC valve stuck open or wires, bad to it.
  4. vacuum hose knocked loose or you cracked it, now sucks air and engine races, (speed density EFI systems
  5. .
lots more, but am lazy , on beach

Jan 18, 2015 | Cars & Trucks

1 Answer

Bottom falls out of idle after revving engine cold


Its probably a problem with the water temperature sensor. Also do not rev a cold engine. The engine has a "cold start sequence" which is similar to a choke. When the engine gives a cold signal, the fuel mix is made richer and the timing is changed until the engine warms.

Let the engine warm at the preset factory settings. Sometimes the O2 sensors will cancel the cold start sequence before the water is warm. Racing the engine will warm the O2 sensors too quickly.

May 14, 2014 | 1993 Mercury Grand Marquis

1 Answer

When car is warm engine races at idle.


it is possible the engine to have a vacuum leak,**** air,or the temperature sensor not to work properly and give wrong message to PCM as cold start. clean also the throttle body from any dirt.

Aug 31, 2012 | Cars & Trucks

1 Answer

Idle races when cold


Check your Idle Speed Control Valve,or any vacuum hose leaks.

Aug 24, 2012 | 2001 Jeep Grand Cherokee

1 Answer

2002 ENVOY. THE TEMP DROPS AND THE ENGINE WILL RACE. THIS HAPPENS WHILE DRIVING AND SOMETIMES WHEN STARTING, EVEN IF ENGINE IS WARM, THEN IT WILL GO BACK TO NORMAL. WHAT IS CAUSING THIS? SOMEONE GAVE ME AN...


Could be a bad temp sensor or a bad thermostate.If the engine thinks that the temp is cold it will add more fuel.This will cause it to race.The question is the temp realy dropping or is it just reading a temp drop.Well hope this helps and good luck.

Apr 17, 2010 | 2002 GMC Envoy

3 Answers

Engine races after start up


More than likely if its a fuel injected (multi port on the manifold) than it is the IDle speed sensor on the right side of the throtle body.

Jun 21, 2009 | 1988 Jeep Comanche

1 Answer

1999 Jeep wrangler 4.0 engine races


Check the thottle linkage make sure its not stuck open. And check for any large vacuum leaks.

Apr 04, 2009 | 1999 Jeep Wrangler

Not finding what you are looking for?
1993 Geo Metro Logo

Related Topics:

158 people viewed this question

Ask a Question

Usually answered in minutes!

Top Geo Experts

yadayada
yadayada

Level 3 Expert

71288 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22059 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7009 Answers

Are you a Geo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...