Question about 2002 Pontiac Aztek

1 Answer

Instrument panel not working

My instrument panel on my 02 aztek is not working all lights working but the tach, speedo, and gas gauge are not working the needles move when I start it but once its running they bottom out checked fuses for instrument panel none blown

Posted by on

  • 1 more comment 
  • Anonymous Feb 01, 2009

    My 2003 Aztec has the same problem, I replaced the battery and the instrument panel doesn't work now. I looked for a Guage Relay under the hood in the fuse box and I didn't find one...So now what?

  • mybrns Mar 25, 2009

    My 2003 aztec's instrument gauge's do not work and I replaced the relay under the hood. Do I need a new instrument cluster?

  • Anonymous Mar 30, 2014

    gages all work , but inst. panel lights quit working years ago . checked all fuses are ok but will not light panel lights

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,990 Answers

Look in the Fuse Relay box under the Hood and Replace the Guage Relay. Should get it Fixed.

Posted on Jan 22, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My cars gauges just stopped working last weekend.


Could be a fuse. Have somebody who knows about cars look at the instrument cluster fuse to see if the wire inside is broken.

Jun 07, 2016 | 2004 Saturn VUE

1 Answer

Instruments don't work, key stuck in ignition, doesn't shift correctly


Sounds like you need a new car.
With joking aside, the problem with your speedo, tach, gas guage, temp gauge and odometer can probably be one of two things. Check your fuses. If they are fine you may need to replace your cluster panel. I had to have the entire thing changed over my speedo not working right. It was not cheap. You might want to check the relay box under the hood. Does your transmission leak? Check the fuses and relay on it also. Get a new ignition switch and replace the old one if your key is stuck. You can try WD40 on that key but don't expect any miracles. The bearings are likely shot. Sorry I posted all of this bad news. Good luck.

Jan 05, 2014 | 1998 GMC Jimmy

1 Answer

Rpm gage and speedodomer not working


If the tach and speedo are not working, but the gas gauge is, I would say the problem is inside the instrument cluster.
All three components get power from the same circuit.

Apr 15, 2013 | 1997 Buick LeSabre

1 Answer

Gauge arms 2003 tahoe not working


if its not a fuse then it could be the entire instrument panel-2003 is bad for that

Apr 01, 2013 | 2003 Chevrolet Tahoe

1 Answer

Gas gauge constantly on empty, check engine light not on,


Problem can be one of two things, a bad sending unit in the gas tank or a defective stepper motor in the instrument cluster. All gauges, speedo and tach are driven by stepper motor that have been known to fail. A technician using a scan tool can determine if the tank sending unit is working.

Sep 04, 2010 | 2004 Chevrolet TrailBlazer

1 Answer

Tach & speedo not working


Had same problem with my 2000 dodge stratus 2.4 liter and transmission would not shift out of 1st gear. Solution was ignition fuse under the hood was blown, one side of fuse working, replaced 10 am fuse everything works, tach, speedometer, gas gauge and transmission started back to shifting.

May 27, 2010 | 1996 Oldsmobile Achieva

1 Answer

Instrument Panel Problem - Electrical


check all wiring and maby youl get it right

Sep 18, 2009 | 2005 Chrysler PT Cruiser

1 Answer

1999 996 carrera speedo and tach does not work(analog and digital


maybe the speedo drive has stripped some teeth. good luck!

Jul 27, 2009 | Porsche 911 Cars & Trucks

1 Answer

Gauges not working properly


Hello, Last year General Motors lost a lawsuit about the instrument panels in 2002 to 2005 trucks. The following website contains all the information about this lawsuit settlement.
http://www.speedometersettlement.com/
This impacts the entire gauge cluster in your vehicle.
I have the same year and model as yours and my speedo is never accurate and the tach always read 6000.
The issue is the metal bearings that the gauge meter movements use. The bearings are getting dry which impedes the meter movement.

Apr 01, 2009 | 2003 Chevrolet Suburban 1500

1 Answer

Instrument cluster damaged after battery shorted out.


4 resistors on the back of cluster bad get them at radio shack.

Dec 14, 2008 | 1998 Buick Regal

Not finding what you are looking for?
2002 Pontiac Aztek Logo

Related Topics:

903 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pontiac Experts

yadayada
yadayada

Level 3 Expert

60769 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Pontiac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...