Question about 1992 Subaru Loyale

2 Answers

1992 Subaru Loyale Temp Guage problem

My temperature guage shows cold all the time, but the heater still works inside the car. Is it a bad guage or something else?

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 11 Answers

First question: Your Temp. gauge in your car does not work. Have you noticed if your electric cooling fan is working? These 2 are connected and is A: Bad thermo sensor located on radiator (Passager side) toward bottom of tank.
B: If you pull the sensor from your radiator and no.or very little water/coolant comes out. Then the problem is a plugged radiator.
Those radiators plug very easily with crud. The fix is simple.
Remove radiator
Drain.
Fill with Draino Max. Yes...the gel or liquid type used in everyday household drains.
Let it set in the radiator for about an hour (Shaking about every 5 minutes or so.
Then drain and rinse very well with very hot water.
I bet TONS of crud comes out when you rinse.
Re-install the radiator once its rinsed and refill.
This should fix your problem with the radiator flow.
If the problem has not gone away.....
You can replace your thermo sensor for about $157
OR you can buy one from a wrecking yard fro about $5
These thermo sensors are very tough a RARELY go bad.
This should fix the problem.
If it doesn't....try replacing your relay located under hood. passager side...near the fire wall.
The relay looks like a lil black box located under a plastic container with rubber tubes coming from it.

Good Luck.

Posted on Mar 28, 2013

  • Christopher Cramer
    Christopher Cramer Nov 09, 2013

    I have similar problem, some heat from the car and guage is always stone cold-going to flush coolent system and thermostat and if that dosent work ill try your suggestions thanks

×

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,118 Answers

Most likely its the temp.guage sending unit.

Posted on Jan 22, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Heater blows cold air and the temperature guage reads cold after driving for 20 minutes


Best case scenario is your thermostat is stuck open. When this happens the engine will take a long time to warm up and will never get up to full temp. Worst case could be a serious problem such as a blown head gasket. If there is no coolent in the engine the temp gauge will not register either.

Dec 15, 2013 | 1999 Ford Explorer

2 Answers

My mazda protege is having a heating problem. The temp guage will go up to the normal place as the engine warms up but then when I drive down the road the temp guage goes down to below cold and then my car...


I believe the mazda protege has a separate thermoswitch to activate the radiator's fan. Perhaps the fan keeps blowing until the temperature is too low. Try replacing the fan thermoswitch. Just take care to put in tis place a thermoswitch of the same temperature range.

Nov 11, 2013 | Cars & Trucks

1 Answer

Temperature gauge on 2000 catera is staying on cold as if caris not heating up


If it is actually warm, but the gauage has not moved, you probably have a bad temp sensor that feeds the guage. On some cars there are 2 temp sensors, 1 for the computer to it knows how much fuel to give based on coldness, and one for the guage that just shows you in the dash what the temp is. The other 2 ideas would be a bad gauge and a bad wire/cable from the sensor to the gauge. There is not much else it could be if in fact the reading is wrong.

Sep 26, 2012 | 2001 Daewoo Leganza

3 Answers

I Have a 1992 dodge dakota And my temp gauge does not move. Do you know whats wrong with it


find temp sender turn key on and disconect wire from sender and earth it if guage moves to hot sender falty, if not guage faulty, or broken wire,or no power to guage

Aug 14, 2011 | 1992 Dodge Dakota

2 Answers

The gas guage and temperature guage in my 02 cavalier are not working properly. half of the time the temp guage stays below 40 and will not go up and when i fill up the car and start it the gas guage will...


Hi, take the connector off the temp sensor, turn the key on, and have someone watch the gauge while you insert a paperclip to short the terminals together inside the connector. If the gauge goes from one extreme to the other when the terminals are connected, the cluster is probably OK. It may just be that both sensors are bad.

temp sensor location, 2.2 liter engine:
jturcotte_1822.gif


2.4 liter engine:
jturcotte_1823.gif

Jun 11, 2011 | 2002 Chevrolet Cavalier Coupe

2 Answers

Engine temp guage shows cold


Let the truck run for about 15 minutes. If the engine temperature does not come up turn the heater on and check to see if the air coming out is hot or cool. If it is hot the engine's thermostat is operating fine and most likely the problem is with the temperature sending unit for the gauge. If the air is cool the thermostat is stuck open. Try replacing the thermostat if the air is cool.

Jun 05, 2010 | 1996 Isuzu Hombre

1 Answer

97 Subaru Legacy, 142,000 miles. Temp Guage


Sounds like the Coolant is not full and has a air bubble. It is very important to have the system filled complete. That would be the first step.Good luck and have a great day.

Feb 22, 2010 | 1997 Subaru Legacy

2 Answers

Temp guage showing hot, not getting any heat for 1992 Mercury Cap


If the hoses to and from the heater core are hot , and you say the heater core is hot , then the only answer is that the air duct that flows into or out of the heater core plenum ( housing ) is not opening.
Heater control on dash borad inoperative.
Not sure about 92 capri , some cars have a cable linkage , some work on vacume motors.
Try to find a haynes manual for your car , they will walk you through almost every step of anything you may ever want to do to your car.

You seem to know what you are doing , but I gotta ask ........the heater core you felt was up behind the dash inside the passenger compartment of the car right ?

May 10, 2009 | 1992 Mercury Capri

1 Answer

2003 Ford Taurus temperature guage


replace the temp sending unit if you continue to have this problem

Jan 22, 2009 | 1996 Ford Taurus

1 Answer

Defroster


Yeks, quick (when engine cool) make sure your radiator is FULL and engine is AIR BLED at the thermastadt. If your master brake cylinder is assisted power your DIAPHARM could be ruptured. Causes low vac in system so heater controls only work at idle the changes to cold when driving

Nov 24, 2008 | 1992 Subaru Loyale

Not finding what you are looking for?
1992 Subaru Loyale Logo

238 people viewed this question

Ask a Question

Usually answered in minutes!

Top Subaru Experts

yadayada
yadayada

Level 3 Expert

63587 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21981 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Subaru Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...