Question about 1998 Oldsmobile 88

2 Answers

My Oldsmobile runs good but, only once every blue moon it just cuts off on me, any ideas?

Posted by on

  • fordridinhig Feb 18, 2009

    the car will be fine and all of the sudden it just shuts off normally when pulling into parking spaces or slowing down for lights or turns. it has happened a few times at higher speeds on the freeway

×

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 99 Answers

Itp sensor

Posted on Jan 22, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

My sons car had the same problem. The side mounted battery cable screws would be loose. replace these and clean the cable ends well and put some conductive grease to protect from oxidizing.

Posted on Apr 14, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My transmission work good until i guess warms up real good then nothing, car still running just trans stops


When did you last replace trans filter and fluid? Ever? Star with that if you haven't done it.

Mar 28, 2016 | 1997 Oldsmobile Regency

2 Answers

Why is my 2006 cutting out while driving,and sometimes stalls while driving


I think and I am sure that you must change your spurking plugs
and wires . Hopping help you!

Apr 29, 2014 | Volvo S40 Cars & Trucks

1 Answer

Tachometer drops low


vacuum leak usually increases rpm--the electrics got hurt from overheat--hav a data stream run-displays values of evry component-so u kno what parts are bad----private mechanic not a dealer- a scanner that uses factory gear not a 30$ tool sold in stores--the vehicle computer may hav an issue-a readout wont disclose it--so disconnect batt n see if problem clears or pull plug on computer and clean the pins--may reboot

Dec 16, 2013 | Buick Rendezvous Cars & Trucks

1 Answer

MY 92 OLDSMOBILE CLASS SERBIA WILL RUN FOR ABOUT 10TH MINUTES THEN CUT OFF, ANY IDEA WHAT IS GOING ON?


UNPLUG THE MASS AIR FLOW SENSOR( LOCATED -- FIND AIR FILTER BOX THEN FOLLOW THE BLACK HOSE OVER AND THE PART ITS CLAMPED ON TO YOU WILL SEE A BLACK BOX ON TOP OF IT. JUST UNPLUG IT AND START ENGINE IF IT RUNS THEN THE SENSOR IS BAD, REPLACE IT.

Aug 14, 2011 | 1992 Oldsmobile Cutlass Ciera

1 Answer

Have to use starting fluid to get started once it is running i can cut it off and back one when it sets for a couple hours it wont start put new plugs and wires on still doing it but not as bad


possibly the fuel pressure regulator,or fuel pump sending unit. I had 2000 olds similar symptoms.sending unit pump resolved issue.good luck!

Mar 23, 2010 | 1999 Oldsmobile Bravada

1 Answer

99 olds bravada rear wiper not working


Check for power to your rear wiper motor. To do this you will have to remove the rear door trim. Once the door trim is removed check for power at your connector plug on the rear wiper motor with switch on. If there is power there than replace motor if not then start by checking fuses (which is a good idea to do before removing door panel because it's the easiest thing to check), connectors and wiring for damage and open circuit( cuts or broken pins in connectors or open/broken wiring)

Nov 04, 2009 | 1999 Oldsmobile Bravada

1 Answer

1990 oldsmobile CC SL running very rough, smoking, backfiring


Well Mike" a few things to check could be Breather on fuel tank /fuel return to tank pipe/ as pump can pump high pressure and excess has to return to tank and it sounds like yours is overfueling./take air cleaner off and all pipes and check for any thing partly blocking air flow/also check any black hoses coming from the engine breathers/going to air in take/make sure all cylinders got good compression

Oct 02, 2009 | 1990 Buick Century

1 Answer

Polo 1.4 cutting out every 30 seconds


Do you hear the fuel pump cut off? Once your pump reaches pressure it should cut off. Also you can try and remove your fuel cap and see if the car will run just know it could cause your check engine light to come on so do not run it very long. If it continues to run with fuel cap off I would say it is your fuel pump. Good luck with that and the best thing to do is get a fuel pressure gadge and see what kind of fuel pressure you are running. I know there are some parts houses that will loan or rent you tools. Good luck.

May 24, 2009 | 1994 Volkswagen Jetta

1 Answer

Start up


U have 2 seperate problems, the gas gauge issue is caused by a defective sending unit in the gas tank, the cutting out will require u take the car in and have the electronic engine control system tested for trouble codes. Does this car have the 5.7 L engine?

Mar 17, 2009 | 1994 Chevrolet Caprice Classic

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

121 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

70374 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6878 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...