Question about 1995 Mercedes-Benz SL-Class

1 Answer

Bose radio in my sl500 not working properly

When i turn on the radio the display flashes between phone and 87.7 and a clicking noise is in the antennae

Posted by on

  • tamekita Mar 03, 2009

    I had work done to my s430 and my radio asked for a code and now i just have the word PHONE on the screen.....any suggestions?

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Stereo asks for code sporadically, will not turn on or will turn on then powers off?
This problem was troubleshot to poor connections on the fuses in the fuse box under the hood. Access the fuses, twist each fuse in it's holder. This will clean the contacts at both ends of the fuse and may bring the stereo back to a more reliable working condition.

Posted on Mar 11, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a 1996 Nissan Maxima with a factory Bose CD player / cassette and radio and it will not turn on what's the solution


Maxima Bose Radio ' eBay

www.ebay.com/bhp/maxima-bose-radio

eBay1995 1996 1999 Nissan Maxima Pathfinder Infiniti J30 Radio BOSE CD tape Player ...Will fit and work in these with BOSE audio package only:1995 - 1999 NISSAN .... 2006Nissan Maxima OEM Bose Cassette & 6 Disc CD Player Radio CR13B ...DESCRIPTION Unit is missing some bottons, 3 of them, this item has NOT ...

Nissan Maxima Bose Stereo ' eBay

www.ebay.com/bhp/nissan-maxima-bose-stereo

eBayWill fit and work in these with BOSE audio package only:1995 - 1999 ... 1996 - 2000 NISSAN Pathfinder. 2004 2005 2006 NISSAN MAXIMA FACTORY BOSE STEREO 6 DISC ... Factory NISSAN INFINITI BOSE Radio, Tape, and CD Player. ... 6 Disc AM FM Stereo Cassette Radio Bose OEM LKQ (Fits: Nissan Maxima).

Nissan Maxima Car Stereo Removal and Repair - YouTube

? 8:52
https://www.youtube.com/watch?v=RT-SZEfeA4Q
Sep 16, 2012 - Uploaded by Factory Car Stereo Repair
Factory Car Stereo Repair .... I have nissan maximal 05..the CD part turns on but the cd won't eject...should ... I have a 2005maxima non-bose radio system. ... my speakers is super in my 05 maxima but my cd player keeps on ...

Nissan - Factory Car Stereo Repair



Feb 03, 2016 | Nissan Cars & Trucks

1 Answer

Porsche radio flashed and stopped working


Hiya, what do you mean but flashed? did it turn on and just went off again or did it spark (flash) I need more information.

Thanks

Jun 25, 2014 | 2004 Porsche Cayenne

2 Answers

Bose radio has display but no sound


radio has failed...my blaupunkt does the same and I just turn it off and on til it works

May 01, 2014 | 2000 Nissan Maxima

2 Answers

I got an Audi TT Turbo Model 2000 The radio Bose Audi concert is giving safe on the screen and nothing else what should I click on to reset the radio so I can put the code.Thanks


  1. Turn on radio. The radio display shows "SAFE".
  2. Press the FM2 and RDS buttons simultaneously and hold until "1000" shows on the display. Release the buttons. Do NOT press these buttons again, otherwise the radio will consider "1000" to be the code.
  3. Use Preset buttons 1 ... 4 to enter the four-digit code number from your radio card. Preset button 1 corresponds to the first digit, Preset button 2 corresponds to the second digit, etc. Each press of the button increments the number by 1.
  4. Once the code shown on the display is correct, press the FM2 and RDS buttons simultaneously and hold until the word "SAFE" appears in the display, then release the buttons.
  5. The radio should unlock and be usable shortly afterwards.
  6. If an incorrect code is entered, the word "SAFE" appears, first flashing and then continuously. You can repeat the above steps to unlock the radio once more, the number of attempts will be shown in the display. If an incorrect code is entered again, you radio will be locked for about one hour. After one hour - the radio must stay on and the key must remain in the ignition lock - if the display goes out, the you can repeat the above procedure to unlock again. The cycle - two attempts, one hour lock-up - still applies.

May 29, 2011 | 2001 Audi TT

4 Answers

My 1994 Mercedes Benz SL500 radio display turns on, but no sound?


I had same problem with my 1994 SL600. Also when this happens you will lose your interior door lights when you open the doors. My problem was solved by taking out the, A-white 40 amp 12V Relay and cleaning off the 6-prongs and reinstalling. It is located in the box underhood ahead of the main fuse box. Just need a phillips screwdriver. It is the fartherest relay in back left. I had to pull the one out in front of it to be able to remove the white one. You can hear it click when you push in dooropen switch. When working right you do not hear it. Hope this helps.

Sep 07, 2009 | 1994 Mercedes-Benz S-Class

2 Answers

2001 Acura 3.5 RL Radio Problem Stopped Working - Inoperable


need raido code for 01 acura, anyone got it?

Apr 30, 2009 | 2001 Acura 3.5RL

1 Answer

2002 gmc envoy bose 6cd player does not play, shows player error


how to remove a bose cd/radio from dash of a GMC envoy slt cd's are stuck inside

Apr 17, 2009 | 2002 GMC Envoy

2 Answers

HOW TO UNLOCK RADIO 4 AUDI A6 1999


Turn on radio - the word SAFE will appear in the display. Press th P.SCAN and RBDS buttons simultaneously and hold them down until "1000" lights up in the display.Release buttons.Do not, under no circumtances, continue holding them down or press them once again. This will cause the radio to consider the number 1000 to be the input code.Use station buttons 1,2,3,and 4 to enter the code number on your Radio Card. Use the button 1 to enter the first number 2 for the second number 3 for the third number and 4 for the last number.Once you have entered the code and it shows on the display,press the P.SCAN and RBDS buttons down again simultaneously and hold them down until the word SAFE appears in the display.Release buttons. Soon afterwards a frequency will be displayed.

Mar 12, 2009 | 1999 Audi A6

2 Answers

Turn signals and wipers don't work but high beams and curise cont


check your charging system the voltage at the battery should be 12.85 Volts WITHOUT the engine running and 13.2-14.5 Volts with the engine RUNNING. If the voltage is low it probably means the alternator is at fault.

Jan 29, 2009 | 1987 Toyota Xtracab

Not finding what you are looking for?
1995 Mercedes-Benz SL-Class Logo

391 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

yadayada
yadayada

Level 3 Expert

61037 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

164 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...