Question about 1999 Ford Escort

1 Answer

Cannot start My ford 1999 Ford escort was working fine Sunday but on Tuesday afternoon the engine would not start. Thinking it was the battery, I utilized jumper cables but even after 15 min it still would not start. The ''check engine'' light remains illuminated. when I attempted to start it again, it did not even make a sound. I replaced the battery and the alt this past summer. Please help me out here before I dump more and more money into this car.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 5,158 Answers

Have someone turn the key to start it... and smack the starter with a hammer... if it starts it's the starter needing replacement

Posted on Jan 21, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My brand new expedition 2013 ford won't start


Take it back to the dealer. It should be under warranty. Also have them check all of the recalls if any.

Jan 23, 2014 | Ford Expedition Cars & Trucks

1 Answer

1999 ford escort 2.0 p1516


Just reset it and it will be gone.

Nov 24, 2013 | Ford Cars & Trucks

1 Answer

Engine problem 1999 Ford Escort 4 cyl Front


Sounds like you make have a vacumn leak on one of the rubber vacumn lines that attach to the intake manifold. Check all of these lines and look for cracks, pinholes and lines that have colapsed.

May 08, 2010 | 1999 Ford Escort

1 Answer

Every 3 or 4 days my 1999 Ford Escort won't start


the alternator may be bad...replace it and you should be fine

Feb 16, 2009 | 1999 Ford Escort

2 Answers

1999 Ford Escort idle problems


PVC valve is not metering air correctly, it will appear ok shaking it but looses it ability to maintain proper position causing a medium to gross vacuum leak.

Sep 12, 2008 | 1998 Ford Escort

Not finding what you are looking for?
1999 Ford Escort Logo

Related Topics:

147 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

68032 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22011 Answers

Fordexpert

Level 3 Expert

5367 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...