Question about 1997 Chevrolet S-10 Pickup

1 Answer

1997 Chevy S-10 v-6 engine cuts out

Last few mornings very cold, let truck warm up all ok, put in reverse or forward engine cut out and had to restart 2 times.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 17 Answers

Try giving your truck a tune up cap,rotor button,plugs wires mine did same thing changed it now works and runs fine

Posted on Jul 26, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2001 jeep grand Cherokee every time I start it Idles rough and cuts out until warm and if heater is turned on when cold it cuts out really bad and dies. but after completely warmed up runs fine. (?)


ok no engine stated?
if gas engine, ?
I bet never tuned-up up in decade,right?> that gets 99% here.
but it can be far more complex, not guessing,,
what if , the ECT reads wrong.
and the PCM thinks you are in ALASKA,and you are in key west,FL..
so,it floods cranked. and cold running,same...

all EFI cars do that ,everyone, like that.'

forget heater (that blow'r motor sucks 15amps and alternator puts that load on the engine, breaking the CAMELS back, for get that
fix MISFIRE COLD that is the problem.!! real.

and new spark plugs top that list????
a rich engine needs more spark, and on HILLS

and scanning the ECT.
does ECT read correctly first thing in morning before starting engine
yes ECT can be scanned keyon, not started.

correct means if last night was 40f, the ECT is 50f in morning
or lower. say 41f.
-20f wrong, 0f wrong , got that? not blow average of last nights
ambient air temps or garage temps parked. there.
the air cleaner can be packed.up
the ISC valve stuck (my 4.0L did that ever 10k miles)most of the cured in 90s with better ISC
leaking injectr.
misfiring cold
and more
best is a tuneup ,pray, and work form there.
doing tests.

Feb 07, 2017 | 2001 Jeep Grand Cherokee

1 Answer

Could bad maf sensor and bad idle air valve have vehicle stall then hard to start for awhile and cuts off after 10 minutes of driving


I would also suspect the ignition module. They tend to work ok for a few minutes when they are cold, then fail once they warm up. If you wait awhile for the ICM to cool down, it will work as well as it can until it warms up again. A code scanner is your best friend to know where to start looking, and to perform tests and log data.

Feb 16, 2016 | 1997 GMC Yukon

1 Answer

1997 4.3 s 10 4x2 automatic.starts up fine when cold after warms up wont start at times some times if you hold it to the floor it will start after cranking it hard..Idels normal at time then it starts to...


this could be a problem with engine managment you can get it pluged in to a diagnostic tool and they will give a fault code these can be purchesed from well known aution sites for 30 pounds

Sep 19, 2013 | 1997 Chevrolet S-10 Pickup

1 Answer

After I drive my jeep some, if it is somewhat warm or not cold weather, my jeep has a hard time starting. It may crank but run a little ways and cut off going down the road.I have had the coil, plugs, plug...


if it shuts off after running for a while and will not restart for about 10 min,a bad crank sensor will cause this. abad crank sensor will make car shut off and not restart for about 10 min. put a scanner on to make sure. a check engine light does not allways come on. if you do not have a scanner, any auto parts store will scan it for free.

Feb 27, 2010 | 1997 Jeep Grand Cherokee

2 Answers

When i have crunk it in the morning it makes a


Change the oil pressure gauge and use heavier oil such as 10w40 or 10w50 if you have more than 100k you may want to use 20 w 50

Nov 25, 2009 | 1996 Chevrolet Blazer

2 Answers

I hear Noise when i back up in my 1997 Dodge Ram 1500


do you live in a colder climate? if when you start your truck in the morning and you hear a whine type of noise when you place your truck in reverse, the problem you have is likely a malfunctioning valve body. this problem is common with the 46re trans log onto http://genosgarage.com this site is dedicated to rams both diesel and gas. in the search box at genos type in tech service bulletins and it will list any tsb specific to your ram. it will describe the problem and walk you through how to repair. im pretty sure this is your prob. if you start your truck with the transmission in neutral and let the engine come up to temp before engaging reverse, this will reduce the noise. part of the problem is inadequate trns fluid circulating though the torque converter. placeing your truck in neutral while idling seems to improve fluid flow thereby reducing the noise.

Mar 10, 2009 | 1997 Dodge Ram 1500 Club Cab

1 Answer

Won't go into reverse this morning


reverse requires more hydraulic pressure to hold it in reverse. Maybe you have a partially plugged filter that the thicker, cold fluid can't get through. The whirr could be the pump in the trannie being dtarved for fluid due to being plugged. Otherwise, you may have a bad clutch or band for reverse that requires a trans overhaul. good lcuk.

Jan 12, 2009 | 2000 Chevrolet Silverado 1500

1 Answer

Engine cuts out when cold


check the engine and connect a heater for the engine

Dec 15, 2008 | 1988 Plymouth Voyager

1 Answer

97 Buick Century - Quit running


Its sound like a Crank sensor to me. Good Luck

Dec 12, 2008 | 1997 Buick Century

2 Answers

97 dakota barely warm heat


If replacing the thermostat dosen't work ,It is most likley the heater core.Don't worry it's not as bad as you think.You will need to flush it out.Disconnect the hoses from the firewall, in the engine compartment.You will find them to the left of the brake booster.A 5/8" garden hose will fit with the end cut off.You may want to place a length of hose on the opposite tube as well.Turn on the water and flush it for a few minutes.Reverse the water into the other hose to back flush.Reconnect the hoses and you should have heat.

Oct 14, 2008 | 1997 Dodge Dakota

Not finding what you are looking for?
1997 Chevrolet S-10 Pickup Logo

Related Topics:

136 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

70346 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6864 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...