Question about Cars & Trucks

Open Question

2011 Nissan juke has started to stutter when pushing accelerator on an incline. Seems ok rest of the time. Any ideas what might be wrong??

Posted by Anonymous on

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: When accelerating the engine seems to stutter.

Try unplugging your Mass Air Flow Sensor (MAFS) - you'll find it on top of the metal body immediately after the air filter. I went through an 18 month ordeal - replaced fuel filter, fuel pump, dropped fuel tank and cleaned it, ran 55 gallons of fuel injector cleaner through the system - nothing! After reading some blogs on this car/engine, gave the MAFS unplug trick a try. The car instantly corrected itself (when you unplug this sensor, the engine control module reverts to factory default, allows sufficient fuel into the engine for unitterupted performance.) However, if this corrects your problem, it's only a temporary fix. Run it about 3 days - it you notice soot in the tailpipe, the factory default is running too rich. Replace the MAFS.

Posted on Jun 02, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Nissan patrol forum


possibly cold start valve????????

Feb 19, 2014 | Cars & Trucks

1 Answer

Mazda 323 bj not exccelerating


ENGINE HESITATES WHILE ACCELERATION

LOSS OF ACCELERATION


It can be fuel pressure issue or it's the problem with accelerator pedal or its clogged filters causing there.

There are many other possibilities. I suggest you to go through the list of help links mentioned below, these will help you to confirm where the actual fault lies: -------

Jerks and Hesitates During Acceleration?

http://technoanswers.blogspot.in/2012/07/2004-dodge-town-country-jerks-and.html

-----------

Loss of acceleration?

http://technoanswers.blogspot.in/2012/02/loss-of-acceleration.html

---------

Headlights flickering and car hesitates to start?

http://howtobyme.blogspot.in/2012/02/headlights-flickering-and-car-hesitates.html

--------

How exactly the Vehicles Accelerator Cable works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-cable.html

-------------

How exactly Vehicles Accelerator Pump Diaphragm Works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-pump.html

--------

2000 Toyota Avalon: Engine Lean Codes and Knock Sound on Acceleration?

http://whatisbyme.blogspot.in/2012/05/2000-toyota-avalon-engine-lean-codes.html

---------

2004 Toyota Avensis: Acceleration And Deceleration makes noise on Front End?

http://whatisbyme.blogspot.in/2012/05/2004-toyota-avensis-acceleration-and.html

---------

Wheel hop under hard acceleration?

http://technoanswers.blogspot.in/2012/04/wheel-hop-under-hard-acceleration.html

--------

2009 Chevy impala accelerator pedal sensor?

http://technoanswers.blogspot.in/2012/02/2009-chevy-impala-accelerator-pedal.html

---------

Nissan Pathfinder stalls and bucks on Acceleration?

http://technoanswers.blogspot.in/2012/02/nissan-pathfinder-stalls-and-bucks-on.html

--------

Acceleration lag problem?

http://repairhelpcenter.blogspot.com/2012/01/acceleration-lag-problem.html

-------------

These details will help.

Thanks.

Dec 31, 2012 | Mazda 323 Cars & Trucks

1 Answer

2011 Nissan Rogue SL AWD has sluggish acceleration


Start by checking for codes. Even if no check engine light still may have code. Sounds like app code

Jun 16, 2012 | 2011 Nissan Rogue

2 Answers

I have issues with my wife's car 2011 Nissan Juke. There is a weird signal showing in the gauge cluster near the fuel gauge and i have no clue what it is.


Hi, are you referring to the CVT indicator in the picture below? It is supposed to indicate the direction the transmission is set in. There are several pages in the owner's manual on the CVT. If you don't have a manual, download one here: http://www.nissanusa.com/content/dam/nissan/pdf/techpubs/juke/2011/2011-Nissan-Juke.pdf

Please let me know if this is not it or you have more questiuons, and thanks for using FixYa.


jturcotte_317.jpg

Mar 03, 2011 | 2011 Nissan Juke

1 Answer

Accelerating/Transmission


possible transmission speed sensor problem.

Jun 24, 2009 | 1997 Nissan Maxima

1 Answer

Nissan QX 3.0 (2000) Engine stutter


Its a misfire and more than likely from experience a BAD injector or injectors. Check injector. Good Luck and Thanks for using FIX YA

Feb 15, 2009 | 1999 Nissan Maxima

2 Answers

Transmission overdrive Problem


you need a tps or adjust it. throttle position sensor .

go here for help

http://autos.groups.yahoo.com/group/villagerquest/

Jul 28, 2008 | 1995 Nissan Quest

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

33 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

74896 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...