Question about 2009 Chevrolet Malibu

Open Question

2009 Chevy Malibu rear defrost does not work. The light comes on, but the defrost doesn't work. Fuse is good.

I push the button for the rear defogger. The light goes on but the defogger does not work anywhere on the glass. I checked the fuse, it is fine. The cable still looks like its attached to the glass. I've read I could check to see if there is power to the glass with a meter. I put the contacts to the wire, but the meter did not light. Is there anywhere else I could check for that?

Posted by on

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 33294 Answers

SOURCE: Need wiring diagram of rear-window defogger circuit for 2008 Chevy Impala LT

Check for a broken or missing ground connection at the X2 terminal of the defogger grid. Then go back up the line from the grid to find where you are losing voltage. The black wire from the grid is spliced to a PPL wire and the PPL wire goes to the F1 terminal of the 40A BATT 3 fuse which you say checks good

Posted on Oct 30, 2012

  • 6 Answers

SOURCE: 2004 Chevy Tahoe, Horn doesn't work.

The button on you steering wheel is the problem, try to open it up and pull the spring just a little bit. I think you have used it too much ;)

Posted on Jun 16, 2012

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 2006 stratus sedan rear defrost dont work and will not light up


if you push on the rear defrost switch and it doesn`t light up then check the fuses with a test light. if the fuse is good then the defrost switch is likely bad.

Sep 17, 2014 | 2006 Dodge Stratus Sedan

1 Answer

Rear defogger won,t work


Check basic fuses first.

If the button that works the defogger lights up continue reading.
Many Impalas and Malibus have wiring that corrodes by the passenger side kick panel along the lower side A pillar. There is a connector with many pins that gets ruined. I dunno if malibus have a fuse box here as well like the impalas, but check there. might have to sneak a peek under the carpet. but it takes like 15 minute to check.
very common for defoggers that dont work when the fuses are good and the button lights up.

May 09, 2014 | 2005 Chevrolet Malibu Maxx

1 Answer

Malibu heating and ac


does the car have automatic climate control?

Apr 05, 2014 | 2005 Chevrolet Malibu

2 Answers

Rear window defrost not working on 2012 Chevy Malibu


I don't think its supposed to clear off snow, only fog or condensation. Try to remove the snow, and see if it will clear the fog. The wires connecting the defroster to the window should be on the side of the window, or behind a cover somewhere. Look for something like this:a26b694c-156d-416f-ab62-366c344c0aa7.jpg

OR:

ef620a1c-e2d3-4c13-a386-d7118527f529.jpg

dfe1867c-2676-4cea-a508-3f7cb747b6ca.jpg

555ce42c-ca65-4ac6-8fa5-3b7a5f57dbe4.jpg

Dec 15, 2013 | Cars & Trucks

2 Answers

WHERE IS THE FUSE FOR REAR WINDOW DEFROSTER WHAT NUMBER FUSE IS IT IN THE 2007 ENVOY


Does the indicator light come on when you turn the defroster on? Have you checked to see where the wires come in on the rear window to see if they might have gotten disconnected. It usually happens right at the point where the wire connects to the grid.

Oct 16, 2013 | GMC Envoy Cars & Trucks

2 Answers

Need wiring diagram of rear-window defogger circuit for 2008 Chevy Impala LT


i just fixed my car to the exact question above, it took 20 minutes total. yes I\'m good with a wrench, but this fix doesn\'t reqire you to be.

Problem: Rear defroster doesn\'t work, but the fuse is good and the little light comes on on the button.

Answer: Go to front passenger kick panel where the "other" fise box is and remove the pastic panel, it just pops straight up. Under the fuse block is a white plug that connects front wire harness to the rear harness. this is where the problem is. pull the connector off the body, my plugslide straight back. Now flip the whole connector over, there you\'ll see the burnt spot on the plug. losse, corroded connection causes melt down. this stuff happens. my car has a purple wire going into the plug and a black one coming out, this is the rear defroster wire. cut the purple wire aleast a half inch before the plug and cut the black one coming out of the plug the same, always leave a little wire incase you ever want to reuse that terminal, standard rule. now take two butt connectoers and a four inch piece of ten gauge and splice the purple and black wires back together. lots of current so DO NOT use 12-14 gauage wire, it will melt. and Wa-La, its fixed!! since you dont have to do the trouble shooting and chase down the wires like i did, should take you ten minutes to fix.

Now if this doesn\'t fix your car, then don\'t pay me!!

If this DOES fix your car, then take your wife out to dinner with the $150.00 i just saved you from having to take it to the dealer,

(they would sale you new connectors and harness)

Oct 30, 2012 | 2008 Chevrolet Impala LT

1 Answer

I have a 2009 Chevy Malibu 2.4L, the Service ESC light and Service Traction Control ESC light comes on almost daily. I pulled the code and it is C0131. My cruise control randomly won't work when


CK codes c0131 ABS/TCS system pressure circuit malfunction. Their is a Technical Service Bulletin out for this that is being addressed by chevy so you may want to get in touch with them.

Sep 19, 2012 | Cars & Trucks

1 Answer

I have a 2003 dodge neon..and the rear defroster doesn't work..it has a button for it..and it just shuts off and back windshield doesn't clear at all...even if I keep turning it back on it...


Yeah, I'd think it would have lines, too, unless some new way of doing it that I'm not aware of. Maybe the rear window was replaced with a window without the defrost option. There should be a small two wire connector coming out of the back shelf near lower driver's side of rear window. That would be the defrost connector to the window lines (that aren't there,lol).
Well, good luck with that! I think there are aftermarket kits for rear window defrost, though.

Nov 23, 2011 | 2003 Dodge Neon

1 Answer

My rear window defogger won't defog. I pushed the button and the light comes on but it still won't work. I checked the fuses, and replaced the relay but it still won't work. I thought maybe I need to...


check the supply that goes into the rear screen. that connector must have power when switch is "on". if got power, you need to change the window.....

Nov 23, 2010 | 2005 Chevrolet Impala

Not finding what you are looking for?
2009 Chevrolet Malibu Logo

Related Topics:

742 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75051 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7726 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...