Question about 1991 Mitsubishi Eclipse

1 Answer

Instument Guages Speedometer works,problem is this fuel, temp,oil,and the rpm guages on the instument panel stopped working. the lights work within the instument panel except for one. Have any ideas where to start looking? checked all the fuses they all look good. Is that there a relay that runs those items instrument panel. Help..Need my fuel guage! LOL

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 24 Answers

Well the issue is youe enitre gauge cluster i do understand that your speedometer is working but it is a cable speedometer not electronic like everything else in the gauge cluster so first i would recomend checking the voltage getting to your gauge cluster then just replace the guagecluster they are really cheap i a salvage and not hard to install at all but the cluster itself is not very comon to go out so make sure you check voltage to it first i wouldnt want you to go through buying and replaceing the cluster and that not fix it

Posted on Mar 25, 2009

  • darren jones Apr 28, 2012

    we got another instrumental cluster and it still don't work it worked until we plug in the dash warning light panel.

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Guages for a f350 ford truck .all 3 guages on the left side of instument panel are inop except for the oil pressure and its real low.


this is a common problem with the ford f-series the motors or the circuit board burned out on the back side. the cheapest and easyest fix is go to a local junk yard and get a used one this web site should help you locate a junk yard in your area that will have one... car-part.com

Jan 12, 2010 | 1992 Ford F150 SuperCab

2 Answers

All guages on console are not working, truck-GMC 2006 P/U


Factory defect. Take it back to the dealer. Had my entire instrument cluster replaced at 85K miles. Even though out of warranty, everything was free.

Dec 29, 2009 | 2006 GMC Sierra

1 Answer

Audi a4 1995 1,6l no rpm in instrument and warning


If you've just had the instument changed then its probable that the connector has come loose and will have to be re-connected. It could also be that the instument has failed. Take it back to the mechanic who changed the old one. This assumes that the car drives ok and all the fluids are topped up and ok.

Nov 04, 2009 | Audi A4 Cars & Trucks

1 Answer

Electrical issue with instument lights


Maybe a loose ground somewhere

Sep 28, 2009 | 1985 Jeep Cherokee

3 Answers

Speedometer, gas gauge, odometer, rpm gauge not working


My gas guage, speed odometer and tempiture does not work
The speed odometre is reading 9999999 what should i do

Jul 29, 2009 | 1998 Nissan Frontier

1 Answer

1999 blazer guages not working


It sounds like the wire harness in the back of the instument cluster has gone lose. Check the wire harness. Good luck

Apr 06, 2009 | 1999 Chevrolet Blazer

Not finding what you are looking for?
1991 Mitsubishi Eclipse Logo

765 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

60960 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...