Question about 1999 Pontiac Grand Am GT

1 Answer

1999 grand am speedo dosen't work. put a new senser in still dosen't work

Put a new senser in still dosen't work. dtc reads po56? on my snap on computer, low voltage to senser. car has been sitting for 10 years

Posted by on

  • jerry ladson Jan 14, 2013

    broken wire on the top side of trans

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 110 Answers

Sounds like you have some electrical corrosion in a connection somewhere in that system causing the low voltage. Take the connectors apart and clean them and that should help

Posted on Jan 09, 2013

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 184 Answers

SOURCE: coolant temperature guage not reading.havve

If the CTS is good, check the wiring and connectors leading to/from the ECT sensor and the PCM. More details @ http://www.obd-codes.com/p0118

Posted on Feb 11, 2010

  • 55 Answers

SOURCE: 1999 pontiac grand prix 3.1 starts great but sputters throttling

check tps sensor check idle air control valve or iacv for proper func

Posted on May 09, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1999 suzuki grand vitara 2.0 5 speed what speed sensor do I need and what colour


easter egg hunt 1million
Car speed?
or ABS speed sensors. we cant guess, whats wrong, can we.?
USA car,? we are USA, cars not here are vastly different.
so........????????
why ask not telling problem? scans told you sensor is bad
post the DTC error. speedo dead.Odom, dead? what?
J20 engine ,
5 speed stick shift box. manual trans,,m/t
4wd or 2wd?
toss coin NOT ABS sensors.
there are 2 speed sensors ill do all 3 permutations of car
4wd one or tail of transfer case
2wd one on tail of 5speed box.
any, the backup speed sensor in the speedometer cluster
89-98 years and was deleted 1999, usa.

why ask ,tell why. so we can be on the same page and
not have to document all the above.

color is of on concern, only correct part numbers matter !!!

colour (non usa spelling) is my only real useful HINT.
never said speedometer fails. or odometer fails
the trans is manual so no speed sensor needed ever there to shift automatially,its a stick

scan it yet.?
THAT BE FIRST.

i looked at our 1999 usa GV . serv. man
best i can tell speedo has new electronic head.
no speedo cable. first year, in fact. (i owned a 97 and 04)

so when VSS goes dead (say)
the speedo goes dead
odom goes dead
and ECU sets DTC errors for VSS dead.
3 clear symptoms.
some cars have different VSS1 to match, axle gears.
the vss gear on end .

on newer cars with stick shift
like mine now
the aBS sends speed to PCM
so there is no transmission speeds sensors at all , 6sp, m/t
so lacking symptoms, me bollixed.

Feb 28, 2017 | 1999 Suzuki Grand Vitara

1 Answer

Speed senser reads 7 miles slower thin what I'm going


changing any spec on tyers or rims from original is going to change the speedo. you need to get the speedo recalibrated.

Mar 09, 2014 | Cars & Trucks

1 Answer

Speedometer going crazy


USA or non USA car. not knowing this makes answers , all wrong.
define crazy.?
if bouncing like mad"? is
1: the cable to it bad. if cable good ,speed is bad, (tests, ask)
2: if the cable gets bad enough the CEL comes on and shows bad VSS. (DTC) veh.speed sensor, dead.
oops 99 is a cust year,
every page in fsm (related) shows if equipped.
cable speed (old school)
electric gauge, no cable. new cars. cusp year.
that means , one looks for the cable to the
tranny or to the not stated 4wd transfer case.

if its a 100% electric gauge
and crazy means bouncing?
its:
A: bad meter.
B: bad power to meter (or loose fuse or speedo connector plug)
C: Bad ECU (hah)
D: vss input to ECU is crazy,

or go to alldata.com and read, its all there. RTM.




Nov 21, 2013 | 1999 Suzuki Grand Vitara

1 Answer

Some dash lights on my 01 ranger don't work.the bulbs are good


Get an Auto Electrician to trace and fix the problem. There are partial contacts in the wiring system.

Dec 29, 2012 | Ford F-250 Cars & Trucks

1 Answer

How to I Install a Universal Oxygen Sensor? on 99 nissan quest orjinal wire collers are wite,black,blue,yellow new universal senser has black, black,white,blue


I'm not sure what kind of universal sensor you got but having been in this business for over 25 years and own a shop now I would like to make a suggestion to you. Take the universal back. Your system has a heated O2 sensor and a universal will just not do the job and you may still get DTC's (the engine light will come back on). Even if you need to go to Nissan and spend a little more money for the sensor, it will work correctly. Even though your vehicle is older, it still depends on readings from the sensors to the computer in order for it to run right. This may also help gas mileage by putting the correct one in not to mention if your vehicle runs richer or leaner you will end up doing a tune up on it sooner then normal so the extra money you spend now will pay for itself later. Your not my customer so I'm not making money off of you just trying to give you a tip. I hope you take the advice. If you do still want to put the universal on you may end up contacting the manufacturer in order to get the correct wiring for it unless someone has it on here but they would still need to know who made it.

Jun 23, 2011 | 1999 Nissan Quest

1 Answer

Speedo not working on renault kangoo 1999 still clock up the miles fuel gauge and temp gauge are still working


If its still clocking up the miles then the speedo its self is faulty,Fit new ometer.Not senser.Good luck

Sep 15, 2009 | Renault Sportwagon Cars & Trucks

1 Answer

Speedo sometimes failed to work


I had this exact problem on my old focus. Its nothing to worry about and its not expensive. Your car has a speed senser underneath the gearbox and a common fault on these cars is for the gearbox to slightly drip oil. When the oil drips it drips right on top of the senser and blocks the speed readings.
The good thing about this is your milage on your car wont go up when the speedo stops working, so when you come to sell it!!!!!!! you get my point.
to fix this problem it cost about £20 if you do it yourself.

Feb 18, 2009 | 2000 Ford Focus

Not finding what you are looking for?
1999 Pontiac Grand Am GT Logo

Related Topics:

85 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pontiac Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8152 Answers

Are you a Pontiac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...