Question about 1994 Oldsmobile Achieva Special Edition

1 Answer

94 olds achieva 6 cyl coolant problem: after startup water temp keeps rising past 195 degrees; as it does i instantly lose my heat. temp will get up to 40 then it drops back to 185 and when this happens my heat comes back hot. it will go thru this cycle 3 or 4 times and each time the temp wont go quite as high and finally runs at a normal tempature. i changed the thermostat, flushed the system and bled out the air ( it seems like air in the system )

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,118 Answers

A few things come to mind from reading your problem, first your right about the air, it could still have some in it, i know from experance they can be a bear to get all out. secound if your sure you got all air out, the only other thing it could be is a blowen head gasget. third if you suspect head gasget do a coolent system pressure test, and watch for leak down.

Posted on Jan 20, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 2008 hhr ss temperature goes from 196 to 210 on the road. Can I drive 1001 miles? While driving the coolant system goes down and then goes up when it's parked. Is it good or bad idea?


I'm fairly sure what you described is normal operation.
The thermostat opens at 195-197 degrees and the radiator fan kicks on around 225 degrees. So the normal range is between those numbers. And the coolant tank would rise when you turn the engine off because it stops flowing.
As long as the temp stays under 220 and you are not losing coolant you should be ok.

Apr 04, 2016 | Cars & Trucks

1 Answer

Air lock cooling system


Not sure I follow your wording on the different temps. If the system is full of coolant and working correctly, the thermostat should open at 195 degrees which would be several miles down the road. Once the thermostat opens both radiator hoses should be warm. If the water pump is not working the engine will get hot very quickly.
Have you tried running without the thermostat to see what happens ?

Mar 05, 2014 | Hyundai Elantra Cars & Trucks

2 Answers

What is the average temp for a 1996 Pontiac Gran Am 2.4 L 4 cyl? Any info would greatly be appreciated.


the engine temperature is 195 degrees when ran for 15 minutes or more with the correct thermostat installed

Aug 18, 2011 | 1996 Pontiac Grand Am

1 Answer

Why would a 1994 Oldsmobile Achieva S quad 4 engine temperature gauge fluctuate between 195 & 220 degrees? The thermostat has been changed and the engine and radiator have been flushed. The normal...


either the thermostat is getting ready to fail or the temp sensor isnt working properlythese engines also leak fluid from rear side of head after getting hot so check that so may have air in system because of the blown head gasket

May 28, 2011 | 1994 Oldsmobile Achieva Special Edition

2 Answers

After car has reached operating temp, if I don?t move for a while the temp. will keep rising. I notice that the fans have not been coming on, but they do turn on when I turn on the A/C. Where is the...


on your car are two sensors one is an engine temp sensor the other is a coolant temp sensor
change the coolant temp sensor that is what goes bad most of the time when the water gets to 210 degrees the coolant temp turns on of that is working change the radiator fan relay

Mar 03, 2010 | 1996 Chevrolet Impala SS

1 Answer

93 jeep wrangler 6 cyl. my temp gauge never shows full temp. only goes to about 130 degrees. I have a 195 oem thermostat but still gauge does not climb above 130,...bad gauge, wiring???


Assuming the t-stat is good, I'd look at the wiring next. Make sure the connector is clipped onto the water temp sensor/back of the gauge and that the wiring is not chaffed, etc. If that all looks good, replace the coolant temp sensor...they're $20 or so. If it still does it, the gauge is bad.

Apr 15, 2009 | Jeep Wrangler Cars & Trucks

2 Answers

1994 pontiac firebird HAS NO HEAT


Okay. warm up vehicle, get radiator hoses hot.  Turn on heater, fan on low.  Grip both rubber heater hoses close to the firewall, from the engine compartment side.  They should be too hot to hold for long.  If they are not hot, then you have a lack of coolant circulation to the heater hoses.  If they are hot then access heater core, behind glove box area.  Blend door which moves as you chose HOT or Cold, should be cable controlled, move the controls and be sure the door is actually moving. Keep me posted 

Dec 17, 2008 | 1994 Pontiac Firebird

1 Answer

Coolant temp stays low


I believe when they replaced head gasket they installed too cool of a thermostat in it. need to replace thermostat with proper one should probably have a 195 degree one in it

Nov 06, 2008 | 1998 Dodge Stratus

Not finding what you are looking for?
1994 Oldsmobile Achieva Special Edition Logo

93 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

60769 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...