Question about Cars & Trucks

1 Answer

I have a 2004 Chevy impala, it recently shut down n stopped working ... I thought it may have been bad fuel so I put fuel cleaner the car ran for about 2 hours but it still had to b driven on breaks n gas at the same time when I stopped now it won't start. I've changed fuel filter, fuel pump, crank sensors spark plugs wires, new battery etc. it now starts but when I place it in gear it kills. What else could it be?

Posted by Anonymous on


1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 20 achievements.


    An expert that got 10 achievements.


    An expert that got 5 achievements.

  • Cars & Trucks Master
  • 13,758 Answers

Did you ever hear of testing systems before replacing parts ? Fuel pump pressure an flow testing ,voltage drop testing the electrical circuit ,current draw . viewing scan data for sensor's etc...
002 Fuel System Tests Start Here
048 Engine Hard to Start or No Start Scan Data for Starting Problems

What you should have done is take your vehicle to a qualified repair shop.

Posted on Jul 21, 2017


2 Suggested Answers

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: 2004 Kia Optima no start after timing belt, crank, cam sensor replacement

did you use aftermarket crank sensor? if so that might be your problem. dealer has several different ones, by providing vin number, but there is only one after market for all optimas 01-05. try to connect thick pink wire and thick orange wire together on the ignition failure sensor. you might have the same problem as me. good luck.

Posted on Jan 15, 2010

Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

2004 chevy impala won't start put a new fuel pump in and started ran 20 minutes then drove and shut down it cranks but won't start please help

make sure the fuel is getting through you might have an airlock in the need bleeding to get all the air out.

Nov 09, 2016 | Cars & Trucks

1 Answer

Y does my 2001 chevy impala die occasionaly while

Make sure your Car is not on the defective switch list...If not it may be your fuel pump starting to most cases a bad pump the car should not start right away after shutting down but will start after setting for a short period..until eventually stops all may want to have a pump pressure test done it will detirmne if proper pressure is getting to the injectors or carb...good luck..

Aug 29, 2014 | 2001 Chevrolet Impala

1 Answer

Ok i have a 1995 chevy caprice with a 5.7 LT1, the problem i have is the car shuts off while its running and i dont have all my hoarse power. i put the engine in last week and the car ran for 2 days

The engines should be much the same.
Is the check engine light on ?
Do you know what you are loosing when the engine stops ?
Fuel or spark ?

Mar 01, 2013 | Cars & Trucks

1 Answer

2000 chevy impala 3.8 was driving and made a turn and car shut off tried to start it back up and it would start but stumble alot and then shut off couldnt get it started for a while then once it sat for a...

Is the engine light (MIL) on? what are the codes?. I would replace the fuel filter first as it might be bad and if the problem presists then check the fuel pressure.

Oct 12, 2011 | 2004 Chevrolet Impala

1 Answer

2004 impala fuel gauge not working

when you changed the fuel pump, did you bump the sending unit in tank. or a wire to tank may be the problem. maybe sending unit in tank is bad!

Sep 15, 2009 | Chevrolet Impala Cars & Trucks

1 Answer

Chevy Aveo - Lousy Fuel Milage, From 33+hwy to 19mpg

try giving your car a simple service, change oil, oil filter, air filter, plugs and leads etc. also get your wheels aligned and balanced as having bad geo can also be bad for fuel consumption. if that doesnt work then id recomend a garage.

Dec 18, 2008 | 2004 Chevrolet Aveo

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

28 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts


Level 3 Expert

77947 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14405 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides