Question about Cars & Trucks

1 Answer

Rev meter not working and engine light on console on , and car just stops when driving

Rev meter not woking ,engine sign has come on and car just stops while driving

Posted by on

  • cheryl thomson Jan 06, 2013

    2002 nissan x trail ti

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Sounds like an ignition problem, but without knowoing the year / make / model anything is possible

Posted on Jan 06, 2013

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 8 Answers

SOURCE: after a stop car wont drive, 98 Taurus

This may be the Vehicle Speed Sensor (VSS). It generates the speed signal that drives the speedometer and gives the signal to the electronic transmission control. It is a sensor that has a plastic gear on the end that is turned by the transmission. Look at the speedometer when the transmission shifts to neutral on its own, if you are moving, and you will see it at 0 MPH if its the VSS. It may or may not show up as an OBD-II code P500,(VSS fault) or P502 (VSS intermittent). My 1998 used to do the same thing when I left the driveway, but only in the morning. It would electricallly shift to neutral, I would put shifter to N and back to D and it would be OK. It continued occasionally for about two years with no codes or Check Engine light until it suddenly got worse and it would not correct itself after ******** to N and back to D. The code then showed up as P500 or P502. The VSS is about $50 at NAPA or about $25 at Advance or AutoZone. It is a pretty easy but hard to see replacment. (get a Craftsman round inspection mirror) It is located in the top of transmission, passenger side, sort of under cylinder #1. It is held in by one small bolt. I think I used a 10mm 1/4" drive socket to get it. A Haynes book will help, but beware, they don't tell you that the VSS is enclosed by a square tube heat shield and the photos stink. You will see the wire going into the square shield tube. Pull the shield up to get to the VSS and unplug the wire. IMPORTANT: Haynes says to check the VSS output for a pulsed AC voltage output. My VSS produced a pulse voltage when rotated, but it was still bad. IMPORTANT: take old VSS with you to match new one. There are more than one part called out for this year model and they look almost the same. I hope this helps..

Posted on Feb 12, 2009

rockitman187
  • 2559 Answers

SOURCE: 1997 Mitsubishi Galant Died

Sounds like the EGR valve is bad and is stuck in the open position.Just replace that and you should also check the catalytic converter.

Posted on May 01, 2009

  • 1 Answer

SOURCE: engine light is on ,code P0171, hesitates when start driving

If you have had a bad enough problem with the fuel filter, and it is not the fuel pump I would have to say it is the injectors. If your car is fuel injected there could be dirt in the injectors in which case they will need to be replaced. The problem is you can flush the whole fuel system except for the fuel injectors themselves. Though I am not sure how to check them myself, a mechanic could tell you if this is the problem in minutes. I cant say for sure if this is your problem but I have a 79 corrolla and it is doing the same thing and since I have replaced almost the whole fuel line except for the injectors themselves this is what I am leaning towards. Good luck!

Posted on Jun 08, 2009

  • 12 Answers

SOURCE: Car stalls while pulling up to stop signs or red lights

check battery connections tighten altenator belt or replace altenator

Posted on Jul 07, 2009

  • 99 Answers

SOURCE: mazda 626 hold light flashes

it's probably the problem with the sensor failure or the switch fails to completely off the current flow, it's a miner issue so for hazel free drive do visit the nearest MAZDA authorized service station or see for a good skilled & experienced mechanic who may sort out this problems so till the next this is siddhesh saying bye for now feel free to ask any quires regarding automobile field we will be happy to help you so till the next time have safe drive & happy motoring.

Posted on Oct 08, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Engine revs high and low all the time when stopped


run the fault codes and check for faulty MAP/MAF/VAF sensors

Mar 23, 2014 | Mazda MX-3 Cars & Trucks

1 Answer

My 96 ford taurus revs high when starting then works it way from 1500 or more down to 800 but fluctuates from 800 to a little over 1000. When putting car in rverse or drive from park engine revs up to...


You need to clean the IAC again and also the throttle valve and bore, use only CRC brand Throttle body cleaner. After they are thoroughly cleaned disconnect the battery for 5 min's and then drive the car in varying condition for a few days. If that doesn't cure the issue you have more serious problems and will need a scan tool to look into the readings from the MAF, TPS and ECT sensors. High idle cold start is normal then slowly dropping after a few minutes. I assume you never had a check engine light. Correct?

Mar 24, 2017 | 1996 Ford Taurus

1 Answer

When i first crank the car it idles at like three or so then goes to zero and cuts of it does this a few times especially if i push the brake, i have learned to rev engine lightly and press brake and put...


Might be a leak on your brake booster (this will most probable give you a hard brake pedal or a "sucking sound " when applying brakes) also check the vacumm pipe from the engine to the brake booster. It might have a leak, so when you press the brakes it influences the air mixture.

Dec 14, 2012 | 2000 Nissan Maxima

1 Answer

1993 chrysler acclaim 3.0/6 cyl misses or hits while engine cycles this while in idle or drive ex; sitting at stop light.


if it sits there and seems to rev up and down, it is probably your throttle position sensor. Mine acted up very bad, expecially when leaving the highway back into city driving when at a stop sign.

Dec 03, 2010 | 1993 Plymouth Acclaim

1 Answer

When stopped at light/stop sign, rattling comes


Inspect the motor mounts for cracks or breaks in the mount. Ask a friend to stand at the right front fender with the hood open while you start the car. Make sure the emergency brake is on and you block one of the rear tires in front of it and in back of it with a brick or similar solid material. Put the car in drive (1st gear for manual transmission) and with your foot on the brake pedal rev the motor for a few seconds at about 1500-1800 rpm as your friend watches for excessive left and right movement from the engine. Then do the same in reverse and have him stand on the left side and do the same. If one mount is bad it is recommended that all the engine mounts be replaced. There are usually 2 or 3 for the engine and one for the transmission.

May 14, 2010 | 2005 Mazda 3

1 Answer

Well when I drive the car for a bit, and it is warmed up when I start to decelerate coming to a stop the car will **** and when I come to a complete stop it will start jerking and then die. If I put it in...


In my opinion it could be:
1. Battery discharged
2. Battery connections loose or corroded
3.Air filter element dirty or clogged
4.Fuel injection system dirty or clogged

I would go for this last and check the air intake meter, clean the injectors, etc.

Apr 17, 2010 | 1992 Oldsmobile Cutlass Ciera

1 Answer

1995 buick lesabre engine revs up very loud, then normal when


I saw exact same problem for few days. Now I see check engine light all the time and engine speed is normal.
The cruise control stopped working. Cruise control sign so nOT light up when I turn it ON. Nor does it works.
But car seems to work fine.

Mar 21, 2010 | 1995 Buick LeSabre

1 Answer

Car stalls while pulling up to stop signs or red lights


check battery connections tighten altenator belt or replace altenator

Jul 07, 2009 | 1997 Mitsubishi Mirage

1 Answer

Engine shuts off somtimes when I'm driving.


could be your comp. is your check engine light ever on? or a crankshaft position sensor.

Apr 19, 2009 | 2001 Chevrolet Blazer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

29 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...