Question about 2002 Ford Mustang

1 Answer

Service engine I have a service engine light on i am running too lean and either both 02 sensors gone bad at same time or something else, any suggestions also where is the fuel filter located?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 10 Answers

If you want to change you fuel filter it take a special tool for a ford it should be in on the inside frame under the drive side. Also try taking your car to and auto part store and have them run the obd 2 code reader to find out why your engine light is on they usual don't charge for that

Posted on Jan 20, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I am getting po171 on my 1996 jeep


only that code???????
which engine? of the 3. (ill pretend 4 liter I-6,)
how many miles one engine, and do you service it? fully?
the fsm covers this. need that?
171 is lean AFR. lean AIR/FUEL/RATIO. (or lean fuel mix)
it means the 02 front sensor B1S1 is lean.
the fsm lists 10 causes after a new 02 , dont cure it.
first is low fuel pressure.
in geek speak (ASE) it means fuel trim show gross lean.
the OBD2 systems have trim level trip points.
if you were to scan the PCM youd see LTFT way the heck off.
and id fix that first.
the 171 means the 02 is stuck at 0v. super lean.
or is shifted lean,, only looking at it with a scope or scan tool shows
you what it is DOING.
if stuck at 0v, idling, its bad, the sensor or there is and exhaust leak
allowing outside 20% oxygen to hit this sensor and slam it horrid lean for ever.
that is why you just scan it and look. not just a useless code reader.
good scan tools you can scan and graph the 02,
and see this.
if i dont see this, i then work this full time. with a battery of tests.
there are many causes.. over 20.
http://www.fixkick.com/ECU/Authority/A_Full_OBD2_scan.html

see blue line in the full scan graph?
we can scan and graph 12 values at once, 1996 car too. any car.
see DSO photos(scope)

the full manual is here chapter 9 cover this 100%

http://www.jeep4x4center.com/knowledge-base/index.htm?utm_source=cj#service


me,. i try an new 02 , and with that i know it can't lie.
and then use the to find why.
weak MAF (Dirty)
intake leaks (maf engines)
exhaust cracks. hoepless this.
gross misfire sends 20% oxgen down stream, so i look for misfire like a hawk. felt , heard or see engine shake that is misfire.
low fuel pressure 58psi is good.
those are the big ones.

good luck.

btw, if a V6? or other V engine
a bad maf will cause both banks to go lean. (mines a 3.8L v6)
so.............. no engine stated, no details....


Mar 01, 2014 | 1996 Jeep Grand Cherokee

1 Answer

Fouls plugs after 50-55mph


its rich, (which engine, there are more than 1) ?????
and is not in closed loop mode (ECU) fix that first.
so diagnose rich.
EFI engines. no country stated, as others have carbs way newer,.
1: too high fuel pressure, (gage it) alldata.com has spec. and steps.
2: injector(s) leak. same tool above finds this, ask.
3: ECT reads low temp all time time, (thermostat bad, or missing?)
4: IAT reads too low. (TBI engines, with MAP sensors)
5: 02 sensors bad. (if all else is good and o2 reads wrong its bad)
6: exhaust leaks near, 02, causing o2 to read lean, forcing max rich.
7: did you run the ECU scan codes? the Check engine flashing light using the diagnostic jumper , yet?

mostly those. there are tests for each. ASE ways and means.

if your swift has a heated 02 sensor, it can even hold closed loop
at idle..... sure can, and if so , i check that first.
then closed loop at 2500 rpm , in neutral. (how is complex)
on these old dogs. suz, the worst ,no scan tools. are sold over the counter. so I must use a scope.
i watch the 02 sensors output. and make sure engine goes to closed
loop, if not i fix that. first.
there are ways to do this, (by me forcing lean or rich using other tricks of the trade. ask. I do so , to see if i can wake up the o2 sensor.
this is all covered in ASE courses...... this magic./

id be all over, fuel pressures, REAL not guessing or squirting checks bs.
id be all over exhaust leaks near the O2.
and first a new 02. most cars, its like long ago ,dead and you
look and the tip is , GONE! 1992 oxy sensors are useless.




Jan 21, 2014 | 1992 Suzuki Swift

1 Answer

1999 Ford Explorer XLT 4.0 SOHC 4x4 code P1151 bank 1


Ok this is either a shorted wire or bad connector or just plain a bad 02 sensor or a stuck injector or bad PCV needs cleaned. You stated it runs great i would go with Bad 02 sensor first or check for possible exhaust leak and last check for bad converter.

Apr 07, 2012 | Cars & Trucks

1 Answer

SYSTEM TOO LEAN BANK 2 MUSTANG 2002 3.8 ENGINE


Generally if the vehicle is running lean on one side the O2 sensor is bad. The oxygen sensor is normally located at the back of the exhaust manifold, and there is one on each side. It is best to replace both at the same time to save money and problems later on.

Dec 25, 2011 | 2002 Ford Mustang

1 Answer

I have a 04 f150 with the 5.4 check engine light is on and it read o2 sensor changed twice still read same problem


you have to figure out what is causing the 02 to activate the light, lean or rich exhaust emissions? what its saying is the sensor is working and it has detected a bad emissions or fuel mix in the exhaust, it is not telling you the 02 is bad, thats what the sensors do they detect faults with temps,knocks,emissions, timing,crank position, fuel air mix,throttle position. so the 02 is detecting something and that something is what needs to be found.

Jan 21, 2011 | Ford F-150 Cars & Trucks

1 Answer

I have a 2000 Hyundai Sonata that runs rough when you start it up. I hooked a code reader to it and it said that system was lean on bank 1 and multi misfire and not reading 02 sensor on bank one. I have...


time to get the engine properly scanned, real time not code scanner, then you will have the readings from sensore and actuators, diagnose from there

Dec 14, 2010 | Hyundai Motor 2004 Sonata

2 Answers

I have a 2002 chevrolet blazer with a 4.3, 4dr, 4wd. Service engine soon light came on, took it to the auto part store to code it they said knock sensor, 02 sensor, low evap voltage or something close to...


No I don't think so, knock sensor only work under engine load, when sensor picks up a ping or knocking, it will adjust timing, o2 sensor could be bad, and will save you fuel mileage, but a miss will also give you an o2 sensor code, running rich, have him check for cylinder miss first.

Aug 13, 2010 | Chevrolet Blazer Cars & Trucks

1 Answer

HI THE CHECK ENGINE LIGHT IS ON IN MY LINCOLN TOWN CAR 95. THE CODE SCANNER READS "TOO LEAN" WHAT THAT MEANS? AUTOZONE PEOPLE IT SAYS THE 02 SENSOR IS BAD, IS THIS CORRECT??? THANKS.


what code did they give the code will tell u something like "o2 lean bank ? sensor?" and if auto zone is telling u that its giving an o2 sensor problem most likely thats the trouble code that showed up and which sensor

Oct 21, 2009 | 1995 Lincoln Town Car

1 Answer

Running lean


02 sensor is what causes lean and rich mixture. If it is not correct then 02 sensors beed ti ve reokaced,

Sep 29, 2009 | 1999 Lincoln Navigator

Not finding what you are looking for?
2002 Ford Mustang Logo

135 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60867 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...