Question about 1999 Chevrolet Silverado 1500

1 Answer

91 1500 fuel pump works but wont start no fuel coming out of injectors

New relay was running when parked

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 54 Answers

Have you checked your fuel filter? also may be a problem with your fuel pressure regulator. also consider fuel pumps are known to get weak. good luck

Posted on Jan 03, 2013

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 36 Answers

SOURCE: starts then quits

Try the ignition control module located under the distributor cap $30 - $60. This is one of two parts on this truck that will cause it to not run or shut down after running for only a short time. The other is the fuel pump I think it is safe to rule that out as your problem

Posted on Jan 08, 2009

  • 523 Answers

SOURCE: no power to fuel pump no hum when key on and inj not pulsing

I can't speak for the electronics in your Chevy Sub. however I had experienced this same problem on my Montero and on my son's Dodge Stealth (it too is a Mitsubishi) in both cases I had spark but no injector pulse. In the end both ended up being the engine ECU units, once changed they ran and are running fine. Any chance you know someone with the same truck? If so confirm the part number and swap in their ECU unit. If your car then runs you know the answer. Good luck!

Posted on Aug 16, 2009

  • 1 Answer

SOURCE: my injectors have no power going to them. i just

my injectors have no power ging to them. i just replaced fuel pump and relay. i have fuel going to my 350 tbi but nothing coming out the injectors. it wont start and i have no power at the injector so i dont know if its the ecm or what

Posted on Dec 20, 2009

  • 3600 Answers

SOURCE: 90 chevy k1500 350 tbi fuel problem starts but wont stay running

try bypassing the oil pressure switch on the back of the block behind the distributor, if there oil pressure switch goes bad it will do this. had one that drove me nuts trying to fix it then figured out I had to buy a book and low and behold thee it was 3 wire oil pressure switch you can't see between the engine and fire wall just behind the distributor and costs 8 bucks to buy new.

Posted on Jan 16, 2010

  • 409 Answers

SOURCE: 1988 silverado, tbi 350 has 12 psi fuel pressure,

Fuel pressure is a little low, check the pressure regulator, and the fuel filter

Posted on Mar 09, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

1994. Why won't it start?


If the fuel pump/s continue to run with key on, suspect a relay issue. The relay is grounded by the vehicles computer. If the computer supplies a constant ground, the relay will continue to stay closed and power the fuel pumps constantly. If the the ground wire that comes from the computer to the relay is shorted/grounded, the relay will stay energized as well. As for the no start, are the injectors getting a power and ground supply? The ground side of the injector is controlled by the computer as well. Is the vehicle getting spark at the coil/plug? Have you scanned the computer for any trouble codes?

Nov 29, 2015 | Ford F-150 Cars & Trucks

1 Answer

95 Taurus 3.8 SHO wont start replaced everything fuel pump to big relay is buzzing even new one im lost need help


Run tests. Fuel pressure correct? Spark at plugs when cranking? Fuel injector pulse working? Compression test?

Apr 06, 2015 | Cars & Trucks

2 Answers

My 2005 l200 wont start but if you run a lead from battery to switch on pump it starts take lead of and it stops new switch on and still no start.


The fuel pump is powered from a relay. That relay is powered by the engine's computer ("ECU"). The relay is necessary to scale the low current control signal from the ECU into a high current switch to operate the fuel pump. The high current circuit will likely contain a fuse. That fuse or the fuel pump relay may be defective.

The fuel pump relay is activated for a few seconds when the ignition is turned on before starting the engine. If everything is working properly, you should be able to hear the fuel pump run for those few seconds before starting the engine. This is so the injectors have adequate fuel pressure before the engine is started.

Apr 11, 2014 | Mitsubishi Pickup Cars & Trucks

1 Answer

Turns over,but wont start.


Did you check base fuel pressure with a gauge before and after replacing the pump ? Is the pump getting power from the relay ?
The fuel filter is under the car and should have been replaced with the pump.

May 15, 2013 | 1995 Buick LeSabre

1 Answer

I replaced the turn signal switch and now it wont start. i can hear the fuel pump kick on. makes no sense


You said you hear the pump come on, then said fuel pump not running ???
Check the fuse for the pump, preferably with a test light to verify power is there. Key must be in on position. If the fuse is powered, feel for the fuel pump relay to click when you turn key to on. Put your finger on it while someone turns key to on. If it clicks, check for power at the tank connector on the pump wire, while the engine is cranked. If power there when cranking, the pump must have failed and needs replacing. If the relay clicked with key on, and no power at the pump wire at tank while cranking, then check wiring from relay to pump connector-the fuel wire may have broken.
If the relay doesn't click when key turned on, check for the power feed for the pump at the relay terminal. If the relay has power available to be transmitted to pump, then the relay's signal from the computer or the ground side of the relay's coil signal (from the computer) may need checked.
If the pump is working, and you have good pressure in the lines, check the injector circuit. Also a fused circuit, so check the fuse first. The injector should have a steady voltage signal to it with key on. The injector only has two wires, the power wire and the ground wire which goes to the computer. When the computer momentarily grounds the injector circuit, the injector "pulses", causing fuel to spray out the bottom.

Apr 15, 2013 | 1988 Ford F 150

1 Answer

2000 mercury grand marquis 4.6 Intermittent problem. 35,000. miles. Problem engine died several times wile driving. Also after car is parked from a drive will not start. Found that the fuel pump is not...


I'd have to test when problem is ongoing. When you first turn on key, no crank, you should hear the pump run for a few seconds then stop. For initial prime, the computer doesn't need rpm signal. Engine cranking, the computer needs to see rpm signal or it won't ground the fuel pump relay. W/o rpm signal, no spark at the plugs and no fuel injector pulse. I know your talking about fuel, but, when problem is ongoing, check spark and fuel injector pulse, engine cranking.
Intermittent problems are a pain, have to test when problem is ongoing.
mercury fuel pump-i4kx0gxqalhdz4ok10irisui-5-0.jpg

Feb 27, 2017 | 2006 Mercury Grand Marquis

1 Answer

Im working on a 1986 toyota pickup 2.4l efi non turbo 4x4 i replaced the head gasket and i have a black wire coming from the intake wiring harness that has no plug on it .if i touch this wire to a hot wire...


Sounds like this wire should operate the electric fuel pump through the fuel pump relay.The fuel pump relay should start the fuel pump to maintain fuel supply to the common fuel rail and any surplus fuel will be bleed back to tank by pressure control.The injector opening sequence is contolled by computer once the engine is properly timed.
If you say the engine runs for a few seconds it would indicate fuel pump or relay is not getting power to operate or fuel pump is not delivering enough pressure to feed the injectors

Apr 29, 2011 | 1986 Toyota Pickup 4WD

2 Answers

I have a 1999 chevy blazer that will turn over but won't start. prime with fuel runs untill it runs out. have code of p1351 in it


Need more info.......It could be the injectors are not pulsating...Check to see if it is spraying fuel from the injectors....If not it should be a clogged fuel filter or a fuel pump....It is almost definite though that it is the fuel pump/sending unit in the tank ...IF it is not spraying from injectors....
Disconnect battery remove main fuel line going in the fuel filter under vehicle frame at drivers side..with drain pan under it of course...Reconnect battery turn engine over and watch for fuel...
You will need an assistant...Most people think fuel is under great pressure but it is not.....If everything works the fuel will come out in a stream...But it wont come out like a bullet...
If fuel comes out Fuel pump in tank is good...Then your problem is at the injectors ...I would change the filter of course anyway...unless you just have...You will see rusty dirt come out of it if it is clogged...It is always good to change fuel filter every 15,ooo....Todays fuel is terrible...I would first check or swap fuel relay with a new relay or identical relay in fuse power block ...Make sure they are all good....................What engine and how many miles ? Hope this helps....Metalpoet

Apr 17, 2011 | Chevrolet Blazer Cars & Trucks

1 Answer

My injectors have no power going to them. i just replaced fuel pump and relay. i have fuel going to my 350 tbi but nothing coming out the injectors.it wont start and i have no power at the injector so i...


my injectors have no power ging to them. i just replaced fuel pump and relay. i have fuel going to my 350 tbi but nothing coming out the injectors. it wont start and i have no power at the injector so i dont know if its the ecm or what

Nov 08, 2009 | 1988 Chevrolet K1500

Not finding what you are looking for?
1999 Chevrolet Silverado 1500 Logo

39 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75744 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8123 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...