Question about 1994 Chevrolet S-10 Blazer

1 Answer

94 s-10 blazer lost power and brakes

I have a 94 s10 cpi and have changed everything i can think of to try to fix the lost power and hard pedal. It will take gas as long as it is in park and idles roughly, and when you put it in gear it will quit when you give it gas or if it will go you can have the pedal to the floor and it won't go over around 15 mph. I've checked the vacuum lines and replaced all the sensors and filters. No codes come up when we've checked. I read on another post that the problem would be the ecm plugin corroded? Is this a problem that this model has? Also, is there a way to get to the computer without taking most of the dash apart?

Posted by on

  • 3 more comments 
  • coolbreze15 Jan 19, 2009

    Yes, black smoke does come out of the exhaust and it is a vortec. We've already replaced the EGR valve also.

  • coolbreze15 Jan 21, 2009

    The intake has already been checked and the spider has been replaced. Too much gas was an issue but after the injection replacement the pressure and everything was fine. I had also replaced the fuel pump before these problems started so it has a new pump and it works the way it should. Overall, everything in the fuel system, vac lines, and transmission has been checked.

  • coolbreze15 Jan 23, 2009

    Yep, all sensors and filters have been checked and replaced.

  • JBlazer Mar 10, 2009

    Mine idles rough as well, and blows black smoke from the tailpipe when the RPM's get up to about 6,500. It won't smog like this will it? Also, my "Anti-Lock" light is on... is that light okay to be on when they smog it, or do they not smog if ANY lights are on? Thanks!

  • Phillip Ridener
    Phillip Ridener May 11, 2010

    Does it blow black smoke out of the exhaust? And is it a W engine code? That is the 8th digit on your VIN code. That means it's a vortec.

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 146 Answers

Sounds like your problem is your injector there is a cap on your upper intake that comes off pull it off take a flash lightlook down into the intake if it's got gas in it thats your problem. good luck Phil.

Posted on Jan 19, 2009

  • Phillip Ridener
    Phillip Ridener Jan 21, 2009

    That all said, if all the new parts are working the way they should, ck your computer. A lot of GM cars have computer problems that are misdiagnosed. - people spend a lot of money changing parts - Good luck.

  • Phillip Ridener
    Phillip Ridener Jan 22, 2009

    have you checked your map sensor it could cause this problem also. good luck.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 88 Chevy s10 blazer won't start did complet Service on change fuel jets mapsencer.still nothing


1. try to remove positive power cable from your battery and wait for 5 minutes.
2.while waiting for 5 minutes,Drain all remaining power by switching your ignition to ON,switch on your headlights,step on your brake pedals
3.switch off your ignition ,including your headlights
4.install back your positive power cable to your battery
5. try to start your engine

Sep 04, 2015 | Cars & Trucks

1 Answer

Where is the computer on 93 blazer s10 how do you change it


For 1993 Chevrolet Truck S10 Blazer 4WD 4.3L CPI 6cyl the Engine Control Computer is located in front seating area, passenger side, behind dash, above glove compartment cavity, mounted on dash upper panel.

Hope this helps (remember to rate and comment this).

Sep 27, 2010 | 1993 Chevrolet S-10 Blazer

2 Answers

Trying to locate the ignition module for chevy blazer s10 1994


Ignition module sits in the ignition distributor, remove distributor cap, there will be two elec. harness plugs, the one with two wire's is for the pick up coil, the other one is for the ignition module, just unscrew module out of distributor and install new one.

Sep 23, 2010 | 1994 Chevrolet S-10 Blazer

2 Answers

1994 s10 blazer no spark


Sounds like the ignition module. Do you know if it is tbi or cpi?

Mar 28, 2010 | 1994 Chevrolet S-10 Blazer

1 Answer

Adjusting or replacing brake light switch on 1994 Chevy S10


i don't think there is a adjustment on it, but there is a clip on the brake pedal to hold the brake switch on.

Feb 19, 2010 | 1994 Chevrolet S-10 Blazer

1 Answer

The cruise quit on my 92 s10 how do I trouble shoot this to fix it?


There are 2 switches on the brake pedal 1 for the brake lights and 1 for the vac dump for the cruise. Make sure the switch for the cruise is closed with the brake pedal up. If that is not it it is probably the sevo unit under the hood

Mar 12, 2009 | 1992 Chevrolet S-10 Blazer

1 Answer

1999 Chevy S10 Blazer 4x4. Replacing rear pad's,& Bleeding Breaks


have one person in the blazer pumping the brake pedal and then hold to the floor, crack the bleeder then tighten, release pedal, repeat till all air is out one side at a time, if this does not work then your ABS unit is bad witch if u follow your lines from your master cylinder u will find a black box with a motor on it, or the master cylinder itself is bad, it also can cause u to have no pedal, replace the master cylinder first, most likely cheaper.

Mar 11, 2009 | 1997 Chevrolet S-10 Pickup

2 Answers

01 Chevrolet S10 Blazer hesitates/misfires


If it is only doing this in overdrive lock up, tap the brake if it quits see a transmission man your torque converter might be bad

Feb 15, 2009 | 2001 Chevrolet Blazer

1 Answer

94 s-10 blazer 4.3 cpi loss of power, no brakes


This is not a problem with these models, but the injector drivers in the computer are a problem. Pull your glove box down, look behind it to the right - that's where your computer is. Hope this helps. PHil

Jan 18, 2009 | 1994 Chevrolet S-10 Blazer

1 Answer

No brake!


also check the brake booster usually when it goes bad the pedal goes to the floor causing no brakes.....try replacing that.....also a vacuum leak could cause that....are you loosing brake fluid at all besides when you bleed the brakes? let me know

Jul 05, 2008 | 1994 Chevrolet S-10 Blazer

Not finding what you are looking for?
1994 Chevrolet S-10 Blazer Logo

Related Topics:

292 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

63242 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21981 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...