Question about 2003 GMC Envoy

1 Answer

2003 temp. gage goes compelety to right , but engine doesnt get hot ?

Engine temp. gage goes pass hot

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • GMC Master
  • 1,311 Answers

It's very possible that the gauge itself is bad, it is common for the stepper motor that drives the gauge to go bad.

Posted on Jan 03, 2013

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do i do a wave gage for my tempture sensor my gage had peage out allthe way passed hot


You will have to remove the gauge assembly and take the cover off to flip the gauge back to proper point.

Aug 19, 2014 | 2004 Buick LeSabre

3 Answers

My temperatur gauge shows hot when i turn on the ignition and two fans turns on right away can you tell me whats the prablem is?


Well it can be one of too things the gage or the temp sensor.
its most likely the sensor. The temp sensor is normally mounted with the thermostat housing which is on the top of the engine and has the top radiator hose going to it if you can't see it, try taking off the plastic covers. With the ignition on so all gages are reading go and unplug the sensor the gage should drop back strata way, this tells you that you have the wright sensor there are sometimes 2 one for the gage and the other for cold starting. There is a possibility that the problem may be coursed by a squashed or rubbed throw wire so if you can't make the gage return to cold by disconnecting the wires then start following the wires back along the engine.
I think you will find a faulty sensor is the cores of your problems and should be easy to pick up at any car part place.

May 09, 2014 | 2002 Chevrolet Impala

1 Answer

F150 4.2 temp. Gage pegs to h


SOUND LIKE THE TEMPATURE SENSOR IS BAD REPLACE IT WITH ONE THAT THE CAR RECOMEND. IF THE CAR ENGINE IS HOT :CHECK THAT THE FAN IS PRODUCING ENOUGH AIR THRO THE RADIATOR IF OK THEN CHECK THAT THE THERMOSTATE IS NOT THE FOULT.

Feb 05, 2014 | Cars & Trucks

1 Answer

Hello My honda runs great but sometimes the temp gage goes up and then down. It doesnt do it all the time but its dont it more times then i like. What could be wrong?


Start with checking your coolant level, you may need to add some. Make sure the engine isn't hot before removing the radiator cap, and be sure to fill the reservoir too.

Jan 20, 2011 | Honda Civic Cars & Trucks

1 Answer

Temp gage reds hot for a second and returns to


I would check the wiring to the temp sensor. Make sure that it's connected properly. If so, and it's still giving you that problem, I would replace the sensor. (That's of course assuming you can't live with it's eccentricity/quirk.)

Aug 02, 2010 | 2003 Ford Explorer

2 Answers

2003 impala temp. gage goes high & low and no heat comes out of heater. it continues to cycle like this as I drive. When temp. gage goes up the heater quites.


Have u checked the coolant level? this type of problem useualy indicates the coolant is low, if it is low you need to have the engine cooling system tested for a leak, the coolant goes out somewhere.

Jan 29, 2010 | 2003 Chevrolet Impala

1 Answer

93 plymouth Voyager temp gage gets hot only when


Your electric fan is probibly not running.Fan switch,fan relay or the fan could be bad.If it is getting hot and you pop the hood you should hear the fan running.

Jan 22, 2010 | 1993 Plymouth Voyager

2 Answers

Water temp gauge stay on 160 degree


should be fine as long as the gage goes up and down and you get heat it should be fine make sure you consider the outside temp. as the engine starts it will heat up get really hot the the thermostate opens and the gage will fall and should but not always stay low it could just be the ip gage.

Dec 28, 2008 | 2005 Chevrolet Silverado 1500 2WD

1 Answer

Temp gauge off charts


Are you mistaking the engine temp sensor for the engine temp sending unit? The temp sensor is for the fuel injection system and the temp sending unit is for the gauge. If you asked for a sensor thats what they sold you. You need to ask for a sending unit.

Dec 18, 2008 | 2005 Chevrolet Cavalier

1 Answer

Heater doesnt work


Check your colant level it might be low and if its top it up with proper collant ratio......and if that doesnt work replace your thermostat...... then let me kno wwat happens?

Nov 23, 2008 | 2003 Honda Civic

Not finding what you are looking for?
2003 GMC Envoy Logo

Related Topics:

129 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...