Question about 2005 Nissan Altima 3.5

Open Question

2005 Nissan Altima rear defrost not working

Rear defrost does not work. I've checked all the fuses in the entire car, wondering if there is a common problem with these vehicles?

Posted by on

Ad

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 548 Answers

SOURCE: I have a 2005 Nissan Altima. The radio has

i would check the antenna connections

Posted on Sep 19, 2009

Ad
  • 83 Answers

SOURCE: THE AUTO DOOR LOCK AND POWER WINDOW DO NOT WORK

From the service manual, which is available relatively inexpensive at Promanuals.net here

 Both front wiper relays are located in the IPDM E/R (intelligent power distribution module engine room)
 Wiper switch (combination switch) is composed of a combination of 5 output terminals and 5 input terminals.
Terminal combination status is read by BCM (body control module)
 BCM controls front wiper LO, HI, and INT (intermittent) operation
 IPDM E/R operates the wiper motor according to CAN communication signals from the BCM.
Power is supplied at all times
 through 50A fusible link (letter f , located in the fuse and fusible link box)
 to BCM terminal 70, and
 through 20A fuse (No. 39, located in the IPDM E/R)
 to front wiper relay, located in the IPDM E/R
With the ignition switch in ON or START position, power is supplied at all times
 through 10A fuse [No. 1, located in the fuse block (J/B)]

Posted on Sep 28, 2009

  • 1 Answer

SOURCE: Lost Fuse Box Diagram - Altima 2005 2.5L

i need to know what ENG CONT AND ENG MTG means on the fuse box of my 2006 altima.

Posted on Jan 14, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1993 Nissan Altima defrost not working,


Its possible that the switch its self could have gone bad considering its 20 yrs old. good luck

Dec 07, 2013 | Nissan Altima Cars & Trucks

1 Answer

Rear window defroster in Saturn Vue not working


find manual could be mini relay and fuse

Jan 30, 2013 | 2005 Saturn Vue V6

1 Answer

Rear shock replacement


I would match the rear shocks,brand & model to
the front & also check over the entire suspension
front & rear

If-- when you say I just replaced & your referring to a repair
shop,then who knows what goes on there

What about worn stabilizer links,there only good for
about 5 years

Try & get a look at any bulletins on anything to do with
your vehicle
Manufacture & Aftermarket Tips etc

Oct 01, 2012 | 2005 Nissan Altima

1 Answer

My 2005 nissan altima won't crank or turnover. It justs makes this clicking noise. Can you help me?


The click is most likely the starter solenoid you hear

Should be a familiar sound you've heard may times
on other cars

I would guess you know how old the battery is?

If it is original,it is 8 years old & dead,if so, replace it

If it is only 3 years old ,check the voltage with a meter

Next the solenoid could be working as you hear it,but
it's contacts are burnt,it can be replaced

You remove the starter & change the solenoid

Don't want to do that, buy the entire starter at auto parts,
not a dealer,cost too much to even be there for any reason.

Sep 28, 2012 | 2005 Nissan Altima

1 Answer

My brake lights are not working. Bulbs look good, and it doesn't seem right that they would both fail. Fuse is good, and I checked voltage at the fuse box and get about 9.3 volts DC when I press down...


When the brake light is illuminated on the dash, it may not be because the hand brake is engaged. It can also mean that your breaking system is in distress. it is possible that you have a short somewhere between the fuse panel & light assembly or it is possible that the sensor for your rear brakes has malfunctioned. I apologize that I am not as knowledgeable on Nissan products, however I had a similar situation with a Dodge Durango, only to discover that the rear brakes were not functioning. I hope this helps =)

Aug 26, 2011 | 1996 Nissan Altima

1 Answer

I am not getting good heat when heater is on, windows take a long time to defrost in winter and rear defroster also takes a long time to defrost rear window.


check radiator -thermosate-hoses -heater core far as the rear defrost window it works off of voltage maybe have somebody to look at this for you

Nov 01, 2010 | 2003 Nissan Altima

Not finding what you are looking for?
2005 Nissan Altima 3.5 Logo

Related Topics:

183 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

76070 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

726 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...