Question about 2006 Nissan Xterra

2 Answers

Fuel Gage reading E after I Fill up.

#20 (permalink) 05-10-2008, 05:54 PM thegreatxterra Newbie
2005 Xterra Join Date: Mar 2008 Posts: 2 If you are reading this because you have the same problem... FILE A COMPLAINT AT THIS WEBSITE ---->>IVOQ - File a Complaint Apparently this is a problem that deserves a recall! Why should we take the cost of repair when this was an existing problem on earlier models? You'd think that something would have been done in order to prevent a repeat. Here is a copy of my complaint.

"I had 1/4 of a tank of gas and went to fill up. After filling up my gas tank, I turned on the car, at which point the needle did not register the full tank. After driving a couple miles, the check engine light came on. I went directly to the dealer and was told that it was a fuel sending unit/sensor and that it was no longer covered after 30K miles. After returning home and doing research, I went online to x.nissanhelp.com After performing a search, I came across many others who have experienced the same problem. Apparently it has something to do with the fuel sending unit. A similar problem was found on the 2000-2004 xterra models and a recall was performed when the vehicle would stop after not getting any fuel, posing a great danger. It seems that somthing in the unit is faulty and will corrode over time. There is a general consensus that everyone who is having the problem is experiencing the same thing after having the vehicle for over 2 yrs and with around 39k-49k. If this problem existed in previous models, and it was recalled, the 2005-2007 xterras, frontiers, and pathfinders should get this fixed at no charge to the customer!! Why wait for accidents and possible deaths, especially since the problem lies in an integral part of the vehicle. Cost of repair ranges from $300-600."

Please file the complaint if you agree that we, the loyal Nissan customers, should not have to pay for something that is clearly a defect on Nissan's part.

Posted by on

  • 17 more comments 
  • Anonymous Feb 04, 2009

    I do experiencing the same problem with 2005 crew cab pathfinder and Nissan dealer asking to corect the problem $600 ,at 37000 miles

  • Anonymous Feb 09, 2009

    I have the same exact problem on my 2005 nissan xterra. Started happening at 42k miles. Really makes me mad on a 21st century car(especially nissan).

  • Anonymous Feb 16, 2009

    Same problem with a 2006 Xterra. 87,000 miles though (long commute).

  • sonya_bowman Feb 27, 2009

    I have the same problem with the fuel sensor and check engive light. It started with the gauge still reading empty when I had already filled up. I have about 37,000 miles on my Nissan Frontier Nismo and there is no recall and they won't do a "goodwill" repair on it. Has anyone ever written Nissan about this? I am a Nissan customer but won't be for long if this issue isn't resolved. I don't have enough money to fix it right now...but, I have to get to work to keep paying the bills. So, everyday I drive to work and hope that my truck doesn't quit and cause an accident on the freeway.

  • drill3d Feb 27, 2009

    I have the same problem. It started recently on my 2006 Xterra with 51,000 miles. I filled up with gas but the gauge continued to indicate empty. After I drove about 3 miles, the "Service Engine Soon" warning light came on and is staying on.

  • mosesask Mar 03, 2009

    I have the same problem. Fuel gauge shows empty after fill up and service engine light is on all the time. Nissan dealer quotes $600 for replacing sending unit

  • Anonymous Mar 13, 2009

    same problem here...apparently, I know have to keep an eye on the amount of miles I put to gauge when to fill up again...this is BS!!! A recall is indeed a MUST here!!

  • Anonymous Mar 16, 2009

    62,000 miles on my 06 frontier LE. 

  • texrnrob Mar 17, 2009

    Same thing here. Check engine light and fuel sending unti problem. Filed complaint on NHTSA. Nissan needs to take care of this or they risk losing loyal customer. I currently own 3 nissans and am looking at 370Z. Unfortunately I don't have a relationship with my nearest dealership as we have moved since previous purchases.

  • gearhead1320 Mar 23, 2009

    05 Exterra with 52,000 on it. Have the same problem as others. Noticed that after a reset (disconect battery then reconnect) would clear the Service light. When fuel gage would get to ust under 1/2 tank up pops the the light.

    GearHead

  • guest2377 Apr 06, 2009

    Same Problem. Happened today. Filled up with 1/4 tank and suddenly the Service Engine Soon light came on, and the fuel gauge will only read 1/2 full. If it matter, the vehicle was just in for service on the never ending TPMS light being on.

  • POSXTerra Apr 07, 2009

    Same thing happened here as well on a 2005 Xterra. I took it in to the dealer, they did a diagnostic $96, and then told me that I needed a new fuel sensor ($515). I asked what it does, they say it controls the gauge. I have had zero issues with the gauge so declined the service. I'm goign to try to reset like Gearhead said and see if it works. I agree that a recall must be issued. This is retarded I only have 43K on it..

  • guest2377 Apr 08, 2009

    Dealership covered it under the 5/60 today. They know it's an issue, but Nissan has no plans to make it a covered problem. No charge for the code reading, everything covered. In their defense, my warrant just ran out 9 days ago. $1685 for a 6/72 extended warranty.

  • TITERE4JESUS Apr 12, 2009

    2006 NISSAN XTERRA WITH 43,000 MILES STARTED HAVING THE SAME PROBLEM WITH FUEL GAUGE GOING WACKY AND SERVICE ENGINE SOON LIGHT COMING ON. MAYBE IT'S TIME FOR A CLASS ACTION SUIT!

  • peseta Apr 16, 2009

    39,400 miles on '06 Xterra as of last night (4/15/2009). I thought maybe someone had siphoned my gas, and this caused the strange reading. I had just under 1/4 tank, then suddenly it drops to DTE ----, and "Service Engine Soon" light turns on.

    Filled up at gas station, and it reads correctly now, but the "Service Engine Soon" light is still on. Gonna try the battery shutoff and see if next 1/4 tank causes this to show again.

    I love my X, but this is giving me doubts about keeping it.


  • Igiveup777 Apr 17, 2009

    Xterra 2005, I have the same problem. At first, it took a long time to register a full tank, service engine soon was always lit. My garage told me they have to change the sensor at $400, I said no, I though I would be able to live with that. Yesterday, After I filled my tank the fuel gage drop from half to E with Low fuel alarm and it is now a steady state.



    I had some 15 differents cars/truck so far, I never had a trouble like that, not mentioning $300-$500 for a sensor, this is insane. Might be my last and only Nissan, although I like the Xterra.

  • Anonymous Apr 20, 2009

    hi all,

    i have a 2006 xterra as well and i had the same problem around 48,000 miles. i waited, thinking i can deal with it and at 50,500 i took it to the dealership. yep, fuel regulator sensor was broken.



    $450 repair. i have an extended warranty but i still had to pay $100 deductible. thank god for that, at least the extended warranty finally paid off in my case.

  • nissanowner May 06, 2009

    I have a 2006 Nissan Xterra. Yesterday I had about 1/4 tank gas and decided to fill up. After filling up, my gauge read that I was on E. I took the car to the dealer. They state its the fuel sensor and its going to be about $400 to fix. After researching online, looks like everyone has the same problem around the same time. I've got 40,100 miles on the vehicle. I've filed a complaint but not sure if anyone will do anything. It doesn't hurt to try. The more that complain the better. But if this is a known issue, why isn't Nissan doing anything about it? Why should we have to pay out of our pocket. I didn't buy an American-made car because they generally have more problems and didn't expect this from Nissan.

  • Anonymous May 11, 2009

    I have a 2006 Nissan Frontier with 37,000 miles. I have experienced the same problem as many of you. After feeling up to a full tank my gauge will read it as empty. My check engine light has been on for some time now, I thought it would cost being that it is not under warrenty anymore. Is this something covered by the recall you are talking about? I hope so. Thanks for your help!

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

WE HAVE THE SAME PROBLEM WITH OUR NISSAN X-TERRA. HOPEFULLY THEY CAN COME UP WITH A RESOLUTION FOR THIS PROBLEM THAT WAS CAUSED FROM THE MANUFACTURING OF THE VEHICLE. WE CAN ALSO TRY THE BBB ( BETTER BUSINESS BUREAU) AND PUT UP A COMPLAINT TO THEM AS WELL. IT'S PATHETIC THAT WE WOULD HAVE TO PAY OUT-OF-POCKET FOR THEIR MALFUNCTIONS. -NL

Posted on Jul 24, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

The problem is a bad fuel sending unit located in your gas tank. You can get the part on Nissan Courtesy parts for about $75 and the install is pretty easy. I did it myself on my 06 Xterra

Posted on Dec 07, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How can I deactivate my car alarm, it keeps going off everyday


alarm keeps going off - Acura Forum : Acura Forums

www.acuraworld.com > ... > CL > 1st Gen CL

Jun 6, 2011 - 8 posts - ‎4 authors
Now the alarm is suddenly going off when I put the fuse back in. ... I am going to print it and keep it with my stuff in my Acura folder. ... as i connect the battery terminals and wont turn off with the remote. can you help me on this one please? ... Join Date: Sep 2012. Posts: 2. Car 1: 1998 Acura 2.3 Cl. alarm ...

1999 TL Deactivate Alarm/pull the fuse - AcuraZine Community

acurazine.com/.../problems.../1999-tl-deactivate-alarm-pull-fuse-746888/
Oct 4, 2009 - Is there a way that I can deactivate the alarm on my car. ... It is very annoying, especially when it goes off for no reason in the .... My 2001 CL black box has 4 relays, 2 grey, 2 black.removing any and ... Troubleshooting Fail: Stuck Drivers Window, xsilverhawkx, Problems & Fixes, 5, 09-28-2015 07:51 PM. 2005 TL, HFL Malfunction and Parasitic Draw
May 7, 2012
2012 TL Remote Starter
Jul 15, 2011
99 acura tl stuck in park and brake lights won't work
Aug 25, 2010
1999 Acura 3.2TL shuts down on its own
Jul 20, 2009
More results from acurazine.com

Jan 08, 2016 | 1998 Acura CL

1 Answer

Why does it lack spark?


Part 1 -How to Test the Ignition COP Coils (Nissan 1.8L)

troubleshootmyvehicle.com > Nissan > 1.8L
Feb 12, 2013 - What Tools Do I Need to Test the COP Coils. ... coils (most commonly known as the COP ignition coils), on your 1.8L Nissan Sentra is pretty easy. ... When one COP ignition coil fails... that cylinder goes 'dead' due to a lack of Spark and is said to be misfiring. .... 2000, 2001, 2002, 2003, 2004, 2005, 2006 ...

Part 2 -How to Troubleshoot a No Start (Nissan 1.8L)

troubleshootmyvehicle.com > Nissan > 1.8L
Jan 17, 2013 - Checking for Spark With a Spark Tester. ... Your 1.8L Nissan will either have a distributor-type ignition system or the more modern COP ... A BAD fuel pumpwill cause your 1.8L Nissan Sentra to Crank but Not Start... since the ... Still, the other method that I've used to test for a lack of fuel... is spraying starting ...

2002 Sentra 1.8, no spark, code 0505... - Nissan Sentra Forum ...

www.b15sentra.net > ... > Technical Discussion

Nov 4, 2008 - 15 posts - ‎3 authors
I have never had a problem with the car before (02 Sentra 1.8/auto), so I had no need to post ... Originally Posted by Black B15 ... Join Date: Jun 2005 ... Can you see if the coilpacks are getting spark & work back from there? how many spark plugs do i need ? - Nissan Sentra ...
7 posts
Mar 19, 2010
Spark Plug Replacement - 2002 GXE 1.8L - Nissan ...
15 posts
Oct 12, 2009
1.8s starting problems - Nissan Sentra Forum - B15 ...
15 posts
Jun 23, 2009
No start on 1.8L 02 GXE - Nissan Sentra Forum - B15 ...
15 posts
Apr 11, 2009
More results from www.b15sentra.net

Jan 01, 2016 | 2005 Nissan Sentra 1.8

1 Answer

What is the cost to replace timing chain in 2002 ford explorer


replacing timing chain???...Costs??? - Ford Explorer

www.explorerforum.com > ... > Stock 2002 - 2005 Explorers

Mar 20, 2008 - 8 posts - ‎5 authors
Stock 2002 - 2005 Explorers. ... What is the reccommneded time to replace the timing chain in a '02 Explorer 4.0 ... Costs inc. mechanics labor? Timing chain replacement cost on 2003 Ford Explorer ...
2 posts
Dec 2, 2011
Timing chain rattle resolution process - SOHC V6
19 posts
Jul 6, 2011
Timing Chain Replacement Cost - Ford Explorer and ...
6 posts
Jul 28, 2010
4.6L Explorer engine timing chain ooops! - Ford ...
19 posts
Jan 10, 2008
More results from www.explorerforum.com

Estimate of cost for a timing chain replacement - 2003 Ford ...


Dec 15, 2015 | 2002 Ford Explorer

1 Answer

Where is purge valve solenoid located?


Mar 16, 2014 - 2 posts - ‎1 author
I have a 2003 Vue 3.0L 2wd.After fueling I have trouble starting, it cranks but I have to pump it a couple of time then it starts, Sometimes after it ... 2008 Saturn Vue Purge valve canister solenoid location ...
9 posts
Aug 24, 2013
access to vent valve solenoid - SaturnFans.com Forums
2 posts
Jan 20, 2013
Service engine soon light: P0440 - SaturnFans.com Forums
6 posts
Apr 15, 2010
Code P0446 (evap solenoid) and now I can't fill the gas ...
16 posts
Nov 17, 2007
More results from www.saturnfans.com

EVAP Solenoid Location - YouTube

? 2:17
https://www.youtube.com/watch?v=jIKaPF2Yw3I
Mar 20, 2007 - Uploaded by richpin06a
Saturn EVAP Solenoid Location. ... How To Test and Replace EVAP Canister Vent Control Valve P0446 - Duration: 6:18. by CarsNToys ...

EVAP Purge Solenoid Removal - YouTube




Dec 11, 2015 | 2003 Saturn VUE

1 Answer

How can I free up ABS seized on rotor?


Rear Rotor Removal-ebrake stuck? - Ford Explorer and Ranger Forums ...

www.explorerforum.com > ... > Stock 2002 - 2005 Explorers
Aug 7, 2007 - 19 posts - ‎9 authors Ok, I've got a 2005 explorer and I can't seem to get the rear rotors off. Did a search ...Join Date: Nov 2006. Posts: 76 ... You might even be able to slide these angled pieces of metal out and it will surely free up the brakes. They are .... You have to hit it at 90 deg from the two connecting metal tabs. When you ... Abs, traction control, and wrench light on ?
14 posts
Mar 1, 2013
Explorer Disc Brake Tips and Tricks (LONG)
1 post
Apr 17, 2010
Tip on Getting a stuck Rotor off
19 posts
Apr 13, 2007
What causes brake calipers to get stuck ??
10 posts
Jan 13, 2005
More results from www.explorerforum.com

Nov 06, 2015 | 2006 Ford Explorer XLT

1 Answer

Plug gap 05 Toyota 4.7?


2005 Tundra spark plug confusion - Tundra Solutions

www.tundrasolutions.com/...tundra/187079-2005-tundra-spark-plug-con...
Mar 20, 2010 - 9 posts - ‎6 authors I have a 2005 DC 4x4 4.7 which is due for spark plugs. I read about ... The spark plug gap spec for the 4.7L 2UZFE is .032. The V6, IIRC, is .044 ...

Oct 24, 2015 | Toyota Cars & Trucks

1 Answer

2002 ford taurus check engine lite code is po460, a mechanic replaced the fuel pump, still didn't pass inspection......please help!


I am going to paste a list of potential causes for a p0460. There is a cure for a dirty reader card and Ford recommends CHEVRON TECHRON fuel system cleaner. Run tank low, put in cleaner, use best gas you can find,avoid your frequent brand.

02-06-2006 06:19 PM #2 TXFO user-offline.png Not Special Enough txfo.gif?dateline=1249691143 Join Date Jul 2002 Location New Braunfels, TX Posts 13,976 icon1.png Re: Fuel level sensor circuit malfunction (P0460)? P0460 - Fuel Level Sensor Circuit Malfunction The PCM monitors the fuel level input (FLI) circuit for electrical failure. The test fails when the signal moves outside the minimum or maximum allowable calibrated parameters for a specified fuel fill percentage in the fuel tank. Empty fuel tank
Fuel pump (FP) module stuck open
Incorrectly installed fuel gauge
Damaged instrument cluster
CASE GND circuit open
FLI shorted to VPWR
Damaged PCM
Overfilled fuel tank
Fuel pump (FP) module stuck closed
Damaged fuel gauge
FLI circuit open
FLI circuit shorted to CASE GND or PWR GND
CSE GND shorted to VPWR
Monitor FLI PID and FLI V PID in key ON engine RUNNING. FLI PID at 25% fill (with non matching fuel gauge) and FLI V PID less than 0.90 volts [for FLI PID at 75% fill (with non matching fuel gauge) and FLI V PID greater than 2.45 volts] indicates a hard fault.

Jul 13, 2011 | Ford Taurus Cars & Trucks

1 Answer

Fuel Gage reading E after I Fill up.


The fuel level sending unit is bad. Part is $90 from dealer. You can replace it yourself and save $500 from stealership. Drop gas tank and remove fuel pump. Sending unit is attached to fuel pump.

May 31, 2009 | 2005 Nissan Xterra

2 Answers

Fuel Gage reading E after I Fill up.


the problem would be that of the fuel gauge which in newer models are mounted in the fuel tank, or the fuse for the gauges are burnt out, or there is a loose connection

Apr 20, 2009 | 2005 Nissan Xterra

1 Answer

Fuel gage wont read past 1/2 mark when using fuel


it is the pontimeter in the fuel sender you can buy it seperate from the whole assembly and they had alot of problems with them please rate -jeff

Aug 21, 2008 | 1998 Chevrolet C1500

Not finding what you are looking for?
2006 Nissan Xterra Logo

2,314 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

61168 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

705 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...