Question about 1997 Dodge Avenger

3 Answers

1997 dodge avenger engine problems V6 2.5

I saw your solution for the other 2 people who had the same problems with their engines. i just bought a 1997 dodge avenger V6 2.5L after i got it i hooked it up to one of those computers at autozone and it said i had a misfire in one of the cylinders. so wat i did was i bought all new wires and spark plugs and new gaskets for it to c if that would fix the problem. after i got everything back together it ran perfectly fine for 1 day with no problems. then the next day after i got off of work and i started it the car did not want to stay idling at the usual rpm's. i spoke with my mechanic and he thought it might be the pcv valve. i replaced it and it still was not running right. the car will idle at very low rpm's if it's not moving, but if i'm driving it and i am going down a hill or i stop at a red light the car will die. the only way i can keep it running is if i put my foot on the gas slightly. i saw that u told the other people on here that it was the Idle Air Control motor. I just wanted to check with u and c if u thought that was the problem with my car. thanks

Posted by on

  • Anonymous Feb 17, 2009

    Same problem here, same car, year and engine.

  • MissFox Mar 10, 2009

    I bought my 1997 Avenger New and from day one it has givin me problems starting...cold start.. even at temp -5 C ...It has to be plugged in or it wont start in the winter months.If i forget to plug it in , the only way it will start is to pump on the gas. It idles to low and when at red light coming to a stop it want to stop running rpms go down to low... check engine light has been on almost since the day i bought it new..codes misfire..o2 sensor replaced...pcv valve..egr..fuel injectors..main pcm...many things but i will say i do love my car ! Not alot of them out there .

×

3 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 2 Answers

Check your EGR valve. It may be stuck open. I had a similar problem 2 years ago on my 97 avenger w/ 2.5L V6. Engine idled rough and would die when I stopped at a stop sign unless I feathered the gas pedal as I coasted to a stop. Replaced EGR valve, problem solved.

Posted on Jan 22, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

    Sergeant:

    An expert that has over 500 points.

  • Master
  • 450 Answers

Ckeck your air controll sencore.clean it

Posted on Apr 27, 2012

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have owed a 97 Avenger with the V6 2.5 for about 5 years. I have to say I love this car it runs great looks great and has never given me any problems and I DRIVE the hell out of her. It's been sitting for about 13 months never started it or anything just 2 days ago I had to go and move it because the house it was at got sold reasin for it sitting was because I lost my licence. Anyways after pumping up the tires, checking oil, and brakes fulids I jumped her, and to my amazment it gave me ZERO problems, the back tires where seized but after rocking it I drove around the block a few times with one foot on the gas and one on the brake just to try and kleen them up alittle. then I drove her home about a 40 minute drive, she ran great no problem and she still had all her pick up. I LOVE MY AVENGER. only problem is i need a new battery because of it sitting and new pads but thats it

Posted on Apr 01, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Is the power steering belt and alternator belt the same on a 1997 dodge avenger


The alternator and power steering are on one belt for a V6 engine, and on different belts for a 4 cylinder.

Jul 02, 2012 | 1997 Dodge Avenger

1 Answer

How do I put a speed sensor on a 1997 Dodge avenger


go to autozone.com. register,type in make and model of your vehicule.then click on repair manual,go to engine electrical, find your part and then you can print out the instructions

Nov 13, 2011 | 1997 Dodge Avenger

1 Answer

1997 dodge avenger won;t start. engine has no spark. checked the spark plugs, they look good.


Does your engine turn over, just not fire? if it sounds like it wants too start but its not firing, try your distributor. this happened to my car last week actually, went out and bought a new dist. and it is fine now. its a big expense, so try to find one at a junk yard and they say you can take it back if its not that. thats your best bet. hope it helps.

Oct 18, 2010 | 1997 Dodge Avenger

1 Answer

When driving my 1997 Dodge Avenger its fine until I come to a stop alot water leaks from engine its not from the radiator or the water pump


Is it coming from the over flow tank? is it over heating? what side of engine is it leaking from?front /back/ center/ is it running down engine / check hoses./if it isn't radiator or water pump/you are getting it narrowed down./ feel free to ask again if you need any further assistance. Thank you.for using Fixya.

Apr 09, 2010 | 1997 Dodge Avenger

1 Answer

Where is the thermostat located on 1997 2.5L 6 cyclinder dodge avenger?


follow the top heater hose to the engine the thermostat is in the gooseneck at the end

Dec 05, 2009 | 1997 Dodge Avenger

4 Answers

Anything positive on 97 Avenger?


Tune up (plugs,wires,and distributor cap) was done on a '97 Dodge Avenger with the 2.5l engine because it wouldn't start. It ran for 1 day after the tune up,but will not start now. No spark at the plugs. Any suggestions? Thanks

Feb 17, 2009 | 1997 Dodge Avenger

1 Answer

My 1997 Dodge Avenger's engine won't start


Try cam and/or crank sensor. If crank to cam timing isn't detected properly it'll crank all day but won't start. I had similar problem on my 2.5L V6 Avenger....drove home fine, no engine light, next morning it cranked, but wouldn't start. The crank sensor was faulty.

Jan 11, 2009 | 1997 Dodge Avenger

Not finding what you are looking for?
1997 Dodge Avenger Logo

1,410 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

61037 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...