Question about 1994 GMC Jimmy

2 Answers

4.3 L Vortec problem, can anybody point me in the right direction

1994, 4.3L Vortec (CPI), when it's cold, it'll run great...but once it warms up it starts surging, to the point of dying. If I don't manage to keep it running, it won't start unless it sits for about 10 minutes, it then repeats what I already said. I've changed the inline fuel filter and plugs, I've rapped and isolated the sparkplug wires, replaced distributor cap and rotor. Biggest problem is I can't find a person. manual or shop that knows anything about CPI, let alone Vortec engines. Please help me somebody!!!!!!!!!!!

Posted by on

  • 1 more comment 
  • Oxyco Jan 24, 2009

    I've been told its the Crankshaft Position Sensor. I was talking to a guy who car pools with me and he said his brother in-law had the same problem. And that fixed it. I'm going to pick it up next weekend and see if it really does fix it. Thought i would pass on this info. Hope it helps!

  • carhob May 11, 2010

    is your check eng. light on,if yes scan it,it should point you in right dir.

  • michael ayers Mar 08, 2013

    the pick up coil or the ignition module is the problem

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I had the same problem. I replaced the in-line fuel Filter and the entire fuelpump assembly in located in the tank and the problem went away.

Posted on Oct 16, 2011

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Check the temperature sensor for the computer. it may be telling the computer that the engine is still cold and causing the engine to run too rich at warmer temps

Posted on Apr 23, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I remove and re install the CPI unit and gaskets on a 1998 Chevy Blazer with Vortec V6


You have to reove the upper plenum. that is the part on top of the intake that looks like a dome on top of the lower intake.There is 8 10mm bolts around the outside of the dome part. the disconnect the fuel lines at back of lower intake and remove the cpi unit.

Sep 12, 2014 | 1998 Chevrolet Blazer

1 Answer

Focus tdci 2004 cold starting fault


pressure regulator on feul rail

Jan 12, 2013 | Cars & Trucks

1 Answer

93 S-10 blazer, vortec v 6 cpi, when cold it is very hard to start, you have to shoot ether and it will start right up, new fuel pump and filter and fuel pump relay, once it starts it will start right back...


Issue with PCs Valve Check for vacum lost cracking rubber connection Pre-Heater and Primer System Mal-Functional Check also for Idle sensor Relay for bad connection....good luck

Sep 28, 2010 | 1993 Chevrolet S-10 Blazer

5 Answers

1994 GMC Jimmy engine runs rough when cold; smooths out when warm


you need to have the codes checked to know what direction to start repairs,Autozone does this for free

Jan 20, 2010 | 1994 GMC Jimmy

1 Answer

I have a 1993 GMC Jimmy with the Vortec 4.3L engine, VIN code is W. It has CPI fuel injection with a new O.E.M. CPI unit installed. My problem is that the car 'surges' during hard acceleration (such as...


put a fuel pressure gauge on it and check cold and hot pressures if you have too take off hood and drive with gauge installed so you can see it. duct tape and a ruler to hold it up .should have 50 psi or more if it drops below thirty it cuold have trouble hope this helps.

Jan 11, 2010 | 1993 GMC Jimmy

2 Answers

4.3 vortec runs OK cold, runs rough or dies warm


replace the CKP and the truck will need to go to a shop and have the "crankshaft variation relearn" performed. the misfire may or may not go away, and that will need to be addressed also.

Oct 01, 2009 | 2002 Chevrolet Silverado

1 Answer

My 1999 volkswagen bug when cold runs really slow once warm it runs great. what is the problem


check the owners manual to make sure youre using the right oil. cars do lose compression when theyre cold, thats why it is so important to warm up the car before driving in cold weather.

Aug 17, 2009 | 1999 Volkswagen Beetle

1 Answer

94 s10 blazer runs great cold but studders at half throtle when warmed up i just did tune up thought it was timing but dont have a light to time it.i didnt have this problem befor tune up just a sluggish...


A few things could cause this: one-if you replaced wires then make sure wires are in right order and if in right order then make sure gap is right on new plugs and/or they are on the right places on distributor cap, two- your right at timing being important but timing would be all the way through, three- the most probable cause is your fuel injection depending on cpi or TPI, I would run a fuel injection cleaner through it for about three tanks or run premium gas for about 5 tanks and that should clear up your problem. Hope this helps....

Mar 25, 2009 | 1994 Chevrolet S-10 Blazer

Not finding what you are looking for?
1994 GMC Jimmy Logo

1,383 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...