Question about 2004 Ford Explorer

1 Answer

2004 explorer dash gauges acting crazy

Started my 2004 explorer and the rpm gauge did not do anything and then the speedometer and the rpm where jumping around then it was ok. Later that day I thought I smelt a burning odor. It has not did this in the last couple days. Just one time.

Posted by on

  • hawgnfrog Jan 17, 2009

    For about the past 6 months my 2004 Explorer has been doing a lot of strange electrical things... what really bugs me is that when the engine is turned off, all of my a/c and instrument panel info goes back to factory presets. Now, the automatic headlights won't turn on either. When the engine is turned on, it sounds like some squirrels are chattering inside my dashboard. I cleaned the battery connections, but did not solve the problem.

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 99 Answers

Check and make sure all the fuses are in good but it sounds like a bad ground wire

Posted on Jan 26, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

All the gauges on my dash stopped working. along with blinkers.


Possible cluster failure or body control module wiring faulty.

Jun 17, 2015 | 2004 Dodge Durango

2 Answers

One by one my gauges(rpm,gas,speedometer,oil) stopped working. Is there a sensor that needs replaced? a fuse? dash? Help?


please keep me posted as well, ALL my gauges are doing the same. First the gas, filled it one day and it fell all the way and light turned on, then my themostat, freaked me out, thought i was overheating,...NO just the guage, NOW my spedometer is stuck on 120, and my RPM's are acting crazy. i have read tons with this same problem, WHY WONT the manufacturer DO SOMTHING??

Aug 25, 2010 | 2004 Isuzu Ascender

1 Answer

Fule gauge speedometer and rpm gauges stopped


Go to the fuse box and change the fuse for "Gauges". I think this might solve the problem.

Feb 23, 2010 | 2004 Chevrolet Monte Carlo

1 Answer

Electrical Problem with speed gauge, RPM and dash board lignts.


That is a manufacturing defect associated with your instrument cluster. My local dealer replaced my entire instrument cluster for free (truck was out of warranty) when my speedometer showed 100 mph in a parking lot and my oil pressure gauge read 0.

Jan 01, 2010 | 2004 GMC Envoy

2 Answers

Gauges misreading bigtime


instrument cluster and buy and extra per gm quality

Dec 24, 2008 | 2003 Chevrolet Cavalier

2 Answers

1990 honda accord rpm gauge out of wack


You probably have a faulty sensor at the transmission.

Go to your local parts store, and they can give you the part and how to install it. It's pretty easy.

Jul 18, 2008 | 1990 Honda Accord

Not finding what you are looking for?
2004 Ford Explorer Logo

Related Topics:

760 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

66126 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Fordexpert

Level 3 Expert

5363 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...