Question about 1997 Oldsmobile Cutlass Supreme

1 Answer

Oil presure light comes on after driving 15 min. only when i stop. this just started after i gave it a rutine oil change. when ii turn the heater on it stops coming on .

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 4 Answers

After making sure that you used the propper oil filter and the correct grade of oil. inspect the Oil presure switch. if you see it wet with oil, replace it. given that you hear no internal engine noises, while you come to a stop and the light comes on. Then more that likely you have the wrong filter. please doubble check your oil level, 2.. Hope this helps

Posted on Jan 16, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Oil light keeps comeing on ???


Remove the electric sender and install mechanical oil gauge to check that you have proper oil pressure. Bet ya the main bearings are not fitted correctly or the engine wasn't cleaned during overhaul and now bearings are trashed.

Jan 19, 2015 | Cars & Trucks

1 Answer

Maint. req. light blinks 10 times after start up?


When a Honda Maint Req light blinks, but then stops, it is telling you to change your oil. If you don't change it, eventually, the maint req light will stay on. Here is how you reset the maint req light: 1) Turn they key to the II position
2) Turn the key to the off position, and push and hold in the odometer reset button
3) Turn they key back to the II position, while still holding the odometer button.
4) After about 10-15 seconds, the light should go off.

If that doesn't work, try it this way: p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 12.0px Verdana}

With the igniition off, press and hold the odometer button, turn the key to the "on" position, but do not start the car. Keep the odometer button down until the oil light begins and ends flashing. Turn the key off, and then start car to see if it worked or not.

May 08, 2011 | 2005 Honda Element

1 Answer

Okay my car started having problems starting it had a quarter gas tank and had never gave me any problems. Never has been over heated just had temp gauge replaced transmission flush and perfect inspection....


try my favorite simple fix. Get some stp fuel treatment or whatever is common for your area, read the label and make sure it removes water from the gas tank/gas pour the entire bottle in then fill up the tank. let the car run for a few minutes drive it if possible. Your problem should clear up shortly.

Jun 29, 2010 | 2004 Jeep Grand Cherokee

2 Answers

My 1995 gmc suburbans service engine soon light comes on only after i drive on the freeway when i turn the car off than turn it back on the light goes out. i have just changed oil and filter problem began...


hi reset it by disconnecting the live battery connection for3 mins then re connect that has done it for me if this helps please rate it thanks

Nov 21, 2009 | 1995 GMC Suburban

1 Answer

Oil light on at stop


engine oil pressure may be low remove oil pressure sending unit and install a pressure gauge check for pressure while warm if pressure is ok replace oil pressure sending unit oil pressure at idle should be between 5-15 psi at min

Nov 17, 2009 | 2006 Dodge Stratus

1 Answer

Oil light indicator


a change in the oil presure the oil is moving around and not enough oil presure to keep the light off i would have the oil presure checked

Sep 10, 2009 | 2004 Dodge Intrepid

1 Answer

CAR CUT OFF AND ACTS UP WHEN DRIVING 20 MIN..


Check the ignition coil or coil packs. It sounds like overheating coil(s)

Jun 14, 2009 | 1987 Ford Bronco II

2 Answers

Overheating


First you need to make sure the fans are coming on and if they are make sure they are coming on when the car is over heating because there is a fan relay by your fuses if its going bad it wont turn the fans on or it willl only turn them on sometimes..

Sep 30, 2008 | 1994 Toyota Previa

2 Answers

2002 Lancer OZ Rally...


I had the same problem with my 2003 Lancer OZ. The oil level and pressure were ok. Car was fine with no light when starting. After 10 to 15 mins of driving it would come on when I was stopped. It would go away when I pressed accelerator. Try replacing the Oil Sending Unit. It's about $10 and easy to swap. That was my problem.

Sep 21, 2008 | 2002 Mitsubishi Lancer

Not finding what you are looking for?
1997 Oldsmobile Cutlass Supreme Logo

152 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

70374 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6878 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...