Question about 1999 Chevrolet Camaro

1 Answer

Auto diagnostic shows multiple misfires/electrical

My 99 camaro with V-6 engine has bad rough idle upon starting, backfiring,voltage too high causing stereo to go on/off and smells of buring wires while in motion. Service engine Soon light stays on and flashes while driving when I accelerate. Low power light has come on as well but volt meter showing normal. I have put 4500.00 into this car as to date, the engine is great. I suspect it's a module or regulator or sensor???

Posted by on

  • Sandra Viguerias Jan 15, 2009

    All circuits checked already,
    The problem is that this car's computer is so sensitive to diagnose I found out it has to be taken to Auto shop so they can run a 2 day diagnostic on it. They have to go through over 5,000 codes just to find it. Is no simple procedure i found out. Thanks for your info though. Much appreciated!! Just thought I'd post to see if someone else had same problem and to see what they did.


  • mcvey_k Feb 04, 2009

    runs rough at idel, wont start sometimes, alt. gets hot and car runs better if you unplug it. tried new alt. and does same thing

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

You have a shorted circuit somewhere. Look at the plug wires for contact with ground.

Posted on Jan 15, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I fix a multiple misfire with a rough idle and auto transmission that shifts rough. I have an obd 2 trouble code PO300?


need to find out why the misfire bad coil ,wire ,wrong plug gap etc check injectors and fuel presure --what ever is causing misfire is also probably causing problems with transmission shifting

Oct 16, 2016 | Cars & Trucks

1 Answer

How do i fix my Mercury Villager 2002 with random misfire?


How to Fix error code P0300 for random misfires on your car ...

diy-auto-repair.wonderhowto.com/.../fix-error-code-p0300-for-random-...
Oct 15, 2010 - How to Fix error code P0300 for random misfires on your car ... amisfire (code P0304) on a 1999 Mercury Villager 3.3L ยท How to Fix error code P0500 ... I reset my codes and it ran fine for a couple of days, then I started getting ...

(code P0305) on a 1999 Mercury Villager 3.3L - auto repair

diy-auto-repair.wonderhowto.com/.../troubleshoot-misfire-code-p0305-1...
Sep 7, 2010 - The vehicle is a '99 Mercury Village, 3.3L, with 150000 miles on it. The chief ... How to Fix error code P0300 for random misfires on your car ...

2000 Villager Misfire - Car Forums and Automotive Chat ...

www.automotiveforums.com > ... > Mercury > Villager
May 24, 2010 - 2000 Villager Misfire Villager Car Forums. ... i was told that the 3.3L engines of 1999-2002 nissan quests/ mercury villagers are INTERFERENCE engines! ... Hope the following may help, and I will post if my last fix works. ... I have a 1999mercury villager that is showing a random multiple cylinder misfire ...

Rough Idle - 2000 Mercury Villager - RepairPal

repairpal.com > Questions > Mercury > Villager > 2000 Mercury Villager
Repair the code issue, because your Villager has OBD-II which is a very helpful Diagnostic system. Upvote (4) ... My 1999 Villager was running poorly; rough idle, lack of power at highway speeds and the engine problem light indicated random miss-fire, etc. I had new spark ... Have code po306 cylinder 6 misfire detected.

P0301 - OBD-II Trouble Code - RepairPal


Dec 17, 2015 | 2002 Mercury Villager

3 Answers

2000. Why does it idle roughly?


Could be blockage in the fuel lines ( are you running low on fuel causing debris in tank to be sucked through fuel lines? ) fuel filter could be clogged up! Idle valve faulty! Plugs need changing! Timing out! Fuel pump faulty!

Sep 19, 2015 | Suzuki Vitara Cars & Trucks

1 Answer

What is settin the po300 random multiple misfire/?


you have a bed coil (s). That's what causes misfire. Your DIC should be specific about which cylinder coil you're having trouble with.

Apr 28, 2014 | Volvo S80 Cars & Trucks

1 Answer

Hi. I have a 99 camaro 3.8l and I'm having some


Sounds like a fuel problem,You did the coils,plug wires and sparkplugs, that should of taken care of the misfire,You may have a EGR that stay open and doesnt close properly and it doesnt set a code why the ECM compensate for the false air.Now this causes rough idle,and smooth cruise with no misfire until you get to stop or idle speed.The map sensor this can also fail when warm especially if the vacuum it is suppose to get is not met. And a failing MAP causes a lack of power. A TPS failing causes a stumble and lack of power but no misfire.cansmo_184.gif

Sep 10, 2011 | 1999 Chevrolet Camaro

1 Answer

I have a 2002 Nissan Altima 3.5 SE About a week ago the check engine light came on, it started running rough, especially at idle. Computer diagnostic results showed missfire in cylinder 6. I replaced...


i would definately replace the coil. pretty certain that will solve your problem. do not drive with misfire or that can cause fruther damage such as catalyst failing, which is prety expensive.

Aug 17, 2011 | Nissan Altima Cars & Trucks

1 Answer

Loud bang, then drop in power, now car running rough!


Get a compression tester and find out if you blew a cylinder. You'll need to test all cylinders. Your most likely running on 7 cylinders instead of 8 or 5 instead of 6 if you have the V-6.

Jun 25, 2010 | 1998 Chevrolet Camaro

1 Answer

Tacoma 4cyl idles rough, heditates, multiple misfires


Possible fuel delivery problem, fuel pump, fuel line, clogged fuel filter, leaking injectors or injector O-rings, faulty pressure regulator etc. Check your fuel pressure.

Jun 20, 2009 | 1998 Toyota Tacoma

1 Answer

Engine starts,reaches high rpm,then slowly returns to a rough idle, misses badly,no backfire,surges as if searching/adjusting air/ fuel/est,timing light shows mark constantly changing/erratic,engine then...


Vacuum leaks. Check all hoses and intake bolts. Leaking EGR or plugged PCV valve. Air filter plugged. Leaking head gasket. Worn timing chain. Camshaft lobes worn. Valves burned or leaking. Fuel idle control system or sensor. Good luck!

Apr 18, 2009 | 1991 Chevrolet Camaro

1 Answer

Engine missing, particularly in idle, or dies when turning


The intake gaskets leaking would cause the engine to have a misfire. Get a can of Brake Clean and spray in around the intake manifold on the top of the engine while the engine is running. The engine idle will go up or down if there is a leak. Also try swapping the spark plug with another spark plug to see if the misfire moves to another cylinder. If it moves then you have a bad spark plug. I hope this helps.

Jan 02, 2009 | 1995 Pontiac Bonneville

Not finding what you are looking for?
1999 Chevrolet Camaro Logo

290 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

60867 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...