Question about 1997 Ford Escort

2 Answers

My 1997 ford escort is not accelerating, it will stay at 20-30mph until it runs for a while then it starts to accelerate. What could be the problem?

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

You may want to have your alternator examined as well. Mine started doing the same thing, and my alternator kicked the bucket a month or so later. You can find a reconditioned alternator for about $120, and removal/installation is VERY easy, especially if you have an extra set of helping hands to hold the tensioner while putting the belt back on. Good luck.

Posted on Mar 19, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 3,533 Answers

I would try some STP gas treatment in the tank make sure you have a half a tank of gas and add the STP and then top off with gas and if this helps replace the fuel filter and check the vacuum lines for any that maybe off and also check the EGR valve

Posted on Jan 15, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

89 ford probe hesitates when leaving a red light, then runs fine otherwise, fuel filter?


Engine Runs Rough, Stalls, Hesitates on Acceleration, Hard ...

repairpal.com > Problems > Ford > Probe
Ford Probe Engine Runs Rough, Stalls, Hesitates on Acceleration, Hard Starting, Poor Performance. This is a verified problem based on 9 reports. Learn more ...

Starting Problems - 1997 Ford Probe - RepairPal

repairpal.com > Questions > Ford > Probe > 1997 Ford Probe
Dec 5, 2010 - Starting Problems on 1997 Ford Probe ... If the engine runs rough,stalls, hesitates on acceleration, is hard to start, or has generally poor ...

A new misfire/hesitation on accel. Problem.. - ProbeTalk.com Forums

forums.probetalk.com > Tech Section > 2nd Gen (93-97) V6 2.5L

Feb 05, 2016 | Ford Cars & Trucks

1 Answer

Car wont stay running


I would start by checking the battery connections, then have the battery tested at a local parts store, then test the alternator.

Jan 21, 2014 | 1997 Ford Escort

1 Answer

1993 festiva replaced the throttle body gasket now will not accelerate at temp


I have a 1997 ford E 150 customize mark 3 van have driven back and forth to work 5 years ran great Christmas Day drove down to the garage and back up to house and now it will not start turns over has spark will not fire

Jan 07, 2014 | 1993 Ford Festiva

1 Answer

Ford Escort - 1997 car does not accelerate up hills. it revs if i am careful on flat up to 50mph but not past that? need to know what it possibly is and how it might cost asap? thanks


Look into exhaust, clogged cat conv. could cause that. Best way to test is a vaccum test on the intake. When exhaust is restricted the vaccum should go to 0 at the intake manifold while accelerating.

Mar 27, 2013 | Ford Cars & Trucks

1 Answer

My 97 ford escort runs fine on 0 solpe roadr. but when I drive uphill it hesitated on acceleration.


It sounds like low fuel pressure to me. Possibly caused by a clogged fuel filter or a weak fuel pump (or both). I would try changing the fuel filter first.

Oct 10, 2011 | 1997 Ford Escort

1 Answer

I have a nice example of a 1.6 ford escort, 97. When I accelerate it is as if I am running out of petrol....holding back but then going too, until speed is picked up. I have tried new plugs. No air leaks...


Either your fuel filter is bad - or fuel pump - acts like fuel filter/pump problem. One other thing to check is the timing / distributor and be sure the inner gasket on the distributor is intact and not allowing oil inside the unit to short it out. 83dfcd4.jpg

Apr 03, 2010 | 1997 Ford Escort

1 Answer

No acceleration after 45/50 mph


I would investigate a clogged fuel filter or weak fuel pump. May just not be getting enough gas to go faster....

Don't forget to check the air filter. Dirty air filter will usually cause issues at lower speeds too but can't be ruled out.

Mar 12, 2010 | 1997 Ford Escort

2 Answers

1997 Ford Escort dies/sputters during acceleration...


How many miles on car? It could be fuel pump and or alernator or both.

Jul 01, 2009 | 1997 Ford Escort

1 Answer

Ford Escort 1.6 1997 Engine runs smoothly but then starts cutting out after a varying period.Replaced air filter, which was dirty, and there was a temporary improvement. The fault returned a few days...


have you attempted to clean throttle plate? I would suggest taking hose off of throttle plate.Hold it wide open and spray throttle body cleaner, (with it not running) let it dry if it is really black or gooey spray and wipe goo and fluid off with a rag.put back together.It may not be problem but if air filter was dirty throttle plate most likely is.

Jun 21, 2009 | 1997 Ford Escort

1 Answer

Shudder terribly on acceleration


sounds like you probably have a bad transmission take it to the shop and have them diagnose it for you.

Jun 13, 2009 | 1998 Ford Escort

Not finding what you are looking for?
1997 Ford Escort Logo

142 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

61168 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...