Question about 1996 Toyota Avalon

2 Answers

1996 Toyota Avalon Heating problem

This just started when I drive my cars heats up real good nice and warm just how I like it but when I come to a light and put on my breaks it feels as if the a/c has been turned on nothing but cold air - help why is it doing this

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Toyota Master
  • 1,779 Answers

It may be as simple as low coolant level. When u are driving, the water pump is circulating the hot coolant to the heater core, if the level is low, at idle, the coolant is circulating much slower, and if level is low, the coolant doesn't circulate thru the heater core. I suspect when u check, u will find the level too low. If so, add to proper level and let me know what happens. If that's not it, I'll help further.

Posted on Jan 14, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 599 Answers

Vacuum line check valve failure to blend doors

Posted on Jan 14, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My car doesn't get warm in idle but I get real good heat while I'm driving. The fan has to be on low while in idle to stay warm.


first thing to check is your coolant level, top up if low, this is probably the biggest reason for low to no heat. Press the helpful button.

Jan 26, 2016 | 2005 Ford Taurus

1 Answer

Oil pump at idle is good when car is warming up, but after it get real warm after 20 miles of driving the idle oil presure is low about 15 lbs



  • This is normal. On your car, on a cold start the pressure will be around 75 PSI. After the engine warms an oil pressure of 15-20 PSI at idle is just what it should be. The oil pressure gauge should escalate when accelerating up a bit to. If your old school like me 15 PSI mean danger but tat Caddy is just fine.

  • If you have any comments please feel free to leave them here.
  • Hope this helps and thank you for using FixYa.


Regards, Tony

Oct 12, 2011 | 2000 Cadillac Catera

1 Answer

Hello i have a 2000 toyota 4runner limited 4x4 . i live in maine and when i start the truck up in the morning to go to work, after the truck warms up it puts out nice heat. but after i drive it for 10...


bleed cooling system.run engine with red cap off till up to temp.replace cap before turning off engine.might have to add more coolant while running.

Feb 13, 2011 | 2000 Toyota 4Runner

1 Answer

Mazda323f 1990.heater working bad,and to feet blouing cold air.how to fix.


The heater core can be stopped up or thier might not be enought coolant in the system as it has to be full for the heater to heat. The engine also has to warm up so if the therromstate were opening too much and the engine does'nt warm up the water will be too cold and the heat won't work. Remove the heater hoses at the motor conections and blow them though If they are Ok they'll blow though real easy. The cars cooling system does'nt blow very hard and is stopped up real easy. Blowing though with a garden hose reconnect and refill with antifreeze and your good to go. If it does'nt have enough antifrezze it could be frozen and the ice won't cicculate. If this has happened you may need to put the car in a garage to warm it up drain the light antifreeze coolant and put in good coolant withthe right amount of antifreeze.

Dec 20, 2010 | Mazda 323 Cars & Trucks

1 Answer

2006 armada blower works but no heat


put your **** in it and turn the blower on...it feel real nice like a number one underage japanese shemale ******

Nov 24, 2010 | 2006 Nissan Armada

1 Answer

My eclipse has developed a misfire after it has been driven for about an hour or so! after the engine really warms up the rpm gauge will spike slightly and the car will shutter a little bit and it slowly...


You didn't need a different distributor,just the sensor in it,if it was bad. That now appears questionable.
When it heats up,your ignition module,is breaking down, under load,and your getting a misfire. That would be a possible cause.
Codes don't always indicate a bad part,only the symptom, of the real issue. e.g.(Misfire)

May 11, 2010 | 2001 Mitsubishi Eclipse

1 Answer

2004 Dodge Intrepid heater problem


This sounds like your automatic climate control is starting to malfunction. Check to make sure your coolant is full, and temp is not fluctuating, and when your vehicle is warmed up, try using the low setting and feel for air temp. Is it warmer than if you turn it up? When at idle the vehicle is not producing heat the same as if you are driving, putting load on your engine and more air/fuel combustion means more heat, which is why you can feel heat while driving. Ideally you should feel heat as soon as the engine is warming up, getting hotter as it reaches peak temp of 190-210 degrees. You can try to make sure your water control valve is not blocked, and all electrical connections are secure. This will be located close to your firewall and connected to the coolant tubes that run into your firewall to your heater-core. Also use recirc (setting)to try to summon as much heat as possible, however ultimately, you may need to take you vehicle in for service. If it only warms when driving defrost will be an issue. Good luck.

Dec 09, 2009 | 2004 Dodge Intrepid

1 Answer

CANT GET MY HEATER TO HEAT IN CAR WHEN COLD


make sure blend door is moving when you select hot or cold.(under dash watch levers moving when changing from hot>cold.

Nov 18, 2008 | 1989 Buick Park Avenue

1 Answer

Ac Problem


Maybe it's a problem with the fuse or the termostat, look i don't see a real problem your a/c is balanced, its really good.

Jun 20, 2008 | 2000 Mercedes-Benz E-Class

Not finding what you are looking for?
1996 Toyota Avalon Logo

270 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

60769 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...