Question about 1997 Chevrolet C/K 2500

1 Answer

97 chevy 2500 4x4 will run good for a little wile and then shuts

Replaced the fuel pump,injectors,distr.,computer,coil,presher reg.,and tps.the plugs are getting wet andfludding out

Posted by on

  • lunchboxcraz Jan 13, 2009

    the check engin light is not comming on. will start up and run then the next min it will not start at all

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Mentor:

    An expert who has written 3 tips or uploaded 2 video tips.

  • Expert
  • 448 Answers

You have already over replaced. Wet plugs are either too cold, too late fire or bad cylinder compression. Hook a timing light to the plug in question. If the light won't fire, the plug is too cold. Check number one at TDC to see if firing at correct time. If this is helpful, please post as such or go live and I can tell you more, faster

Posted on Jan 13, 2009

  • bob collins
    bob collins Jan 13, 2009

    Have you checked the codes for direction. One thing to be very aware of is codes don't mean replace parts, it means something isn't working right. Flat tires would give a check engine of a tranny problem if it won't move very fast but you wouldn't replace the tranny. Please post as helpful or go live chat for faster answers. TY

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1990 chevy 1500 4x4 5spd. New plugs,wires, cap, button, tps, coolant sensor. Hesitation under throttle. And also runs bad after warmed up. Im fed up with throwing parts at this problem. Im thinking maybe...


My 97 was doing this, I too put a lot of money before figuring out that it was a bad coil and coil wire. Works great now. Do you have the 4.3L

Jan 20, 2013 | Cars & Trucks

1 Answer

Have a 1995 Jimmy 4.3W MPFI with OBD2. Error is P0122 TPS sensor and have replaced that. Idles between 700 and 1200. Have replaced injector spider,fuel presure reg,EGR,new gasket, fuel pressure is about...


Hi William, The fuel pump pressure is correct but the fault reading you followed means low voltage signal into the TPS. Seems you may have replaced the wrong part? I would think that the problem is with the mass air flow sensor or the ECU as that is where the signal comes from. Regards John

Oct 21, 2012 | 1995 GMC Jimmy

1 Answer

1991 chevy 454 7.4 wont idle, floods out after a few seconds,replaced everything from fuel pump to tbi presure reg,injectors.cap,rotor,wirers,coil. plugs.i am a member an pay every month to get the r


Have you actually checked the fuel pressure ? The return line could be blocked or one of the injectors could be shorted to ground.
The computer grounds the injectors to regulate "on" time. If one of the injectors is shorted to ground both will be open full no matter what the computer does. And the computer can cause the short.
You can check the circuits with a meter.
If the temp sensor had failed and was telling the computer it was 30 below zero you should get a check engine light. But it would cause the injectors to be very rich.

Aug 17, 2012 | Cars & Trucks

1 Answer

97 chevy suburban 4x4 1500 only when it drops 40 6.5 tubro diesel


fuel might be thickening -try an anti-gel or other fuel additive-also get fuel pump pressure checked

Oct 14, 2009 | Chevrolet Suburban 1500 Cars & Trucks

6 Answers

90 chevy 350 with TBI starts but wont stay running changed fuel filter and fuel regulator dont know what next


I have a 90 chevy k1500 350 tbi with same problem! I have traced problem to... after turning on key fuel pump kicks on when u crank it over injectors shoot gas and truck starts! After few seconds injectors stop spraying and truck dies! This can happen many times over and over! Eventually sometimes truck stays running and all is great! I changed ignition module, oil pressure sending unit (which i was told controls gas after vehicle is running) fuel filter, computer, fuel pump relay, I am at a loss now! Hope this helps and hope someone can help me!

Aug 10, 2009 | Chevrolet C1500 Cars & Trucks

4 Answers

5.3 L Missing and Rough Idle Intermittently


i have a 2001 chevy z-71 5.3L. I keep getting a random/multiple misfire code for cylinder 1 . I have replaced plugs, wires, coil pack(only on #1 cylinder)., and fuel pump. I still keep getting the cylinder 1 misfire code. I put truck on a scanner and watched the cylinders. # 1 misfires at idle but quickly stops misfiring at around 1000 rpms. you can here the engine miss at idle but truck runs great on road . anyone else ever had this problem?

May 05, 2009 | 1999 Chevrolet Silverado 1500

1 Answer

97 tahoe pressure reg keeps running


Are you sure it's the fuel pump your hearing and not the self leveling shock's in the back of the tahoe if you have that option. No fuel should be pumping in to your cyls because of the injector's. Unless there bad. Good luck

Apr 06, 2009 | 1997 Chevrolet Tahoe

1 Answer

My 97 Chevy 1500 runs but it will sputter and shut off .


Check the distributor cap/wires/spark plugs. Also might be clogged injectrors (injector cleaner)
Hope that helps
Good Luck

Mar 18, 2009 | 1997 Chevrolet K1500

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

128 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

60792 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...