Question about 2003 Ford Escort

1 Answer

Engine runs very poor when it gets hot

Ford escort finesse 1600cc 16v zetec engine petrol. when engine is cold it runs fine as soon as gets hot it starts to lose power.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Ford Master
  • 21,932 Answers

It has a sensor problem or a blocked air filter ?' if its a sensor then its most likely to be the one on the other side of the throttle linkage

Posted on Aug 07, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2001 ford focus with zetec engine still sputters and stalls when warmed up after replacing fuel pump, fuel filter, and fuel tank pressure sensor


i have ford focus ghia 2.0 2002 model and i have problem with the fuel pump sometimes it works sometimes it doesn't.. when i fill the tank petrol pores out, the pipe next to the filter also comes out, how do i fix the problem?

Dec 08, 2012 | 2001 Ford Focus

1 Answer

I HAVE A 1998 FORD ESCORT 1.6 LX ESTATE WITH A 16V ZETEC ENGINE. THE CAMBELT HAS ONLY DONE 33 THOUSAND MILES BUT HAS BEEN ON FOR 5 YEARS. DO I HAVE TO CHANGE IT SOON.


I would wait for the milage recommendation. (Unless of course you have an oil or coolant leak that is getting on your timing belt) When you do replace it though, have the tensioner and idler pulleys replaced also. The whole deal can be had as a kit.

Sep 24, 2011 | 1999 Ford Escort

1 Answer

How to set timing marks on 1.8 16v Zetec Escort 97


how I change the fusebox of Escort Zetec 1.8 (1998) SW?

Jun 07, 2010 | 1997 Ford Escort

2 Answers

Can i fit a 2 ltr 16v zetec head on a 1.8 16v zetec block


no, even if they did bolt up, it would probably not run very well and the check engine would most likely be on...

May 14, 2009 | 1997 Ford Escort

1 Answer

Water pump on escort


If the engines are Zetec DOHC 16v, I would suggest that you source a new water pump for your engine. To change the water pump is not very easy for the average DIY. I would entrust the job to a vehcile technician and get the drive belts changed at the same time as the anti freeze would have contaminated your drive belts.

Mar 12, 2009 | 1996 Ford Escort 4 Door

1 Answer

Car wont start


sounds like your batterys flat

Jan 31, 2009 | 1998 Ford Escort

1 Answer

1998 ford escort 1.6 16v Zetec engine running rough and missing (UK Car)


you have answered your own question ,also a regrind of crank wouldnt go far amiss

Sep 21, 2008 | 1998 Ford Escort

2 Answers

Ford tick over problem


Hi there!

A few more things to check for you.-

A vacuum leak in any of the vacuum hoses will cause the ECU to make random guesses at what's going on.

Have you replaced plugs recently - or at all? This is probably the main cause - and certainly worth a try.

Fuel filter should be replaced at recommended intervals - about 3 years.

Clean your leads and HT gear really well with a degreasant. Any losses will be more noticable at tickover than high revs.

Lastly.........wear on cam lobes or timing belt.

Hope it's cheap for you!
Please spare a moment to rate as fixya! if any of this information proves useful. Thanks (I don't get paid for this)

Jun 18, 2008 | 1997 Ford Escort

Not finding what you are looking for?
2003 Ford Escort Logo

Related Topics:

437 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60541 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21927 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...