Question about 2005 Chevrolet Impala

1 Answer

My speedometer dont work and my temp guagegose to the bottom

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 2,101 Answers

Chevy have a lot of problems with thier instrument clusters in all thier cars and trucks . the cluster will need to be replaced

Posted on Dec 07, 2012

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

97 plymouth breeze speedometer,tach gauge,temp gauge,brake lights, dont work.


circuitry behind the gauge panel. you will have to pull the dash to see behind there and track the problem down

Nov 28, 2013 | 1997 Plymouth Breeze

1 Answer

None of my gauges work on my 1981 chevy k10


the speedo on that is a mechanical cable from the trans the other gauges are controlled from a fuse and sending units

Aug 28, 2012 | Chevrolet C1500 Cars & Trucks

1 Answer

Need to find out why the radio, guages, and speedometer all just quit, have checked all fuses. Did troublshooting online and it tells me it could be the voltage regulator or the engine temp sensor. I dont...


Start with verifying that the fuses are indeed GETTING power to them and they are indeed good. Use a test light to check fuses. When the engine is running, gently turn the ignition key either way and see if they come to life, if so, the ignition switch is bad. The Voltage Regulator or Temp sensor have absolutely NOTHING to do with your problem.

Dec 18, 2010 | 2002 Oldsmobile Alero

1 Answer

Speedometer Rpm heater and temp gauge dont work. All of these stopped working after the dealership fixed the dash lights. How do I fix them.


check in your owners manual and see if all the things that dont work are on one fuse.. if they are its simple fix

Mar 20, 2010 | 2000 Cadillac Catera

1 Answer

Gas gauge dont work


sensor might be malfunction of the circuit might be disconnected.

Sep 19, 2009 | 1995 Honda Civic

2 Answers

96 sunfire 2.2 Dumby Lights


i've got the same problem except my car stopped running... i thinks its a corroded wire somewhere in the harness... but i dont know for sure mines been sitting in my driveway while i try to figure out why it wont start

Aug 09, 2008 | 1996 Pontiac Sunfire

Not finding what you are looking for?
2005 Chevrolet Impala Logo

63 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76848 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...