Question about BMW 750

2 Answers

Lack of power

BMW 735i 1991, about 4 days ago I experienced lack of power particularly under load (hills, pulling away etc.) Out of gear the engine runs fine. It is now getting worse. The engine has stalled a couple of times..it starts well, but then runs rough.. a few blips on the throttle and eventually it picks up and I can drive away?? Any guidance please?

Posted by on

  • 1 more comment 
  • Kenneth Bate Jan 12, 2009

    The power is sporadic. If you slam your foot down in neutral it bumbles along then suddenly it goes to full power. If I try to drive, it will totally lack power, the suddenly it revs up again. I feel sure its a fuel blockage or sensor or something along those lines but I don't know where to look first. Its not ignition, as it is not misfiring. Thanks

  • Kenneth Bate Jan 13, 2009

    On further investigation it does seem to be the fuel pump. The car had been laid up for 6 months with very little petrol in the tank, which apparently is not good news if the fuel pump is not submerged in petrol, which might lead to corrosion?? Any experience of this happening??

  • Scott  Moore
    Scott Moore May 11, 2010

    Are you loosing power, or is the car missing in conjunction with?

×

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 103 Answers

Yea I have a 89 prelude that I did the same thing to. Mine wouldn't even start. you might not need a fuel pump it could be the strainer over the pump. it could be clogged. I would try using a high dollar fuel system cleaner.

Posted on Jan 13, 2009

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 39 Answers

Change your fuel filter, and run a can of "Seafoam" in your next tank.....
Check your spark plug condition and connections, as well as your distributor cap

Posted on Jan 12, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

What could be the problem my car lacks of power


What make and model of vehicle ?How many miles on it ? When does it lack power, all driving conditions or just under a load, such as going up a hill under heavy throttle ? A couple of thing's right off that it could be is a plugged catalytic converter , plugged fuel filter or a weak fuel pump. Are there any lights lite on the dash , check engine light etc.. Have you experienced any strange noises or happenings ,like engine back firing. How does the engine run ,smooth ,ruff ? Have you had spark plugs changed and wires if it has them ?

Dec 19, 2014 | Cars & Trucks

1 Answer

My 1996 v6 chevy truck engine runs good at idle but in drive it has poor acceleration. In idle I can maintain 2500 RPM but in drive it does go to 2500 but the truck acts like it has resistance. I was...


sounds like a catalytic converter - runs good but lacks power - the back pressure keeps the engine from being able to accelerate under load - good luck :O)

Feb 19, 2011 | 1991 Chevrolet S-10 Blazer

1 Answer

1986 Ram 50: Engin and carburator sputter and lose power when g...


i have an 86 dodge ram 50 that sputters when i step on gas going up hill after it warms up ive changed the gasket twice with no luck solving problem it runs fine in neutral but in gear under a load it sputters

May 14, 2010 | 1986 Dodge Ram 50

1 Answer

1994 Honda Accord LX Burning Oil; Loss of Power


Replace your PVC valve $10 and see what happens.

Feb 04, 2010 | 1994 Honda Accord

1 Answer

No power when accelerating hard


Possibly a plugged catylitic converter. This can cause to much back pressure and that will cause the engine to run poorly under acceleration or loaded conditions.

Nov 09, 2009 | 1997 Chevrolet Suburban

1 Answer

Car feels slugish when going up-hill, slight vibration, level and downhill runs ok, from start shifts through gears fine, just feels odd at times


problems you described would suggest you need to replace the spark plugs, a bad one tends to fail under loads like going up hill. the other thing you could try is to get a better fuel grade, that would correct pinging noises uphill. and throw in some fuel injector cleaner every 2000km, it makes a happy running engine

Nov 03, 2009 | 1991 Oldsmobile Cutlass Ciera

1 Answer

Bmw 735i starts fine when cool. but once turned off


sounds like you may have a bad coil, would be my guess, hope was some help

Aug 19, 2009 | 1996 BMW 7 Series

1 Answer

No power, idling rough


Replace the catalytic converter and EGR valve

Jun 03, 2009 | 1991 Subaru Legacy

1 Answer

Starts O.K. Lacks pulling power. Will not rev to full power.


check for a clogged exhaust look at catalytic converter it could be stop up.

May 24, 2009 | 1999 Suzuki Vitara

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

331 people viewed this question

Ask a Question

Usually answered in minutes!

Top BMW Experts

Fred Sops

Level 2 Expert

271 Answers

Al Clark

Level 2 Expert

290 Answers

Doberman

Level 2 Expert

246 Answers

Are you a BMW Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...