Question about 2009 Chevrolet Cobalt

1 Answer

Cel on po100

Runs ok

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Chevrolet Master
  • 21,873 Answers

I don't have a definition for this code for GM, but the generic code means there is a problem with the MASS air flow sensor or meter.
You might check to make sure the air filter and hose are connected correctly.

Posted on Dec 07, 2012

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Will not start cold without a lot of tries runs fine warm?


the first sidekick ever. 1989. (and tracker)
the first few were made in Iwata japan then at CAMI (canada) then on.
first off this year, came with 2 engines, 1.3L carb and 1.6L TBI EFI.
so what engine? we can NEVER guess and engine, blind.
The CEL if a CEL , and TBI 1.6L engine G16A
that lamp can glow for 2 reasons in 1989-95.
Check engine. function
and what we call the NAG lamp.
http://www.fixkick.com/CEL/NAG-Lamp.html
the nag switch is hidden in 3 locations in 7 year span.
its just to make folks angry.... (Hiroshima>? revenge?)
on this car, if it has a NAG it on the bottom kick panel
between your legs, (toes)
and can never be seen. only felt (lacking a mirror)
NAG = federal (usa) mileage warning see if leaded fuel messed up the CAT ,deal,, (totally useless now)
We remove them at the cluster 3 wire connector forever.
so if present slide the switch 1 time.
now the CEL lamp can flash out flash codes.
http://www.fixkick.com/CEL/CEL.html
hard cold starts, if CEL flashes 12s does it?
causes (top, not a guess) I do tests to find these but takes TOOLS.
  1. never tuned up with all new spark parts and filters.
  2. cam belt slipped. (60k part)
  3. engine is flooding, high fuel pressure, (too high)
  4. TBI injector o-ring leaking. flooding starts.
  5. ECT wires fell off.
  6. map hoses bad. or clogged end to end. from plenum to map sensor insides (nipple not clogged either)
  7. not melted cat, runs fine hot.
  8. not code 12s flashing (good) so what is it flashing. ?
  9. stuck open EGR main, (that can bounce closed as you crank long then be ok... for a while, many old EGR like to stick just as you stop car and shut down) can be felt by hand on any 8v engine easy. the diaphram ring can be exercised with fingers.
  10. IAC bad, stuck closed, preventing cold start air . and flooding.
  11. ISC valve same.
  12. Dash pot valve stuck retracted. (clod start vacuum start)
  13. spark timed wrong , see cam belt slip.

Nov 06, 2015 | 1989 Suzuki Sidekick

1 Answer

No check engine light, bulb test good


wow, no jeep stated. nor what year, nor what engine.

ill not even beg country (exports are diffr)

below is all ways, discounting bulb tests.



i guess you mean the key on only self test fails with CEL?

ok the PCM glows the lamp at key on, to tell you the PCM is happy and that it passes its rudimentry self checks

basically means its alive.

if the lamp fails to glow ? (all ways, i fix ECU so know this)



  1. power to lamp dead (fuse ) yes fuses can crack (unseen)


  2. lamp bad, (test it with a battery)


  3. cluster wiring to lamp bad, or that wire from PCM to lamp bad.


  4. ECU bad, yes, some bad ECU's can run an engine.


  5. ECU stuck in backup mode, (think limphome but 2 times worse)


in your case id say bad ECU, or bad wire from ECU to CEL.



no year stated, so is it 1988 with that silly junk RENIX EFI with no working CEL or is the unstated car 1993+ where the CEL started working for the first time?

if 93 or newer, we can connect a scan tool, and scan it.

and see , omg , comms are dead, so ECU is in backup mode.

(backup mode is like lawn mower mode, sure it runs but like crap)

ask? can give vivid details of all modes.....



or comm's is ok, and scans and we see DTCs stored and the CEL status in the scanner says ON,"aka, active CEL"



if it says ON< and is not on, then the wire is bad or the

CEL transistor in the ECU blew up. (common with folks using wrong bulb and overheating this poor transistor) replaced many i have.



there are some facts. and is poorly stated. due to NO YEAR !



retired, ET,

Apr 30, 2015 | Jeep Cars & Trucks

1 Answer

Got stolen broken ignition got new back tried starting it runs for few mi and stop how can i bypas


somethings missing here. try to tell the full story,
stolen.
got it back
and what is still broken, phyiscally ??? the key , lock/?
or is the key working? (or are you using the bandits, hacks?)
or runs ok with the key. but then stalls.?
if it stalls ,did the CEL lamp go out too? in the dash CEL lamp at the stall tells you the ECU still has 12vdc electrical power. does it?
do the Head lights work at the stall????
and other electrics???????????

Apr 24, 2014 | 1990 Jeep Cherokee Limited

1 Answer

2000 tundra runs in park but stalls in drive


ok,
cel light on running?
scan it.
no engine power. (low fuel pressure, filthy maf? )

Feb 15, 2014 | Toyota Tundra Cars & Trucks

1 Answer

Spare part 12(po100)


P0100 NISSAN - Mass Air Flow Sensor Circuit Range/Performance Error

Possible causes- Dirty mass air flow sensor
- Dirty mass air filter
- Mass air flow sensor harness is open or shorted
- Mass air flow sensor electrical circuit poor connection
- Intake air leaks
- Faulty mass air flow sensor
Tech notes Before replacing the mass air flow sensor, try replacing the air filter and cleaning the air flow sensor with low compress air or mass air flow sensor cleaner. Reset code and drive vehicle. If the code comes back, it may be necessary to replaced the mass air flow sensor.

Sep 25, 2012 | 1997 Nissan Pickup

1 Answer

Code po100 & p0300 come up. then I clean throttle body with cleaner, then the van stops missing & run good & light go's out.


P0100 is mass airflow circuit, p0300 is multiple cylinder misfire. Faulty maf sensor is most likely the cause of the misfires.

Mar 11, 2011 | 1998 Chevrolet Astro

1 Answer

1999 ford contour se custom sport check engine light stays on recently had new alternator replaced and when i turn heat on it only runs on hi otherwise car is running ok will the check engine light go off...


Contour's are notorious for check engine lights. Mine has been on for years. The only way really to reset the CEL is to rent or buy a code reader and record the codes that are stored. Information on CEL codes is available on the internet. FYI the most common code for contour's are P0420 and P0421. These won't cause any driveability issues. As for your heater problem, your fan blower relay is toast

Feb 13, 2010 | 1999 Ford Contour

Not finding what you are looking for?
2009 Chevrolet Cobalt Logo

Related Topics:

24 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...