Question about 2003 Toyota Tacoma

2 Answers

Stalls when accelerating going uphill - 2003 Toyota Tacoma

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that got 5 achievements.

    Habit-Forming:

    Visited the website for 3 consecutive days.

    Corporal:

    An expert that has over 10 points.

  • Contributor
  • 15 Answers

Sounds like you have fuel delivery or ignition problems.
Also bad throttle pos.sensor can cause similar effects
Do you have any service engine light on? When did you have tune up last time?
Is it stall like loosing electricals (chargin system issues)or alike engine loosing its power?

Posted on Dec 06, 2012

Ad
  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 35 Answers

Replace plugs,rotor button and cap.

Posted on Dec 06, 2012

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

  • 2 Answers

SOURCE: stalls when accelerating

Tom, it sounds like you might have some bad spark plugs or a dirty fuel filter. I would buy a fuel filter and change it myself first. This is pretty easy to do and much cheaper than changing the plugs. Also requires minimal tools. If your not confident doing this you can get a Chiltons Munual for your make and model from your local library.

Posted on Dec 06, 2012

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Van has been loosing power going up hill. Runs fine on level land and going downhill. lately it has been stalling when u first start it up.


try checking your crankshaft or tps throttle position sensor it could cause you to lose power at times

Apr 02, 2014 | 2005 Kia Sedona

1 Answer

Loses power in high gears


run fault codes and look for accelerator position sensor fault . Check for MAP/MAF sensors as well

Feb 18, 2014 | Cars & Trucks

1 Answer

Low oil pressure on 2006 expedition. stalls going uphill and makes a knocking noise. p0012 and p0340


Check oil flow control valve, camshaft position sensor, crankshaft position sensor and all the wires/ connectors.

May 06, 2017 | 2006 Ford Expedition

1 Answer

Runs but stalls going uphill. takes forever to


Have a compression check done on the engine

May 11, 2010 | 2002 Pontiac Sunfire

1 Answer

I have a 2003 ford focus, today I was going up a not so steep hill and my car started stalling, I didnt know what to do so i pulled to the side, turned the car off and then back on, after that I was able...


If it's happening going uphill, or when you hit the gas to accelerate hard, it's very likely a clogged fuel filter. Change that out and you should be OK.

Dec 16, 2009 | 2003 Ford Focus

Not finding what you are looking for?
2003 Toyota Tacoma Logo

368 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8516 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...