Question about 1994 Chevrolet S-10 Blazer

1 Answer

What's your problem?my 96 blazer is revving at about 3100 in park and neutral and accelerates on its own to about 40 45 mph anyone know why this is happening?

My 96 blazer is revving at about 3100 in park and neutral and accelerates on its own to about 40 45 mph anyone know why this is happening?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 458 Answers

You have a stuck/defective IAC(idle air control) motor or a HUGE vaccum leak.Or,your throttle cable could be binding,causing the throttle to stick.

Posted on Dec 06, 2012

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 2309 Answers

SOURCE: I would like to know how to tow a 86 s-10 blazer

best solution is to remove the driveshaft to the rear, and disengage the front hubs

Posted on Jul 27, 2010

  • 21 Answers

SOURCE: rpm running high when park

well. your idle is just high. you can get a screw driver and find the idle screw on the throttle body. . and jsut adjust there , , that is if there are no problems.

now it also maybe a leaky intake. . . . but i think its jsut more of a small adjsutment. . 8)

Posted on Oct 22, 2008

  • 2 Answers

SOURCE: blazer not responding to the accelerator, won't rev up

I'm actually going through the same thing, after i just had my fuel pump replaced. Mine turned out to be my Mass Air Flow sensor (MAF) which when not working properly has the same effects as your acceleration not working.

Posted on Oct 05, 2009

  • 1082 Answers

SOURCE: my blazer runs butiful when

Do you find that it does better when cold, then gets real bad as it warms up?
If so, then the catalytic converter is plugged and needs replacing.
A scope check by mechanic should confirm this.
If it's not been replaced for last 100k to 200k, then it should probably be done anyway.

Cats go bad usually because of long term poor quality ignition, blowing to much unburned gas into eshaust system. Does your 89 Blazer fit this description?

Beyond that I can't help you. Others on this site know more about it.

Posted on Jan 09, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

96 blazer wont start in park or neutral, just happened 2 days ago?


Check the neutral safety starting switch and connections.

Dec 03, 2015 | Cars & Trucks

1 Answer

Dead for starting like no battery


I believe Neutral start switch is in the transmission. Try to start with the shifter in Neutral instead of Park. Make sure the wires to the neutral switch are intact. Make sure the battery cables are good and measure the voltage at the starter solenoid.

Jul 06, 2014 | 1996 Chevrolet Blazer

1 Answer

Engine not revving past 2500rpm in park or neutral?


Could be problem with TPS sensor or IAC sensor.

May 08, 2013 | 2004 Chrysler Voyager

1 Answer

96 chevy blazer stuck in drive


sounds like a cable or lever problem but without a good look i couldnt tell you exactly ,10 secs of me looking i would know thats for sure but from afar ??

Sep 22, 2012 | 2002 Chevrolet TrailBlazer

2 Answers

Clicking only while accelerating, 5-speed


Could be a noisy valve or lifter in the engine, or an exhaust leak.
Can you make the noise happen by revving up the engine with the car parked ?

Jul 18, 2012 | 2002 Toyota Corolla

1 Answer

Idling At 3,000 rpm


you have a open vacum line.check your brake boster..

Jun 10, 2010 | 2000 GMC Sierra

1 Answer

Blazer not responding to the accelerator, won't rev up


I'm actually going through the same thing, after i just had my fuel pump replaced. Mine turned out to be my Mass Air Flow sensor (MAF) which when not working properly has the same effects as your acceleration not working.

Oct 04, 2009 | 1998 Chevrolet Blazer

Not finding what you are looking for?
1994 Chevrolet S-10 Blazer Logo

178 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

74945 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7697 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...