Question about 1999 Chevrolet Astro

1 Answer

Check engine light on with the TPS code. replaced TPS and pig tail and it checked out OK with volt meter. The light still comes back on with the TPS code

What else could be wrong that would make the TPS code come up?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 5,370 Answers

Check engine light comes on and off, these are indication that there is some error code stored in your vehicles ECM. The engine module computer needs to be scanned. These will give the code and as per the error code the further problem can be detected and confirmed. The engine light indicator blinks or remains steady on dash when engine computer noticed any problem with any engine electrically operated components.


For more help, I suggest you to refer the help links provided below. These will let you know more about which areas to look, check, when there is engine light coming up on dash panel.

---------

Click the link below: -------

CHECK ENGINE LIGHT


http://alltypesofpartsreplacing.blogspot.com/2012/12/check-engine-lightengine-warning-light.html

---------------

Check Engine Light Reset Procedure?
http://whoisbyme.blogspot.in/2012/06/check-engine-light-reset-procedure.html
----------
These will help.
Thanks.

Posted on Dec 06, 2012

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
bigawgntown
  • 13 Answers

SOURCE: check engine light

you need to go to an electronic specialist or you can buy one of the scanners that clears the codes for you from advanced auto or autozone or some place like that.

Posted on Jul 30, 2008

  • 4 Answers

SOURCE: 2002 monte carlo EVAP problem continues.

did you try a vent solenoid? this is located behind left rear wheel in fender.

Posted on Nov 07, 2008

  • 14 Answers

SOURCE: Check Engine Light - O2 Sensor - bank 1 running lean

you should have three oxygen sensors on your car, one for each bank of three cylinders; should be towards the Y pipe on each exhaust manifold. Additionally you should have one on the exhaust pipe before the cadilitic converter.

Posted on Nov 20, 2008

GM Elec
  • 1000 Answers

SOURCE: Check engine Light

The P0455 indicates you have a gross vacuum leak in the EVAP system.
Start at the engine and the vacuum purge valve, start checking the vacuum hoses and lines all the way back to the EVAP canister near the gas tank. Make sure no hose or lines are cracked / disconnected.
If all looks OK, let me know and we will proceed from there. Below is a schematic of the EVAP system for reference.
Good luck and let me know.
Regards,
14ebebd.jpg

Posted on Feb 21, 2009

  • 53 Answers

SOURCE: Check engine light and no power to DLC

Check the fuse that powers the DLC. It might be shared with the cig lighter or aux power sockets adn may have been blown.

Posted on Nov 21, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Po123 04 kai


Hello www_ropesmor,

This code P0123 is Throttle position sensor circuit high input.

There four basic reasons for this code.

1. An open or short to ground between the TPS (throttle position sensor) and the ECM (Engine control module).
2. A short to battery voltage between TPS and the ECM.
3. A short between the TPS wires.
4. A faulty TPS.

See below for connector diagrams.

First, with scan tool monitor TPS with throttle closed voltage should be
I f you don't have a scan tool, back probe terminal 1with a volt meter to ground and you will see the voltage as outlined above otherwise follow the steps below.


1.Check to see if there is about 5 volts at the TPS; with engine off key on disconnect the TPS back probe the harness side terminal 3 to ground with a volt meter if there is about 5 volts go to step 2 if about 5 volts if not repair the 5 volt circuit.

2. Probe the harness side terminal 2 to chassis ground with a volt meter, if voltage above .02 repair circuit 2 short to voltage. If voltage is .02 volts or below go to step 3.

3. Probe the harness side terminal 1 to ground with volt meter if below .5 volts go to step 4 if not repair short to battery between TSP harness and ECM connector

4 Turn the ignition off and disconnect the ECM connector . With an ohm meter measure the resistance between the ECM (terminal C18) and TPS ground circuit it should be below 1 ohm. Measure the resistance between the ECM (terminal C8) and TPS signal circuit it should be below 1 ohm. If not repair the open circuit.

After faulty circuit is found and repaired clear code and verify repair.

netvan_160.png


netvan_161.png


I hope this helps.

Regards,

netvan

Aug 15, 2011 | 2004 Kia Optima

1 Answer

P0120 P0220 faults on a 03 Avalanche. First went into reduced power mode. Cleared faults. Truck still will not go over 35 mph. Did not trip the check engine light.


this is an obd2 trouble code table, it can help you understand the meaning of code.
for p0120,
the possible solutions:
If you have access to a scan tool, with KOEO (Key on engine off) observe the TPS voltage. With throttle closed, voltage should be about .45 volts. It should gradually sweep upwards to approximately 4.5 to 5 volts as you depress the throttle. Sometimes only a scope can capture an intermittent glitch in the TPS signal voltage. If you notice a glitch in the TPS sweep voltage, replace the TPS.
NOTE: Some TPS sensors require fine adjustment. If you aren't comfortable with using a DVOM (Digital Volt Ohm meter) to adjust the new TPS, then it's best to take the vehicle to a shop. If the voltage is not .45 volts (+or- .3 volts or so) with the throttle closed or if the reading is "stuck" then unplug the TPS connector. With KOEO check for 5 volts reference voltage present at the connector and a good ground. You can check the signal circuit for continuity by jumping a fused wire between the ground circuit of the TPS connector and the signal circuit. If the TPS reading on the scan tool now reads zero, then replace the TPS. However if that doesn't change the reading to zero, then check for an open or a short on the signal wire and if none is found, suspect a bad PCM. If manipulating the TPS wiring harness causes any change in idle, then suspect bad TPS.

Jul 20, 2011 | Chevrolet Avalanche Cars & Trucks

1 Answer

I was wiring a trailer pigtail to an 06 wrangler and blew the turn signal bulbs but the fuses are good. I have running and reverse lights but no brake lights or turn signals


If the bulbs and the fuses are good, check the brake light switch. You might of shorted out the switch when working on the pig tail. Always use a test light or volt meter when installing pig tails. This way you can check for power and ground before hooking a wire up to help prevent shorts. But by what you have said it does sound as if the brake light switch is now bad.

Jun 27, 2010 | 2006 Jeep Wrangler

1 Answer

None of my brake lights are working, but the taillights do work. Would this be a fuse issue or something else


Make sure the switch at the bottom of the brake pedal is not bad. Pull a bulb out of the tail light have someone use a volt meter, while you press the brake, check to see if you have voltage at the pig tail.

Feb 04, 2010 | 2000 Jeep Grand Cherokee

2 Answers

AP Sensor Serviceable?


no not difficult for weekend mechanic ,just awkard and finger crunching

Dec 27, 2009 | 2001 Hyundai XG300

1 Answer

Passenger High beam/Running light in 99 Cavi wont work


With the engine and lights off check the other light that is working with an ohm meter and determine which wire is the ground. Then check the same wire on the light that is not working and see if it is grounded. If it isn't, you can probably use the one good ground for both lights. The plug you mentioned is usually called a "pig tail" (I don't know why-doesn't look like one...) and it might still be bad. Or the ground connector is bad. The point is with the lights off the vehicle and apart, use the ohm meter to check out the pig tail and eliminate it.

May 03, 2009 | 2000 Mercury Cougar

1 Answer

Check engine light on


replace tps switch and adjust it to factory specs.

Jan 20, 2009 | 1990 Buick Regal

1 Answer

95 ford f-250 4.9 engine


no you need to get service key reset ok m8

Jan 03, 2009 | 1995 Ford F250

Not finding what you are looking for?
1999 Chevrolet Astro Logo

934 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8518 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...