Question about 1998 Land Rover Discovery

1 Answer

2000-1500 rpm loss

Cutting out at around 2000 rpm, to 1750 or 1500 rpm. just replaced all 4 o2 sensors still doing it. Bleeding more fuel than usual.New plugs still doing it. what is the problem ?Please !!!!!!!!!

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

  • Contributor
  • 4 Answers

Hi same Problem too dosnt really miss just cuts out at the same rev range, weve got new coil,leads,cap, dizzy button gonna double check the plugs tomorow but i am thinking maybe a dirty fuel filter or and issue with the dizzy in the module or wiring somwhere along the lines, if not i am thinking also that maybe the MAF meter may be shagged and over fuelling cos it does smell like its running very rich and u can smell the fuel coming out the pipe sometimes

if u find anything else let us know how u go, i will post back on how i go :-)

Posted on Jan 18, 2013

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why is car running rough and cutting off and smelling like Sulphur losing power and not starting sometimes


First, have your O2 sensor (Oxygen sensor) checked or replaced. On most cars it is easy to replace, but will make the computer do as you described when clogged or defective.
Next, see if your Catalytic converter is clogged. This will also make the engine do crazy things, since it affects the exhaust, just as a bad O2 sensor (also in the exhaust) will give bad data to the computer.
Good luck.

Feb 16, 2016 | 2003 Pontiac Bonneville

1 Answer

When driving my 1997 Audi A 4 1.8t there is a loss of power around 3000 rpm, what could be causing the issue?


run the fault codes and look for a problem area in the vane actuator of the turbo
it could be a sensor problem or a MAP sensor problem
this is indicated by the pressures being generated or not generated by a turbo generating pressure from the throttle opening on acceleration or held at constant speed

Oct 19, 2015 | Audi Cars & Trucks

1 Answer

Fuel pump,fuel filter o2 sensor and electronic brain have bee replaced and it still dies at lower as well as hwy speeds?


Check ignition module. They have a low rpm and high rpm section. Parts stores will usually test for free.

Dec 30, 2014 | Cars & Trucks

1 Answer

I have replaced the fuel pump, spark plugs and


I bought cheap $100 fuel pump instead of 200 and have trouble with gauge cutting in and out all the time. Also can't go below 1/4 tank or it will lose prime because check valve doesn't work. Check wires are on good and the numbering. Did similar work to mine. Mine was cutting in and out while driving. Loss power and then gained power back and rpm tach would go nuts. It was the crank sensor.

Sep 27, 2014 | 1997 Chrysler Sebring

2 Answers

Check Engine Light on - needing O2 Sensor However my RPM keeps going up and down while car not moving. And if i stopp for a long time at a stop light car will cut off and I need to put car in neutral to...


You should try to clean the throtle valve and see if that works. The lambda sensor will increase the fuel consumption and the pollution. It's better to replace the sensor.

May 18, 2011 | 1998 Toyota Camry

1 Answer

2000 ford expedition ,,rough idle in park..rough idle in drive,, sometimes dies..rpm's in drive at idle 400...replaced iac


Check the fuel pressure at the rail assembly, there should be a min of 40 lbs at the rails. Do you have any loss of power under a load? You may have an issue with your o2 sensor that is causing the ecm to send an improper signal to the engine ign/fuel map.

Dec 07, 2010 | 2000 Ford Expedition

1 Answer

2006 jetta 2.5 engine light on


Go to the VW Vortex site, or VWFixx, or RussTech and stroll around the forums. Find someone near you with a Vag-Com and get the codes. Or go to AutoZone and get the codes.

I've got a 2001 1.8T New Beetle and I am alwasy getting codes. Have repaired and replaced, repaired and replaced, a number of things. O2 sensors, hoses, valves, sensors, etc, etc., and couldn't do any of it without the VagCom.

Bottom line to help is codes, we need codes.

Jan 24, 2009 | 2007 Volkswagen Jetta 2.5 Sedan

Not finding what you are looking for?
1998 Land Rover Discovery Logo

75 people viewed this question

Ask a Question

Usually answered in minutes!

Top Land Rover Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

yadayada
yadayada

Level 3 Expert

75051 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7726 Answers

Are you a Land Rover Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...