Question about 2004 Mercury Mountaineer

2 Answers

Guages,radio and heater stopped working - 2004 Mercury Mountaineer

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Greenhorn:

    A rookie expert who has answered 20 questions on their first day.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 21 Answers

The most likely cause for this is that a fuse has blown and you need to replace a fuse. Check the fuse box, located on the drivers side under the instrument panel.
guages,radio and heater stopped working - 12_5_2012_7_12_06_pm.jpg


Based on your description, I would check fuse 17 first. Fuse 17 controls various accessories. It should be in the middle column, second from the top. It should be a 15 Amp fuse.
12_5_2012_7_12_43_pm.jpg


There is a fuse puller tool in the fuse box that will make removing fuses easier, remove fuse 17 and check if it has burnt out using a multimeter, or by checking to see if the metal strip in the middle of the fuse (inside the plastic) has burnt through/is disconnected. If so, replace the fuse with another 15 Amp fuse.

If fuse 17 is still okay, it is possible that other fuses have blown, though the likelihood of multiple fuses blowing is uncommon. The radio runs through fuse 3, climate control through fuse 16, and the instrument cluster through fuse 21.

If all the fuses check out okay, it is also possible that you have a bad relay. There are relays located at the top side of the fuse panel, and relay 3 controls various accessories as well.

If neither of these proves to be the problem, then your vehicle may have a wider problem with its electrical system and may need to be taken in for repairs.

Posted on Dec 05, 2012

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 3 Answers

Disconect the postive terminal of yr batery,wait 5 or more mins than conect it back,that might reset yr car computor, good luck

Posted on Dec 05, 2012

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Guage Cluster Dose not work


Have the CPU program reset by using a code reader . When the battery is removed the CVPU program becomes corrupted . As to the radio you will need the radio security code to re set it.

Mar 01, 2014 | 1997 Chevrolet Venture

1 Answer

Guage Cluster


Yes the radio is tied to the dash and if you get another one it will have to be programed to recognize the radio.

Feb 27, 2014 | 1997 Chevrolet Venture

2 Answers

All guages on console are not working, truck-GMC 2006 P/U


Factory defect. Take it back to the dealer. Had my entire instrument cluster replaced at 85K miles. Even though out of warranty, everything was free.

Dec 29, 2009 | 2006 GMC Sierra

1 Answer

FUEL GUAGE DOSENT READ ACCURATELY GOES FROM QUARTER TANK TO EMPTY. HORN DOES NOT WORK ALL THE TIME. RADIO SPEAKER IN REAR DRIVER SIDE COMES ON WHEN IT WANTS TO AND PASSENGER SIDE REAR DOES NOT WORK AT ALL....


Fuel gauge problem is the sender card inside the tank very common problem.Horn could be contact problem inside steering wheel,heater could be coolant level or heater core blockage other things will need to be diag.

Dec 25, 2009 | 2000 Oldsmobile Bravada

1 Answer

Had a slow coolant leak Oil temp guage redlined installed new failsafe thermostat, it still would not produce heat. Had a radiator flush and oil change and used bards leak, seems to have worked. Oiland...


there is a valve in the hot line to the heater core, it may not be opening. or you might have to disconnect the heater hoses and flush the heater core, stop leak will some times stop up core since tubes are very small

Dec 17, 2009 | 1995 Buick Regal

1 Answer

2005 Cadillac Escalade Heater


you could have a leaking hose a bad water pump or a bad heater core...its going to be one of those things,,,

Feb 07, 2009 | 2008 Cadillac Escalade

1 Answer

We seem to be have electrical problems.


Hi Harleysport,

Sounds like you have a problem with the grounding side of your electrical circuits....Check the battery connections and then all the other grounds....

Regards Johngee10

Sep 09, 2008 | 2005 Dodge Caravan

Not finding what you are looking for?
2004 Mercury Mountaineer Logo

286 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

fordexpert

Level 3 Expert

5501 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...