Question about 1988 Oldsmobile Firenza

1 Answer

2000 Chrysler Town & Country , no heat, blower fan working fine

My van all of sudden stopped blowing hot air even though I have the heat controls at mid to full hot settings. The blower is working fine and blowing air.

What could be the problem? Is there a heater on the van? All along I thought that the heat was generated from the heat from the engines and there is no additional heating mechanisms. Is that not correct?

Posted by on

  • 1 more comment 
  • Anonymous Mar 14, 2009

    I have the identical problem. I'm guessing there is a water pump involved, which would not be THE water pump since the engine would overheat if that weren't working.
    Have you heard anything?


  • Anonymous Mar 22, 2014

    heat control works but not fan speed

  • Anonymous Mar 22, 2014

    heat control works but not fan speed
    it always stays on high no matter which setting it is on

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Probably one of two things. First make sure that your coolant level is full. If the coolant is not flowing properly you won't get heat. If you begin to get heat while driving, but only when you are excelerating, this is your problem. If that is not it you may need to change the thermostat. This is noot hard as long as it is easy to get to and it should be easy.

Posted on Apr 08, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2002 town and country Chrysler I turn on the a/c but in the front it wont blow cold or hot air but in the back were I seat my kids throughs cold air in the back


Your van apparently has dual heat and air and it sounds as if your rear unit is working and your front is not. Will the front blow at any speed? or is it completely dead? If it will only operate on a medium setting you should have your blower resistor changed out, but if it does not operate at all, check for voltage at the blower motor plug in. If you have power but the motor is not running then have the blower motor changed.

Apr 22, 2016 | Chrysler Cars & Trucks

1 Answer

My wipers...lights..radio and horn went out but I can drive the car..what would cause this?


2008 Chrysler Town & Country Intermittent Electrical Failure ...

www.carcomplaints.com/Chrysler/Town_Country/.../intermittent_electric...
The 2008 Chrysler Town & Country has 25 complaints for intermittent ... The horn,lights, wind shield wipers front and back going crazy could not shut off. .... I was Driving down the road and my van went crazy possessed! ... Electrical checks reveal nothing wrong with the electrical system, and there is power to the radio.

2003 Dodge Caravan ES Electrical Problem - Discussion on Topix

www.topix.com > Dodge Grand Caravan
Aug 7, 2011 - my van was running fine, shut it off, went in for half an hour then it would not ... or the electric doors. windows do and brake lights. heater stays on hot and i can only ... My horn wipers,power windows, radio,blower front and back, headlights, do not work. ... Chrysler Readies Next-Generation Town & Country.Missing: 2004

Thread: I lost almost all of my dash lights, instruments, and ...

forum.chryslerminivan.net/.../7261-I-lost-almost-all-of-my-dash-lights-i...

Jan 17, 2008 - 10 posts - ‎6 authors
I have a 2003 Town and Country mini-van and I lost power to all my ... In addition to this my wipers, headlight controls, blinker controls, power door locks, and A/C/heat controls are out as well. The odd thing is that the power windows work, the power sideview mirrors work, the radio and ceiling lights also work.

Dec 16, 2015 | 2004 Chrysler Town and Country

2 Answers

2006 town and country fan blows cold air all the time


Change the heating core. Sometimes dificult. Located under the dash.

Dec 31, 2012 | 2006 Chrysler Town & Country

1 Answer

The heat blows cold and hot. Is it the resistor module or the themostat


The resistor controls fan speed, not temp.
If the heat comes and goes, it could be the thermostat, or the radiator could be low on coolant, or have air pockets, or one of the blend doors may not be working correctly.
The blend doors direct air thru the heater core and the vents.

Dec 20, 2012 | 2003 Chrysler Town & Country

1 Answer

How to change the fan.i own a 2006 town an country chrysler van and the air conditioner works when the car is going but once I stop the tempature guage goes up to hot and the van will over heat causin


It should be a fairly simple R&R since the fan and shroud is bolted to the radiator support. Usually you take it out as an assembly.
If you haven't done so already, be sure and check the fuse and relay before condemning the cooling fan motor.

Jul 18, 2012 | 2006 Chrysler Town & Country

1 Answer

My front air does not blow out (it works in the back). I changed the blower relay in the fuse box next to the battery and put in a new blower fan under the glove box but it still does not blow air out in...


Have you replaced the blower motor resistor? It's located behind the passenger-side in-dash glove box. That's what allows you to control the fan speed.

Jul 12, 2010 | 2001 Chrysler Town & Country

1 Answer

2002 Chrysler Town and Country Rear Heat/Air only on High


most of the time the resistor is located downwind of the blower motor so it should be not to fao from the blower motor in the right rear of the van behind the quater trim panel which is the hvac unit is located

Jun 01, 2010 | 2002 Chrysler Town & Country

1 Answer

Fan does not blow in the front for air conditioner


most common problem on this vehicle is the blower motor resistor

less than $40 and only two screws to remove

May 08, 2010 | 2002 Chrysler Town & Country

1 Answer

2001 Town and Country has only high speed fan both front and back fans. Connector to fan has 12v only on one of the 6 leads. Grounding the lead with the 12v on it turns fan on high speed. Where is...


if the blower only blows on high then it is you blower motor resistor that is located behind the glove box it has two screws that hold it in place

Jun 19, 2009 | 2001 Chrysler Town & Country

1 Answer

Front vents will not work


If they are stuck on defrost,then the problem is a little vaccum line that comes through the firewall as all the climate controls are vaccum controlled,so look for a small green or black plastic line unhooked.

Dec 25, 2008 | 2005 Chrysler Town & Country

Not finding what you are looking for?
Cars & Trucks Logo

2,544 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

60792 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...